Parallels 4.0 won't quit when VM is shutdown

Discussion in 'Installation and Configuration' started by billfrech, Nov 12, 2008.

  1. billfrech

    billfrech

    Messages:
    2
    Yesterday I upgraded from version 3.0 to 4.0. In 3.0 when I would shut down a VM, Parallels would automatically quit and remove itself from the Leopard dock. I would like version 4.0 to do the same thing, but I cannot find an option for this. When I shut down my XP VM, the Virtual Machines directory window remains on the desktop and I have to manually quit the Parallels Desktop app to get the window to close and to have the dock icon disappear. I am sure I am missing something, but cannot figure out how to do this.

    Any help is greatly appreciated.

    Bill
     
  2. JDLandry@cox.net

    JDLandry@cox.net Bit Poster

    Messages:
    12
    Parallels Desktop 4.0 will not quit upon VM Exit.

    I have the same problem. When I shut down the VM, in Parallels 3.0, the application would also quit.

    Now when I shut down the VM, not only does the Parallels 4.0 application not quit, I actually have to force quit it each time in order to get it to close. Simply closing it by selecting "Quit" in the file menu does absolutely nothing.

    This is really disconcerting, and makes me question the stability of the program.

    Has anyone found a solution to this issue? Is Parallels aware of this problem?
     
  3. billfrech

    billfrech

    Messages:
    2
    Well I'm not having the problem to the extent that you are. When shutting down either my XP or Vista VM, the Virtual Machines directory window remains open. I can manually close the window and then quit Parallels using the Quit command from the menu. I just would like it to auto-Quit the way it did in 3.0. For me, this is more of an inconvenience than a true problem. I am assuming I am simply missing something.

    I do agree that the 4.0 version could have been more refined before release. The upgrade process for both of my machines was filled with issues. The lack of response to my issue from Parallels support has been less than satisfactory as well.

    After reading some other users' issues here, I guess I have to feel lucky that things went as well as they did. Sounds like it has been an absolute nightmare for some. I will still have to take a hard look at VM Fusion the next time I am forced to pay for an upgrade. Especially since the bulk of what is new in 4.0 was supposed to be released in a 3.0 upgrade that should have been free.

    Good luck with your stability issue. Let me know if you hear of a fix to our issue.

    Best,

    Bill
     
  4. spiffey

    spiffey

    Messages:
    12
    I had the same problem; it would only quit if I used the 'Quit' option by right-clicking on the dock icon - no other menus worked. In the end I was forced to downgrade to version 3 as the copy and paste functionality of Windows was completely disabled after installing version 4.

    I found this helped when I was running version 4 in enabling the menus to work (please remember that I'm now going from memory so I can't give exact paths to preferences):

    In the preferences there was a section which allowed you to specify what happens on startup and shutdown; this might be in the general preferences or (I think) in the VM configuration window. There is a pop-up option that says something like "do this on shutdown of VM". If you change that to "Do nothing" then I found that all the menus worked (though you still have to quit manually). However, if it's set to "close window" then I found that was when the menus stopped working. I was also left with a residual image of the Windows Shutdown screen which would progressively be removed by opening windows and suchlike.

    This doesn't solve the problem of quitting PD4 after the VM is shutdown, but I found it actually enabled me to use the command-Q shortcut or selecting 'quit' from the menu, without having to force quit the application. I hope it helps.
     
  5. funops

    funops

    Messages:
    9
    Has this issue been resolved?

    I just upgraded testing v4.xx and indeed the problem noted above whereby Parallels Desktop will not quit upon exiting the VM still persists. In v3 the program would quit, the dock icon would go away, etc. Not the case in this v4 and since it's now February with the original posting back in November, I guess it is not going to be addressed by Parallels or I am not finding a correct setting or combination of settings. It was convenient that the program would automatically close itself and go away when I no longer needed it open but rather than spend more time on trying settings and restarts, I'm simply curious if it is now normal behavior for Parallels to remain loaded when the VM is closed down.

    Thanx
     
  6. bwehr

    bwehr

    Messages:
    3
    I agree - it would be nice to hear something official. Since upgrading to 4.0 (both builds 3540 and 3810), I too have had to force quit Parallels after shutting down my VM. That doesn't instill a lot of confidence.

    Is there to be no official response to this issue?

    Thanks.
     
  7. Hexanet

    Hexanet Bit Poster

    Messages:
    1
    Still won't quit with Parallels 6

    The VM doesn't quit and it is almost freezing the machine with a 80% on the cpu.
    The application officially closes as far as MacOS X is concerned. (i.e no force quit is possible)
    But the Parallel VM process still runs and has to be forced quit from the activity monitor instead.

    I certainly won't be upgrading to 7 if this is not fixed.

    V6.0.12106.692267 here on Mac OS 10.6.8
     

Share This Page