Parallels 5 makes my Mac EXTREMELY slow

Discussion in 'Installation and Configuration' started by MichaelMyers, Dec 12, 2009.

  1. MichaelMyers

    MichaelMyers

    Messages:
    3
    As soon as it starts up, my Mac is UNBEARABLY slow. 2.4ghz Macbook with 4gb ram, Snow Leopard. Running Parallels 5 on a BootCamp partition with XP.

    After starting Parallels it takes 5 minutes (no joke) just to switch between any open apps, whether on the Mac or PC side.

    Can anyone help?
     
  2. Stephen109

    Stephen109

    Messages:
    7
    Mac Slow

    I'm having the same problem.
     
  3. Shaddam IV

    Shaddam IV

    Messages:
    626
    How much memory have you guys assigned to your VM's? How many VM's are you running concurrently?
     
  4. rheudabaga

    rheudabaga

    Messages:
    1
    open Activity Viewer (from utilities folder). Do you get a large number in the Page Outs report? 200mbytes or more? That's what I'm getting. Parallels bogs my machine down as well, and I believe that this signifies a memory leak. I can find nothing about it on the Parallels site, and trying to contact support has been a complicated joke. Very disappointed.
     
  5. Shaddam IV

    Shaddam IV

    Messages:
    626
    That's not a memory leak, it's the Mac's swap file. Try reducing the amount of memory you've assigned to Parallels to 1 GB or less, and optimize performance for OS X.
     
  6. Dieter

    Dieter

    Messages:
    2
    Even after quitting

    I'm having the same issue, but it persists after quitting Parallels.

    I mean, who's really surprised to see Mac OS's performance go down when running another operating system? But having this issue persist after closing the program?

    I mainly feel it with opening new windows and menus. There is a 2 second delay on every window and menu, unless I had opened it before (after quitting Parallels).

    What could that be? And how do I solve it?

    This is Parallels 5.0.9344.558741, using both Win XP and Win 7.
     
  7. Shaddam IV

    Shaddam IV

    Messages:
    626
    Again I suggest to lower the VM's memory requirements. If your VM uses so much memory that the Mac is thrashing (moving lots of memory to the swap file, and reading it back from there) then that behaviour will persist for a while after you've shut down the VM. I've learned that this is due to a not-quite-optimal implementation of virtual memory. I'm running a rather anemic Windows 7 VM on 864 GB since my Mac only has 2 GB overall; if I give the VM more memory (say, 1 GB) my Mac starts to really bog down and stays that way for 5-10 minutes even when I shut down the VM. When I run it with 864 MB everything's fine.
     
  8. Dieter

    Dieter

    Messages:
    2
    Thank you

    Thank you Shaddam IV, I will try that. I didn't know that about the virtual memory implementation Parallels seems to use.
     
  9. Shaddam IV

    Shaddam IV

    Messages:
    626
    The virtual memory implementation is not one done by Parallels but rather by Apple in the Mac OS; Parallels is just using it. That's what seems to be not-quite-optimal.
     
  10. djmac

    djmac

    Messages:
    2
    So what was the outcome? plan on installing windows 7 myself.
     
  11. Donald B.

    Donald B.

    Messages:
    4
    Leopard , Snow Leopard and PD 5

    Hello Shadam,

    I just stumbled accross this thread where I see another variation of the same problem tha I mentioned before,

    Shutting my mbp takes at least two minutes with PD 5. This problem started with an update to 10.5.8, and has not gotten better with 10.6 10.6.3 or 10.6.3. v1.1. The only solution that I have come up with as of yet is to de-instal. run my MAN scripts repair my permissions, and he only reinstall when I am giving a lecture or supervision where I absolutely need a windows platform to display a program that does not exist for the macintosh world.

    In the mean time another problem has turned up, since the last instalation i cannot go put my mbp to sleep without waiting for five minutes, very embarassing when it happens during a lecture at a medical congress and then again in the workshop series that followed. What ever was changed and or affected was changed deeply in the system and seems to affect other aspects of 10.6.3.

    I have already, as you sugested to me, changed the VM no change I have done a complete clean installation and had to reinstall 380 Gigs of Data Pictures, patient reports, Xrays files and programs. no change.

    I have not given up hope that a solution exist. I only wish it would come soon.
     
  12. Shaddam IV

    Shaddam IV

    Messages:
    626
    Hi Donald,

    as far as I understand Parallels is creating a file at runtime that contains pretty much the memory of the VM, i.e. its current state. It updates that file every once in a while to reflect the current memory's state. The main purpose of that file is that when you put the VM (or the Mac) to sleep, it can relatively quickly flush its memory to disk. However, the more memory you assign to the VM, the larger that file is, and the more data the Mac will have to write to disk before it can go to sleep.

    I've found that Parallels - and Fusion, too, for that matter - don't interact that terribly well with the Mac's virtual memory. That means that any disk operation that has to do with the VM - accessing the VM's virtual memory, or flushing memory to disk in preparation for sleep - may clash with the Mac trying to swap. From what I read here this seems to be relatively independent of the physical memory installed in a Mac; when the VM exceeds a certain size, the Mac starts swapping and the VM become slow. (People here who have 16 Gig in their machines, only 4 or so of which are assigned to the VM, have been complainging about slowdowns.)

    What happens if you try to set your VM to sleep manually before you close your Mac's lid? I.e. use the "sleep" feature from the VM menu. Is putting the VM to sleep manually also slow? And what about the Mac's speed-to-sleep after you've put the VM to sleep?

    I've reduced my Windows 7 VM size to 768 MB which is sufficient (just about) for day-to-day work, and sleeping isn't an issue here. When I had the VM at > 1 GB it certainly was an issue.

    Good luck!
     
  13. Donald B.

    Donald B.

    Messages:
    4
    hello Shaddam IV sorry tha I spelled your name incorrectly. Thanks for the info, but my problem remains. I finally removed Parallels from my computer, and am awaiting another solution. immediately after I removed it the shutdown time became normal but the sleep function still takes1 1/2 to 2 minutes.

    Still looking and hoping donald
     
  14. Chilbear

    Chilbear

    Messages:
    13
    I agree with the above post after my upgrade from V3 to V5. You need to push down the ram asked for (default was 2gb when installed and set to AUTO) and/or increase the ram on your machine. I installed XP not W7 and it runs fine for what I need it for but the other thing I tripped over was a setting for priority and the default was for the Virtual to get priority and I switched this to the Mac OS. It seems the base install of V5 will allow gamers perhaps to get up and running but unless you have maximum ram installed on the Mac you will be choking based on the default install.
     
  15. aaronr

    aaronr

    Messages:
    1
    What if I can't change my virtual memory?

    I have these same problems with Parallells 5 running VERY SLOW and bogging down my whole Macbook. I can't change virtual memory on my Mac (it's 2 years old, now running the latest Snow Leopard OS).

    Any suggestions?
     
  16. AndrewAbram

    AndrewAbram

    Messages:
    1
    More RAM is the cure

    I have been suffering in the same way and just upgraded to 4Gig of ram from 2, and that did the trick. Everything runs faster, MAC environment and Parallels. Also adjusted config to have 1 processor, 1024 MB RAM allocated to Parallels and Enabled Adpative Hypervisor under Options > Optimisation.

    All worked a treat.
     
  17. Hello just want to ask what is the appropriate memory assigned to VM's?[​IMG]
     

Share This Page