Parallels 5: Slow performance

Discussion in 'Installation and Configuration' started by drumz311, Nov 25, 2009.

  1. drumz311

    drumz311

    Messages:
    1
    I just upgraded from Parallels 3 to 5. I never had this problem with ver3 but when I start using Parallels and Windows applications my whole computer slows down and drags. Any suggestions? Can I change the memory settings to help this issue? I am using a Mac Book Pro 10.6.2 with a 2.4 GHz Intel Core 2 Duo Processor 3Gb 667 Mhz DDR2 SDRAM Memory.
     
  2. MichaelMyers

    MichaelMyers

    Messages:
    3
    same issue, similar setup

    Same issue. It's not workable. Same setup but with 4gb ram.
     
  3. Ephra

    Ephra

    Messages:
    81
    Same here. iMac 10.6.2 - 2.4 GHz Intel Core 2 Du0, 3Gb 667 MHz DDR2 SDARAM
    I did a clean/full install of PD5, not an upgrade. I have two VM's, one XPpro and one W7.
     
  4. Alan010

    Alan010

    Messages:
    2
    Don't hold your breath people, there's a few 'slow performance' threads on here .
     
  5. jvolk

    jvolk Bit Poster

    Messages:
    11
    So, how was it, that Parallels was able to claim 300% speed improvement over previous versions? I found that PD5 never worked on any of my XP virtual machines. I'm glad that I got a reasonable upgrade price.
     
  6. DaneCC

    DaneCC

    Messages:
    14
    Installed new version after removing the 5.0 and using nothing for the last week until today when I tried 5.0.9308. Works great got an error message that has never ever been resolved based on this forum. Unable to launch prl_disp_service and I have to wait forever for that message to show up. Right now I am thinking of removing boot camp too becuase I am completey frustrated. First it was the magic mouse and keyboard that does not work properly in bootcamp and then disconnects when I return to snow lepoard. Now I can only get into windows with the keyboard. I have to find other applications for some of the things I do. This no longer cuts it for me.
     
  7. PatrickJ

    PatrickJ Bit Poster

    Messages:
    94
    Some tips...

    PD5 is pretty damn fast but you have to treat each VM like it's own hardware install. The less resource sharing you can get away with the better your computer will perform.

    1. Get more ram. I assign 3GB to my Windows VM. Plenty for OSX left (5GB), plenty for Windows. Unless you are hitting 2+ Windows you're still going to deal with thrash/swap during normal usage. As you've got a 3GB total Mac, you just don't have enough to satisfy both OSX and Windows requirements. Ideally, get 4GB and give 2 to each OS.

    2. Keep your VMs on a separate physical drive. If you're reading/writing something in OSX and your drive is capable of a 50MB/sec transfer rate, great you're traveling at 50MB/sec. Now if you're going to start doing something in Windows also disk intensive, you're now (more or less) halving your possible disk speed.

    3. Give your windows 1 core. OSX is pretty smart and will see that one core (the windows one) is working more than the other and do most of it's work on the less tasked one balancing out the load. If you give both cores to windows, you're now at the mercy of 2 different schedulers effectively trying to fight each other.


    My system.. 4 CPUs -2 go to Win VM, 8GB ram - 3GB for Win VM. I also run Windows on it's own 320GB drive (sata, but USB or Firewire work fine). The GUI can still feel occasionally slow, but the video card is really the only device that has to be shared between the two systems. Everything else is as compartmentalized as possible.

    I do a lot of media work and my rendering/compiling times are pretty close to what I was getting under Bootcamp.
     
  8. DaneCC

    DaneCC

    Messages:
    14
    Hi Patrick,

    Sounds like you are using a mac pro tower. I have the imac released in 2008, but I was wonder if a separate 50GB partition would have more effect on the pvm. I would create the pvm and save in the new partition, right now I am reinstalling winxp.
     
  9. PatrickJ

    PatrickJ Bit Poster

    Messages:
    94
    Hey 2008 MPro yeah. Go ahead give it a try.. might be a bit faster if for no other reason having a dedicated partition will eliminate a lot of random reads due to a fragmented main partition.

    Good luck!
     
  10. DaneCC

    DaneCC

    Messages:
    14
    Works well especially after I removed the boot camp partiition. But allocating 2GB leaves me too little for running it in crystal or coherence mode. I like to run winxp apps side by side with lepoard. I still see one problem and that is consistent. Paralells slows down my mac at boot up. I am not certain why that is but I have always noticed it.
     
  11. H. BurkeJ

    H. BurkeJ

    Messages:
    1
    PD5 Nightmare Slowness, Reinstalled PD4 Happy Again

    I spent all the time since the PD5 reading all the posts and tweaking my settings to try to make PD5 even functional it was so slow; 10 minute startup/shutdowns, Windows so slow I couldn't type an email. After the latest PD5 9308 Build that seemed to make things worse with the below error messages I finally just uninstalled PD5 and reinstalled PD4 per the guidance from Parallels and am happy again. PD4 went right back on with the settings I had when I had uninstalled so it was all perfectly tweaked again. Below are my specs & problems IDs I submitted along the way. It would take so long to do a Problem Report I even gave up doing those. I hope those of us who paid for a PD5 upgrade get the next upgrade for free considering the vast amount of problems reported. I will try PD5 again when my Windows 7 upgrade arrives.

    MacBook Pro 17" 5,2; Intel Core 2 Duo 3.06 GHz; 4 GB; 500GB; v10.6.2
    VM: Windows Vista Home Premium
    PD5 Problem IDs: 1156261, 1163184, 1742453

    Setting this memory amount may slow down the performance of your running virtual machines.

    Your running virtual machines are consuming more memory together than the total amount you are allocating. Increase this amount or shut down or suspend some of your running virtual machines.
     
  12. sryan

    sryan

    Messages:
    5
    Solution to my slow performance

    Uninstall Kaperski. Completely solved all performance problems.
    My machine was taking hours to sync with outlook exchange.
    Hope it works for you..
     
  13. PatL

    PatL

    Messages:
    10
    I've never had Kapersky installed and I'm experiencing the slowness issues described by other users after upgrading from v4 to v5 with Windows XP. Macbook Pro with 2gb Ram.
     
  14. NeptuneNancy

    NeptuneNancy

    Messages:
    8
    I don't have Kapersky installed, and since I upgraded to Parallels 5.0, my VM is unusable, it's so slow. It takes minutes before it responds to a keystroke. (not to mention at least a half on hour or more for Windows to boot up.)

    I have a 17" MacBook Pro, 2GB RAM, running 10.6.2 and WinXP. I've been running Parallels for years, version 4.0 before the upgrade. It was a little slow after upgrading to Snow Leopard, so I thought perhaps 5.0 would be a better fit/optimized for 10.6.2.

    Guess I was wrong....
     

Share This Page