Parallels 6 Audio Issues

Discussion in 'Installation and Configuration' started by Doug Cooper, Sep 17, 2010.

  1. Doug Cooper

    Doug Cooper Bit Poster

    Messages:
    6
    I find that all went fine upgrading from P-5 to P-6, but when I watch a video...any video...the audio is now a couple of seconds delayed. The lip sync is incredibly off. The same video works just fine on the Mac side as it did on the PC side when I used P-5. I notice the audio drivers are now labeled Parallels -- is there any settings I can change to fix this apparent delay? Very frustrating. Reinstall tools? Help. Anyone else experiencing this?

    Doug
     
  2. chienlim

    chienlim Bit Poster

    Messages:
    15
    I have the same issue too

    I found out that if you disconnect and connect back the sound devices from the Parallels\Devices\Sound menu, the lagging is gone. This always work in Chrome but not in IE 9 Beta. However, after couple of video playback the lagging will return and you have to disconnect and connect back the sound devices again.

    Try it!
     
    Last edited: Sep 18, 2010
  3. chienlim

    chienlim Bit Poster

    Messages:
    15
    I found out that if you disconnect and connect back the sound devices from the Parallels\Devices\Sound menu, the lagging is gone. This always work in Chrome but not in IE 9 Beta. However, after couple of video playback the lagging will return and you have to disconnect and connect back the sound devices again.

    Try it!
     
  4. chienlim

    chienlim Bit Poster

    Messages:
    15
    I did these steps, and it seem to help
    Method #1
    1) Goto to "Device Manage"r in Windows 7
    2) In "Device Manager", select "Sound, Video and game controllers"
    3) Right click on "Parallels Audio Controller (x64)"
    4) Select "Uninstall" (DO NOT DELETE DRIVER when prompt)
    5) Then Goto "Action" and "Scan for hardware changes"
    6) New sound card will be detected and driver will be re-install

    Method #2
    1) Regenerate the Windows Experience Index.

    The problems is gone when playing video in Media Player. Chrome is working fine. IE 9 beta is still not too stable.
     
  5. Pineapple1

    Pineapple1

    Messages:
    2
    This is obviously an issue... I am using a Windows 7 machine and playing battlefield 2... audio is 2-3 seconds behind gameplay. Tried the solutions here to no avail.

    Incidently the VM and sound worked fine under parallels 5
     
  6. joevt

    joevt Kilo Poster

    Messages:
    1,202
    Does changing the Channels from Auto to Stereo Sound help in the virtual machine configuration?
     
  7. Pineapple1

    Pineapple1

    Messages:
    2
    tries that, no go unforuntely. The sound is in sync for a short while but doesnt last long. Any word from Parallels on this?
     
  8. chienlim

    chienlim Bit Poster

    Messages:
    15
    Parallels Tech Support

    I still have the sound lagging problem, so I contacted the online tech support and I got back with this to try:
    You contacted us regarding that the audio is not in sync with the video.

    Please follow the instructions mentioned below which would help us in resolving the issue.

    1. Start Windows.
    2. Click on Start --> Control Panel --> Programs --> Programs and features.
    3. If you have any Antivirus program installed please uninstall it and also uninstall Parallels Tools.
    4. Quit Parallels Desktop completely.
    5. Click on the link and download Parallels Desktop latest build 6.0.11822.
    http://www.parallels.com/products/desktop/download/dr/
    6. Open the downloaded .dmg file and click on uninstall.
    7. Follow the instructions and uninstall Parallels Desktop.
    8. Once the uninstallation is completed, Open Finder --> Applications --> Utilities --> Disk Utility.
    9. In Disk Utility window select Mac HD and click on "Repair Disk Permissions".
    10. Open the downloaded .dmg file and click on install.
    11. Follow the instructions and proceed with the installation.
    12. launch Parallels Desktop and start Windows.
    13. On the top menu bar Click on Virtual Machine --> Install Parallels Tools.
    14. Parallels Tools installation wizard will open, Proceed with the installation.

    Please check the status and if still not resolved then follow the instructions mentioned below.
    1. Restart Parallels Desktop (Do not start the Virtual Machine).
    2. Right click on the Parallels Desktop icon on the dock and choose "Virtual Machine list".
    3. Virtual Machine list Window will open, Right click on the VM name and choose "Configure".
    4. In Configure window choose Hardware --> Video. Increase the video memory to 256 MB.
    5. Start Windows and check the status.

    After the above experiment, The audio lagging issue is still there! I never have this problem with Parallels 5.0, how can I downgrade to Parallels 5.0?
     
  9. StefanoDiPersio

    StefanoDiPersio

    Messages:
    1
    Same problem

    Hi to all, I've the same problem. Sync between audio and video completely off in Parallels Desktop 6 while it works perfectly on version 5.
     
  10. Peter Keenan

    Peter Keenan

    Messages:
    2
    Yes, this is also happening to me. I am spending an inordinate amount of time trying to sort this out, with no result yet. In fact, I am getting no audio at all.
     
  11. chienlim

    chienlim Bit Poster

    Messages:
    15
    This problem happens on my iMac Intel Core 2 Duo 2.4Ghz model running Mac OSX 10.6.4, guest OS is Windows 7 64-bit. What system are you guy using?
     
  12. Peter Keenan

    Peter Keenan

    Messages:
    2
    I am using at 2.66 GHZ Intel Core i7, with Windows 7 (x32).

    The message I get when I try to install/update the audio drive is:-
    "Parallels Audio Controller (x32) has a driver problem. Not Fixed."

    With email tech support from Parallels I have been through 5 different types of actions, including deleting Parallels from Programs in Windows and re-installing, Deleting and Updating the Sound Driver through the Devise Manager, all to no avail.


    Any more ideas I would be grateful from the bottom of my core processor.
     
  13. chienlim

    chienlim Bit Poster

    Messages:
    15
  14. chienlim

    chienlim Bit Poster

    Messages:
    15
    Check this out: http://forum.parallels.com/showthread.php?t=104459
    Particularly interesting comment from Parallels -
    This may help to prevent buffer underrun.
    set boot flag (VM configuration -> Hardware -> Boot Order -> Boot flags):
    "devices.audio.playback.latency = 100", default value is only 10 (milliseconds)
     
  15. skechers

    skechers

    Messages:
    6
  16. chienlim

    chienlim Bit Poster

    Messages:
    15
    This problem is resolved in the latest build of Parallels 6.0.11828.
     
  17. lnemo

    lnemo

    Messages:
    114
    Not resolved for me ... lagging is still there with XP SP 3 as guest. It's better (happens not every time and the lag ist smaller than before), still there.
     
  18. lnemo

    lnemo

    Messages:
    114
    After experimenting a litte bit, I can confirm the following:

    The Problems arise first time a given sound ist played (example the Windows startup sound - you can hear the second half of it only, if at all).

    Is a sound played repeatedly, there are no problems at least from the third time on (example a screenshot software that produces a 'clicking' noise when the screenshot is done - first time you hear no sound at all, second time maybe so, but maybe you hear something a little bit 'garbled', from third time the sound comes where expected).
     
  19. SongC

    SongC

    Messages:
    3
    I think I have a worse problem. I couldn't even hear "Start Navigation" sound in any case.
     
  20. macspectrum

    macspectrum Bit Poster

    Messages:
    3
    FIXED ! audio after installing win7 ultimate - parallels 6

    MacBook Pro 2.66 c2d
    10.6.7
    parallels 6.0.11994

    the sound icon in win7 doesn't see any audio hardware

    then,
    I installed Parallels Tools and 'voila'
    sound is now ON
     

Share This Page