Parallels 6 -- Parallels Tools failing to install

Discussion in 'Installation and Configuration of Parallels Desktop' started by GeoffreyC, Sep 9, 2010.

  1. weareinto

    weareinto Bit poster


    I downloaded the SP3 files from

    I kept getting an error about "ksuser.dll"

    The best way to figure this out is to use the search tool in XP.
    If you mess up any of these steps it will pop up an error message and reboot.


    1) Begin the install process
    2) "ksuser.dll" will be an issue
    3) "Browse" to C: > WINDOWS > system32
    4) Click "Open"
    5) Click "OK"
    6) A "Copy Error" will pop up (who knows what this is!?)

    - - NOTE the screenshots show a different file name, because trying to take them screwed up the process a little, although it should not affect your results - -

    7) "Browse" to C: > WINDOWS > system32 > drivers
    8) Click "Open"
    9) Click "Retry"
    10) Install succeeds
  2. kgb

    kgb Bit poster

    This Works!

    The following post worked for me. I am running Windows XP SP3 on a Parallels Desktop for Mac 6.0. This was an upgrade and my Windows OS was working just fine under 5.0. I tried the solutions in the Parallels KB, and those were a waste of time.

  3. TrevorL

    TrevorL Bit poster

    Parallels Tools is failing to install as well for me...but for different reasons :-/

    I just upgraded to Parallels Desktop 6 from 5 today. I'm running Windows 7 on a Mac with it. I uninstalled Tools and McAfee like the instructions told me. I upgraded, and found that my shared folders weren't working. I tried to reinstall Tools, but the installer gets about halfway and throws the following error: "Error 2738.Could not access VBScript run time for custom action." and then "An error occurred while trying to install Parallels Tools. Press Ok to have your computer to restart and you can try to install Parallels Tools again."

    The funny part about this is that it says Tools is installed, except Tools doesn't show up under Add/Remove Programs. The folders are there, but they appear to be log files; nothing vital.

    tl;dr I can't access /psf and Tools says it's installed, but lies to me.
    Last edited: Oct 11, 2010
  4. skechers

    skechers Bit poster

  5. Paul Rieger

    Paul Rieger Bit poster

    Desktop 6 - Tools won't upgrage - error 2738 - vbscript.dll

    Under Parallels Desktop 6 for Mac, Parallels Tools will not upgrade on Windows 7 Pro. During Parallels Tools upgrade installation, I get an error "Error 2738.Could not access VBScript run time for custom action."

    The problem was caused by the free, Parallels-supplied Kaspersky Internet Security 2011, which was causing Blue Screen of Death Windows 7 shutdowns. I uninstalled Kaspersky, but the uninstall did not complete properly. It left an entry in the Control Panel Programs and Features section. When I try to right-click on it (Uninstall/Change), I get the error "This action is only valid for products that are currently installed." Searching the windows registry using regedt32, I find a number of leftover Kaspersky turds. I didn't remove any of the leftover Kaspersky turds from the registry.

    It turns out that the Kaspersky uninstallation left a bad path in the registry:
    pointing to a non-existant dll (the whole Kaspersky directory was removed from Program Files during the Kaspersky uninstallation -
    Default -- REG_SZ -- C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2011\scrchpg.dll

    So, when Parallels Tools was trying to upgrade itself, it couldn't find vbscript.dll.

    Fix the path to the vbscript.dll in the registry.
    Open (as administrator) a cmd window. Run regedt32. Navigate to:
    Right-click on InprocServer32 and edit the permissions to give yourself FULL CONTROL.
    Edit the Default string to point to the REAL vbscript.dll in C:\Windows\System32\vbscript.dll
    Again, right-click on InprocServer32 and edit the permissions - UNCHECK the FULL CONTROL permission you gave yourself.
    Close the registry editor window. I always reboot after editing the registry.
    After the reboot, Parallels Tools will automatically upgrade itself - this time, successfully.

    Fix the registry to point to vbscript.dll
    Default -- REG_SZ -- C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2011\scrchpg.dll
    Default -- REG_SZ -- C:\Windows\System32\vbscript.dll

    Helpful link (thanks, Kevin... sanity is MUCH better!) :
  6. summitscout

    summitscout Hunter

    Keep trying!

    From experience, the best advice I can give you is to keep trying to install PT until it does install. It may take 5-6 times. Yes, a PITA, I know.
  7. BryceW

    BryceW Bit poster

    BSOD Issues

    It is really a shame that there are 4 pages of threads trying to correct a issue that after 3 updates has still not been corrected.

    I am very confused as to where the Parallels support team is in resolving this issue. I am sorry to just post a complaint but I did not purchase this upgrade to constantly be on this forum hoping to find a resolve these constant BSOD I am getting based on the beta version release of software that I am sure Parallels is seem a nice cash flow surge from.
  8. johndoe

    johndoe Member

    i've had the problems being unable to install the tools now with Parallels 6.0 .

    after the upgrade, when starting XP, i get dialogs with the message: "Windows could not install driver for mouse/keyboard/volume. Contact your hardware driver for assistance."

    i try running the "Install Parallels Tools…" menu-item, and it causes me to force start Setup.exe from D: .

    from there, i get multiple (4 times during one install) : "Windows could not install driver for mouse. Contact your hardware driver for assistance."


    it then tells me there's a failure installing the parallels mouse driver:


    after that, it tells me it's rolling back the Parallels Tools install


    and then it presents me with a dialog that the installation was interrupted, and that i need to restart and try again.


    i've tried the restart trick twice without success.

    Attached Files:

  9. johndoe

    johndoe Member

    what exactly do you do in order to "turn off the ESET" ?

Share This Page