Parallels 8 and Windows 7

Discussion in 'Installation and Configuration' started by wycliffe, Aug 30, 2012.

  1. wycliffe

    wycliffe

    Messages:
    83
    I foolishly did it again - downloaded a Parallels update without reading the forums here - shame on me.

    I choose to operate my MBP Retina Display in the setting with maximum resolution (more space). Unfortunately, that means the resolution on my Windows 7 is 3840x2244 and everything is so small I need a magnifying glass. How do I fix this? It has rendered my Windows unusable.
     
  2. juzci

    juzci Guest

    Hi,
    could you please check "Optimize Windows for full resolution" in VM configuration-Hardware-Video section? Is it on or off? If it's off, make it on.

    Regards,
    Hanna
     
  3. wycliffe

    wycliffe

    Messages:
    83
    It is on - and there is no change to the resolution. Still is microscopic and I cannot change the resolution on the VM.
     
  4. SithaN

    SithaN

    Messages:
    2
    Having the same issue as well after upgrading to Parallels 8 and using MBP with Retina Display. Also seems that now when I use CMD TAB, it opens up the Windows Start Menu when going from a Windows APP back to a Mac APP. Never did this before in Parallels 7.
     
  5. wycliffe

    wycliffe

    Messages:
    83
    This is terribly disappointing that there has been no response or help to this issue. I am now also noticing that on some Windows programs in the command boxes that several sub-boxes such as Save, Cancel, etc. do not show up.

    Come on Parallels - do paying customers deserve this?
     
  6. juzci

    juzci Guest

    We are working on it actually. Could you please reproduce the issue, send us Problem Report as described in http://kb.parallels.com/en/9058 and give me an ID?

    Thanks in advance,
    Hanna
     
  7. quinnt01

    quinnt01

    Messages:
    12
    I have same problem with small fonts, and Windows resolution is optimized.
     
  8. juzci

    juzci Guest

    Well, you can uncheck the "Optimize" checkbox and set DPI manually - to do it right-click on Windows desktop, choose Screen resolution-Make text and other items larger or smaller and change font size.
     
  9. SithaN

    SithaN

    Messages:
    2
    Unchecking the optimize and then setting the Windows DPI doesn't work completely. The fonts inside an application still shows up small. With the font issue and the windows start menu popping up everytime you switch from a windows app to a mac app when CMD TAB did it for me. I uninstalled 8 and went back to 7.

    My workstation setup consists of 3 monitors. The MBP laptop display is set to have Resolution: Scaled => More Space, instead of the default "Best for Retina Display". My monitors, ASUS VS248, are set to "Best for display". I have tried with both the Optimize for Windows checked and unchecked to no avail.
     
  10. danieltharris

    danieltharris

    Messages:
    87
    If you have your MBPr to the higher scaled resolutions it will appear as 3840x2244 in Windows.

    I know this doesn't answer your question, but if you are using a scaled resolution at the moment it could be worth changing back to "Best" for retina for now and see if that helps?
     
  11. danieltharris

    danieltharris

    Messages:
    87
    This doesn't fix the issues mentioned above, but (You probably already realise this but for others who may not)...

    Using the retina and external displays at the same time in Windows will not be likely to lead to a pleasant experience.

    You can only set DPI at the user level, and it applies across all screens connected. You can't set DPI on a per screen basis.

    This will obviously lead to things having to be either too big on the external displays or too small on the retina.

    Unless there is something Parallels can do, this is how it will always be. Unless MS were to enable different DPI settings on each monitor, which would be difficult at the moment i'd imagine.

    I've resorted to turning off the PD8 setting to optimise for full resolution when working at my desk, and just using my two external monitors which don't require an increase DPI setting in windows.

    When using my MBPr on it's own I have to re-enable the option, which increases the DPI in windows. It does mean having a 2 display setup instead of 3 for now.
     
  12. wycliffe

    wycliffe

    Messages:
    83
    Exact issue I am having as well. The VM simply replicates the resolution of the screen that it is on. VM is somewhat useable for me in my two screen configuration if I move it onto the second monitor, a 24 inch Apple cinema display. But this is not how I use my VM - I have everything set up - due to various resolution needs such that my VM is used on the MBP RD, and it is defaulting the resolution to 3840x2244 which is unreadable except by a superhero.

    What is the expected resolution (no pun intended) to this issue and when?
     
  13. KapnKrunch

    KapnKrunch

    Messages:
    1
    I have the exact same problem with the Start Menu popping up when switching between OS X and Windows 7 in Coherence mode. Did NOT occur with Parallels 7. Quite annoying.
     
  14. Efraser

    Efraser

    Messages:
    1
    I am having the same exact issue, upgraded to 8 this morning(was working just fine in 7...) and now sql server management studio has really tiny font and icons...
     
  15. serv

    serv Parallels Developers

    Messages:
    797
    Retina resolution can be disabled for a VM here: VM Configuration > Hardware > Video > Enable full resolution.
     
  16. Seridamai

    Seridamai

    Messages:
    1
    I was one of those who immediately purchased an upgrade and usually ran into problems because of bugs. I am still as foolish as ever but a little wiser in that I did not install the upgrade at once.

    Thank you guys for sharing your experiences and advice but no thanks to Parallels for releasing a product before it got rid of the bugs.
     
  17. WalterW

    WalterW Bit Poster

    Messages:
    5
    I too was excited to hear of the new version 8. Like so many of you I rushed to purchase and install. My Macbook Pro was immediately rendered unusable. It became to slow I could not even use the Mac muchless the VM machine. Lucky for me I had just purchased a Time Machine Backup and had a good backup to go back to. I ended up doing a complete Mac restore just to get my Mac back to usability. I'm sure that Parallels will eventually work out the bugs, but I didn't pay for a Beta Upgrade. If Parallels wants beta testers please ask the community in the forums I'm sure you will get alot of people interested in testing for you. If this version was beta tested you should immediately FIRE ALL your beta testers and start fresh with one's who will actually test and provide feedback. Like so many of you I'm very disappointed with purchasing a product that is not usable at all! I have purchased both Parallels and VMWare and Liked Parallels speed and performance better, but if the problems are not resolved soon I might actually upgrade of VMWare License to V5 and try it again. The single most important suggestion I can give everyone in the community is before you install this upgrade, make sure you have a Time Machine Backup so you can do a complete restore...just in case...
     
  18. wycliffe

    wycliffe

    Messages:
    83
    I am still amazed that this version 8 was released without better testing.

    I am unable to use P8 as it makes every one of my Windows programs so small that I cannot use them.
     
  19. Bruce Carillon

    Bruce Carillon Bit Poster

    Messages:
    41
    I have the same issue and am very disappointed in this new "improved" release! I'm going to check out VMWare Fusion and see how it handles things. My VM is unusable once I leave the desktop and launch an app since it renders everything way too small.
     
  20. wycliffe

    wycliffe

    Messages:
    83
    I dialed into the Parallels support line and was able to get someone to work with me to improve my issue.

    A few things - under View, make sure you do not have Use MacLook enabled.

    Under Virtual Machine/Configure/Hardware/Video - make sure you have Retina Display unchecked.

    See if that helps you.
     

Share This Page