Parallels 9 "Human Interface Devices" constant device disconnect/rediscovery

Discussion in 'Windows Guest OS Discussion' started by MrT0ad, Aug 29, 2013.

  1. Priller

    Priller Bit Poster

    Messages:
    7
    This release has been handled horribly. If you go the the Parallels Desktop product page, the current version is 8. If you follow through to the Parallels Desktop upgrade page, the upgrade offered is to version 8. The only place version 9 appears is on the blog and the email current customers received. So, we effectively paid to be Release Candidate testers. This is without doubt a Show Stopper bug that is in-your-face the second you boot Windows, it's not a corner case bug. This should have never been released. I think everybody that paid for a version 9 upgrade should get some kind of good faith credit back from Parallels.
     
  2. dgerber

    dgerber

    Messages:
    2
    I completely agree!!!
    Same issue after my upgrade to PD9.
    And after applying the "workaround" my whole VM crashed like I never experienced in PD7 or PD8.
    I had to go back to an older Snapshot.
    Now it seems to work with PD9 - I hope my VM stays stable...
    Despreadly waiting for update!!!
     
  3. pommis

    pommis Bit Poster

    Messages:
    24
    I would bee happy from some compensation.Payed the software and still have to use Pd8
     
  4. Wolfje

    Wolfje

    Messages:
    2
    Basically. It's unfortunate that somewhere along the line people started paying for unstable boxed-product software, and somewhere along the line people started accepting faulty products on release as it's something that has just become synonymous with the release of new software. Have a look at how many people publish software that simply just doesn't work at launch and yet we all find out after paying the money and the worst thing that happens to them is a couple of angry threads on a forum, some bad tech PR and then it all somehow becomes okay again.

    Bugs happen, I get it. But how did this slip through the cracks? Did any of the RQ engineers even test Windows as a guest at all? Surely that Windows guests would warrant enough of a usage customer base that it deserved to be installed and tested.

    I happen to be a mobile developer and this basically means I can't connect EHCI devices to my guests. Sadly I'm just not going to risk the upgrade on my development environment, and I'm not going to buy further versions of Parallels Desktop unless there is sufficient proof that it actually works. I am thinking about requesting a chargeback, perhaps VMWare has better QC.

    Cheers
     
  5. lukejr

    lukejr

    Messages:
    6
    I fully agree. I am experiencing ongoing issues with my VM and Parallels 9. Windows Explorer now crashes almost every time I start Explorer, I have to disabled shared folders/mapped drives, which honestly is a huge draw back. I don't like being asked to pay for a product that is still in testing.
     
  6. djam100

    djam100

    Messages:
    1
    This is a pretty poor effort how could you miss something so rudimentary with such a small host OS platform
    Really disappointing Parallels
     
  7. MarcoDalli

    MarcoDalli

    Messages:
    1
    Report #1717463 submitted. I noticed this thread too late though, but the suggested tip worked fine. Now I really hope to see a solution to this really soon.
    Marco
     
  8. WrightA

    WrightA Bit Poster

    Messages:
    6
    I bought upgrade from V8 to V9 yesterday but decided to check the forums before upgrading. Had too many previous issues with "bleading edge" software releases. I won't be applying this upgrade any time soon! Parallels need to get this fixed pronto and should have done a much better job of Alpha & Beta testing. Maybe that's what they consider an "upgrade offer" to existing customers!!?
     
  9. ItzikK

    ItzikK

    Messages:
    1
    Hi

    I have the same issue along with performance issues. very disappointing.
    don't upgrade unless you want to pay to join Paralles "QA team" i am sure you will do a better job

    disappointed customer
     
  10. Theradur

    Theradur

    Messages:
    1
    Parallels seems to be a piece of sh***. Is there any way that i can get my money back? Got the same problem with my Plugwise USB-Stick, so its not possible to control my Plugwise network anymore. I did not have the problem with V8.
     
  11. Gary Kellogg

    Gary Kellogg Bit Poster

    Messages:
    36
    I have just tried the standard refund request route offered by the vendor (cleverbridge) through which I bought the software. I suspect it will work. If enough people try this then I think we'll get what we want and deserve and Parallels will get the message. Stupid of me to jump on this rather than wait for three or more updates which is what I usually do!
     
  12. SWANDY

    SWANDY Kilo Poster

    Messages:
    308
    Would certainly not consider Parallels a "piece of sh**" though I am a bit surprised with the problems people are experiencing. But - consider how many people probably use the program compared to the number posting here, the problem might not be as wide-spread as we think. Not to make light of the users having issues - glad I did not upgrade yet, will wait until the problems are ironed out.
     
  13. mikeruoc

    mikeruoc Bit Poster

    Messages:
    20
    I have to say I really thought this would be fixed by now. Considering the problem was introduced in the release and not in any of the beta's it does seem like it would fixed quickly. The other way I look at is 3 strikes you are out.

    Strike 1. The fact you make a change like this for release and not in beta seems like a really bad idea.
    Strike 2. How you handle it. Everyone makes mistakes so the next part is how you handle it. They did post the work around which was good but we are now 4 days later and no update or information on when we might have one. Handled poorly.
    Strike 3. V8 had major issues on launch.

    I think when Fusion updates I will be giving them my money each year.
     
    Last edited: Sep 3, 2013
  14. Jacket06

    Jacket06 Bit Poster

    Messages:
    3
    Same problem here with Win7 VM. I followed the boot flags suggestion and this stopped the connect/disconnect, however Windows will now not recognize a Fat32-formatted USB flash drive when inserted. The underlying USB driver seems to see that something was inserted, then puts up a message that it would work better in a USB 2 port. The device never shows up in the drives list under "My Computer".

    If I insert it as a Mac device, it does show up as as drive letter bridged from the Mac.

    Is anyone else seeing this behavior?

    Thanks,

    Jack
     
  15. Seadoodude

    Seadoodude

    Messages:
    8
    Same problem here, rMBP, Win7, continual device reconnects and increased CPU usage. I had to revert to bootcamp at work. Going back to v8 until things stabilize. For what it's worth to those contemplating Fusion. I have both and in most all benchmarks and usage, integration with host, PD8 wins out. I'll stick with 8 and wait for 9.1
     
  16. SMatthys

    SMatthys

    Messages:
    2
    Same problem here with W7 losing & reconnecting the VoIP phone we use in the office (Plantronics P540-M). I'll have to downgrade to PD8 until this issue is solved.

    Quite disappointed by this pre-release I paid for... :-(
     
  17. MarkDo

    MarkDo Bit Poster

    Messages:
    2
    Hi All,

    Same problem as everybody else after the Upgrade, but I just would like to add something. After getting the HID constant rediscovery problem, I though that I will do the right thing and install a brand new Windows 8 VM.

    The clean Win8 VM was running perfect and fast after installing everything back to the way my previous system was. Today I needed to install Virtual Centre Client 5.1 on my Win8 guest to work on a Vcenter system and BAM, problem back.

    Seems like the VC Client 5.* or maybe other versions install something that causes Parallels 9 to HID rediscovery.

    Used to love Parallels, but having to pay a premium every year when a new version comes out one expects to dev team to test their software before charging clients to fault find their app.
     
  18. LeoW

    LeoW

    Messages:
    16
    This was exactly how I felt. I am a PD user since v4, this version 9 is the most disappointing one. I had to downgrade to PD8.

    Am I too old or too young to fit to the new software releasing model?
     
  19. PaulLevinson

    PaulLevinson

    Messages:
    1
    Reported same issue:

    Report ID: 28333059
     
  20. Priller

    Priller Bit Poster

    Messages:
    7
    Well, VMware announcing the release of Fusion 6 today pretty much explains why Parallels Product Managers rushed this out the door without adequate testing. Got'a beat the competition! WooHoo!
     

Share This Page