Parallels Auto-Suspend When Mac Sleeps

Discussion in 'General Questions' started by JeffA8, Sep 26, 2022.

  1. JeffA8

    JeffA8 Bit Poster

    Messages:
    2
    Hello, I am using Parallels Desktop 18 on a MacBook Pro 14 Inch (M1 Pro). I am having a bit of an issue with an external SSD attached to my Mac that I often use in Windows (note that the VM itself is installed directly on the Mac and not on the external drive).

    When I put the computer to sleep, I use a program to automatically eject all external drives and then it automatically re-connects them upon awakening (Mac program is called Jettison). Unfortunately, if the Windows 11 VM is running or paused when I put the Mac to sleep, I get an error from Jettison upon returning to the computer that it was unable to eject the external drive since it was in use in the Parallels Windows VM. I was able to confirm manually that is I suspend the VM instead of pausing, Jettison is able to eject the external drive without issue.

    I know I can disable auto-pause in Parallels, but what I am wondering is whether there is a way to have Parallels automatically suspend Windows 11 whenever my Mac goes to sleep (whether put to sleep automatically or manually).
     
  2. Robert Stavis

    Robert Stavis Bit Poster

    Messages:
    7
    I've been trying to figure out a similar issue for the past several months and I may have just stumbled across the answer: Try unchecking the Enable Power Nap feature for both the battery and the power adapter in the System Preferences ==> Battery preference panel.
     
  3. JeffA8

    JeffA8 Bit Poster

    Messages:
    2
    I don't believe that the Power Nap option is available on Apple Silicon based Macs...
     
  4. Robert Stavis

    Robert Stavis Bit Poster

    Messages:
    7
    On my 2019 (Intel) MBP with Windows 10 running in PD, the Sleep command in the Apple menu puts the computer to sleep for about 2-3 seconds after which the computer wakes up. There no issue when PD is manually suspended. Unchecking the Power Nap setting fixed the problem and the Sleep command (or closing the lid) now puts the computer to sleep regardless of the state of PD. I understand that these settings do not apply to the Silicon based Macs, so I think the issue is back to Parallels to address.
     

Share This Page