Parallels Client no longer full screen in Samsung DeX after updating to One UI 6.0 and Android 14

Discussion in 'Parallels Client for Android' started by JoeB30, Jan 18, 2024.

  1. JoeB30

    JoeB30 Bit poster

    Messages:
    2
    This morning, my Samsung Galaxy S22 just updated to One UI 6.0 and Android 14. After the update, the Parallels Client no longer enters full screen properly. Previously, I maximize the Parallels Client window in Samsung DeX and then the remote desktop takes up the entire screen. After the update, the top of the Parallels Client window has a black bar and the remote desktop wants to pan up and down whenever I move my mouse cursor close to the black bar or to the bottom of the screen. I notice this black bar is also the exact size of window's header bar which normally shows up after moving my mouse cursor to the top of the screen and leaving it there for a moment. So, it seems like the Parallels Client is no longer reacting when the window's header bar disappears and is leaving the black bar at the top instead of making the remote desktop occupy the entire window again.

    I do not have a good work around. For now, in the Parallels Client session settings, I set a custom desktop resolution with the height 36 pixels less than my display's native resolution. This way, even though there is still a black bar at the top of the window, the remote desktop no longer pans around.

    I appreciate someone from Parallels looking into this and possibly addressing it in a future update. I also appreciate any other possible workaround.
     
  2. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Messages:
    3,110
    Hi @JoeB30,
    Thanks for bringing this to our attention!
    It appears to be an issue specific to One UI 6.0, unlike the Parallels Android client which doesn't exhibit the same issue. Multiple users who have upgraded to Android 14 are facing similar issues with other applications as well.

    To address this, I recommend trying the following workaround:
    Access Samsung settings, then navigate to Advanced Features > Labs > Multi-Window for All Apps.
    https://techcommunity.microsoft.com...x-top-bar-blocks-remote-desktop/idi-p/4005831
    https://us.community.samsung.com/t5/Tablets/Samsung-DeX-Issues/td-p/2769028
     
  3. JoeB30

    JoeB30 Bit poster

    Messages:
    2
    Thank you for the helpful insight. I see that the issue is not specifically with the Parallels Client for Android but is a more general issue. Not having a full screen remote desktop experience in the Parallels Client in DeX has been especially painful. However, my Samsung Galaxy S22 finally got the OneUI 6.1 update and now the problem is gone! In the Parallels Client, I can now set "Resolution" back to "Best for your device" and get a full screen display without any panning.
     

Share This Page