Parallels Desktop 16 and Windows 10. Windows is extremely slow with 100% processor load

Discussion in 'Windows Guest OS Discussion' started by MHofmann1965, Sep 21, 2020.

  1. Michael Becker

    Michael Becker Bit Poster

    Messages:
    7
    Sorry guys.
    I have to back paddle: Change to 1 CPU does not help - system is still extremely slow, practically unusable.
     
  2. CAIRYL

    CAIRYL Bit Poster

    Messages:
    3
    Same issue for me. Horrible performance on any configuration except 1 CPU and 4G.

    This seems to me to be a pretty big "miss" by the Parallels team.

    Thanks for posting, Michael. You're my Hero of the Day


     
  3. CAIRYL

    CAIRYL Bit Poster

    Messages:
    3
    I want my money back. Parallels 17 running Windows 10 is a joke. It's completely horrible. SLOW SLOW SLOW SLOW SLOW SLOW
     
    AshW1 likes this.
  4. MehdiB2

    MehdiB2 Bit Poster

    Messages:
    2
    Hi,
    I had the same problem and the Parallels hypervisor is just so bad with VMs.
    Go To ==> Materials ==> CPU and Memory ==> Click Advanced ==> Change the hypervisor to Apple.
    You should be ok
    Cheers
     
  5. kevcollins

    kevcollins Bit Poster

    Messages:
    18
    Wow, I've been frustrated living with crappy parallels performance for some time. After reading this thread, I changed to the Apple Hypervisor and wow, what a difference! Parallels is now usable again! Thank you.
     
  6. JariH

    JariH Bit Poster

    Messages:
    2
    Same here. Windows 10 is practically unusable. Allowed only 1 CPU and now better but still slow. Please fix this already.
     
  7. kevcollins

    kevcollins Bit Poster

    Messages:
    18
    Did you switch to the Apple hypervisor? In my case, that made a huge difference.
     
    MehdiB2 likes this.
  8. MehdiB2

    MehdiB2 Bit Poster

    Messages:
    2
    Yep. Apple hypervisor runs like a charm with Windows all versions.
     

Share This Page