Parallels Desktop 19.3.0 is released!

Discussion in 'Product updates and feedback' started by Mikhail Ushakov, Mar 7, 2024.

  1. ThorstenR5

    ThorstenR5 Bit poster

    Hi all, just updated to 19.3.0 and all files on the desktop of the VM are gone. Just showing the trash bin and "Mac Files". I cannot open any file because it says it cant find the file and drag'n drop does not work anymore. Cannot place any files on the VM desktop. Any kind of help would be appreciated.
    (Mac Studio, macOS 14.4)
  2. brad-x

    brad-x Junior Member

    The other option available in VM Configuration -> Options -> Startup and Shutdown (which they don't seem to plan on removing) actually does this exact thing - though I agree, documenting a plist method for VM autostart would allow removal of the UI for it entirely. Still pretty nice to have tho
  3. Macintosh Rescue

    Macintosh Rescue Member

    The option that is being taken out is: "Start Automatically: When Mac Starts" which means that the closest that a future UI (Parallels Desktop 20) will offer is: "When user logs in" and for server guests this is not ideal hence the need for the plist; the VM needs to boot non-interactively so 'before' user login. I'll have a go at the plist and post back with results. I've been a bit swamped with other things I need to do.
  4. Macintosh Rescue

    Macintosh Rescue Member

    Here's an example parallels.autostart.plist that works for me allowing macOS to start a VM without needing to login.
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC -//Apple Computer//DTD PLIST 1.0//EN >
    <plist version="1.0">

    This first sudo's to the user who has the Parallels VM registered so in my case "andrewread" and the guest I'm running is called "macOS" ; I previously had spaces in the virtual machines name "macOS 10.15.7" but I couldn't get that to work. If anybody knows more about these plist files than me I'd like to know what you would do different.

    The thing is enabled with launchctl load -w /Library/LaunchDaemons/parallels.autostart.plist

    If you have more than one guest needing auto started you should be able to just duplicate the plist and re-label is as something like parallels.autostart1.plist or something more meaningful.

    It does seem that at least we have a working solution now going forward.
  5. Macintosh Rescue

    Macintosh Rescue Member

    New deprecated feature to workaround:
    • Network boot for macOS virtual machines : an iso available from : will do the job. It's for VirtualBox but I've tried it in Parallels Desktop 19.3 and it does initiate a macOS NetBoot just fine. All you do is attach the iso as a CD/DVD and change the Boot Order to start your VM with CD/DVD and the boot loader on the iso will attempt to NetBoot the virtual machine.
    Again perhaps this could go into a Knowledge Base article to assist Parallels Desktop customers transition from the deprecated features.

    MERMIGKISS Bit poster

    I use Relux over Parallels 19.3.0 on my Mac M1 and since the last 30 days I Had a problem with running the application.
    When i've been asked for the update of the Relux and i confirmed for the version 2024.1.10, I could not run the new version.
    I had to uninstall the program from my hard disk and reinstall the 2023.1.11.0 Relux version. This version can run, but i cannot see the pointer of my mouse in the planning area
    My mouse pointer is visible only in the menu area of the Relux program .
  7. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    We have created a support case and send you and sent you an email with further steps to troubleshoot this issue.
    Thank you.
  8. ChristianH51


    I can't imagine why there is a need to get rid of starting a VM when mac starts. Is it really that hard to continue this support? I use it.
  9. rwessel

    rwessel Bit poster

    I see there's already mention of a change in the latest version, but I need to clarify a point before updating:
    I am currently able to use a 10.6 (Snow Leopard) VM using Parallels 19.2.1 (54832) on MacOS 14.2.1 with an Intel-based Mac. If I update, does change mean that:
    1) The 10.6 VM will cease to work, or;
    2) You no longer provide support if I run into any issue running a 10.6 VM (but it might still work)?
    kkramar likes this.
  10. Macintosh Rescue

    Macintosh Rescue Member

    Quoting my own post unfortunately to say that there is a problem with my autostart plist; If I login to the hosts desktop and interact with Parallels the auto started guest seems to suspend when I logout. I can get it back up again by ssh'ing into the host then running the prlctl command line but this is not good for keeping server guests up.

    The solution could be to make a new user account on the Mac and register the vm to that user and change the sudo options in the plist ; that user would never login to a desktop. I think this is a recent macOS locking down situation rather than a fault with Parallels. There are drawbacks with the separate user option so I think its suffice to say that on a host with macOS guest services a user needs to be left logged in which may not be ideal.
  11. BradS2

    BradS2 Bit poster

    I am having a serious issue with Coherence Mode. Coherence works well until I "View -> Exit Coherence".
    Not always, but sometimes the Windows 11 desktop goes blank, or the taskbar disappears.
    I can reproduce by having a Microsoft Word document open when I exit coherence.

    Parallels 19..3.0
    Windows 11 (22000.2538)
    Microsoft Office Version 2403 (Build 17425.20176)
    macOS 14.4.1 Sonoma
    Apple M1 Pro silicon
  12. BradS2

    BradS2 Bit poster

    In summary Micorosoft Office v2403 apps on Windows 11 do not always "paint" the screen when in coherence mode. The screen turns grey.
    I discovered that this only happens with an external display. A fix is to drag the wayward parallels window (Office app) to the main screen on my laptop.
    I have two external displays.
  13. nickjbedford

    nickjbedford Junior Member

    I am having major issues typing in macOS 14.5 guest on 19.3.1 on a macOS 14.4 host using an Apple Magic Keyboard + Numpad (BT). It constantly repeats keys and sometimes just randomly types other ones.
  14. DessertB

    DessertB Bit poster

    I just updated to the latest version of Parallels Desktop (19.3.0), and I seem to be running into a few issues. First off, I'm experiencing some compatibility problems with a couple of my essential apps. They were working fine before the update, but now they're acting up, and it's really throwing a wrench into my workflow.

    On top of that, I've noticed a significant slowdown in performance since installing the update. Tasks that used to be quick and smooth are now taking forever to complete, and it's getting pretty frustrating.

    I've tried troubleshooting on my own, but I'm not having much luck. Has anyone else encountered similar issues after updating to version 19.3.0? Any suggestions on how to fix these problems would be greatly appreciated!

    Thanks in advance for any help you can offer!
  15. zeeshann


    ok, I understand little bit.
  16. TonyC2

    TonyC2 Member

    What is this crap? Nothing but troubles since updating. VMs don't shut down / suspend. I've been looking at the Parallels "Starting..." screen for 3 minutes now...
  17. kkramar

    kkramar Junior Member

    I am very disappointed in Parallels' dropping of support for "macOS 10.5 to 10.8" on Intel systems.

    I have some important legacy 10.7 VMs that I refer to regularly (this is not professionally unreasonable), and if upgrading to the current version I will lose that usable trove of data and information.

    Yes, I understand that Silicon processors are now Parallels' main focus, and that Intel processor systems in the Mac marketplace are dwindling. If using Silicon, all those older Intel VMs now must be reconstructed with ARM versions of whatever the guest OS is. If you have close to 100 VMs like me that's an inordinate amount of work, and the reconstructed VMs will never be the same as what was previously constructed.

    I made a decision when purchasing a MacBook Pro at a time when both processors were available, and while I could have gone with a Silicon processor, I chose Intel so that I could continue with older work that was made with *your product* to run hyper threading natively.

    So to see these older versions of macOS drop off is a real blow, and personally it dissuades me from updating to the newest version, even though there are bug fixes and improvements I could benefit from. I think it is a poor decision that affects your professional user base. We buy Parallels Desktop to run alternate versions of OSes, and limiting those versions makes your product weaker. (Hell, I even run a VM version of Next OpenStep, would that be cut? You're killing your enthusiasts here!)

    VMware Fusion Pro 13 still supports macOS versions back to Mac OS X Server 10.5, and while the integration to macOS isn't nearly as complete as Parallels Desktop (kudos for that), they are not abandoning older versions of macOS.

    If I understand this trend correctly, it is just a matter of time before all Intel support is dropped from Parallels' products in favor of ARM, and I think that is a poor decision.
    Macintosh Rescue likes this.
  18. DavidC134

    DavidC134 None Bit poster

    Why is there not a create thread topic or button on the main page. I click on parallels for mac and it still keeps me on the same page. How can I fix a problem if there is no clear way to start a thread of my own?

Share This Page