Parallels Desktop and Windows Vista Service Pack 1

Discussion in 'Windows Guest OS Discussion' started by Xenos, Feb 6, 2008.

  1. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Dear all,

    We have become aware of the possible issue with Parallels Desktop and Windows Vista Service Pack 1. Boot Camp VM can get broken after SP1 installation in virtual environment.

    We recommend installing SP1 in native Boot Camp only.

    If you have already installed SP1 in VM and now encountering problems, please repair Windows using native Boot Camp and install SP1 natively afterwards.

    We bring our apologies for the inconvenience caused.

    Best regards,
    Xenos
     
  2. rbh

    rbh

    Messages:
    55
    Hi Xenos,

    Is there any issues around upgrading your Vista VM if it is a "pure" VM, not a bootable partition accessed via Parallels?

    thanks,
    R
     
  3. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello Rachel,

    We are not aware of any serious issues when upgrading a "pure" Vista VM, but just don't forget that installing Service Pack itself in Windows can lead to some bugs and unexpected issues because it's quite serious OS update. So you should keep an eye on Microsoft troubleshooting info too.

    Best regards,
    Xenos
     
    Last edited: Feb 22, 2008
  4. rbh

    rbh

    Messages:
    55
    Hi Xenos,

    Thanks for the response. Glad to know only the expected Windows based problems need to be watched for... So that means just making a clone of my VM prior to bravely allowing the updates through. :)

    I won't be rushing to be an early SP1 update victim.

    cheers,
    Rachel (no second "a")
     
    Last edited: Feb 12, 2008
  5. dagtj

    dagtj

    Messages:
    1
    Hi

    I wonder if this problem is related to my upgrade to Vista SP1: When the VM is idle for some time it will automatically pause. When I return to the VM, instead of starting normally, Windows will always go into bluescreen. I use builde 5584, and Leopard 10.5.2. Everything was working fine before the SP1 upgrade.

    Dag
     
  6. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello Dag,

    The issue you are describing is a known problem that's under investigation now. Vista drivers do not get disabled before Mac goes to sleep mode and power supply stops. This situation provokes crashes.

    To avoid it you should currently use the following workaround: suspend Parallels when going to leave it for some time or hibernate Vista.

    Best regards,
    Xenos
     
  7. schulzkeil

    schulzkeil

    Messages:
    7
    I have 10.5.2 installed and am running Windows XP under Parallels. I now bought Vista Business. I want to upgrade rather than run a clean install. Everything works fine with Vista's installation process. However, after several hours of installation , when Vista is supposed to start I get a very short message that "sptd.sys" is not working and then the screen turns blue etc. In the end, all I could do was go back to Windows XP. -- Any advice what I could do?
     
  8. trevorcobb

    trevorcobb

    Messages:
    1
    I did install Vista SP1 RTM (not a beta or release candidate) in Vista native mode (bootcamp). I am running the most updated version of Leopard, and build 5582 (??) of Parallels. I usually only run Vista via bootcamp. Today I tried to start it up under Parallels Desktop, and it crashed each time I tried to start it up. I haven't run it under Parallels since before I installed SP1.

    I booted back into Vista via bootcamp after it crashed under Parallels, and all of the sudden Vista was no longer activated. Couldn't get into Control Panel, Welcome Center, System Properties, etc...

    I've tried all the troubleshooting measures I could find online and I have only succeeded in taking my install of Vista to the point where I am completely locked out almost. It won't start explorer at all now.

    Have posted on the MS Windows Genuine Advantage Forums, and I have emailed Microsoft WGA support with a response time of 8 business hours, but it is a freaking weekend right now. Arghh...
     
  9. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    I had a similar problem whereby installing Parallels Tools corrupted Boot Camp drivers and withdrew licensing information. I put a post here on the forums and did not get a reply that worked for me. This week I did get one from Parallels which might help you with this problem:

    We aware of this problem and our developers are doing their best to fix
    it in a short period of time. Please see if this temporary solution
    would help you:

    1. Please load your Windows OS from your Boot Camp partition in safe
    mode.
    2. Double-click My Computer.
    3. Open Local Disk (C:) then double-click the Program Files folder.
    4. Open the Common Files folder, then delete the Installshield folder.
    5. Go back into the Program Files folder, then open the Installshield
    nstallation Information folder and delete all the files that you have
    inside.
    6. Close all Web pages and programs.
    7. From the desktop, select Start > Run.
    8. In the Open field, enter %temp% and click OK.
    9. Delete all the files in this temp folder.
    10. Load your Mac OS and start Parallels Desktop, but don't start
    Windows OS.
    11. Click on Edit/Virtual machine from the top Parallels menu.
    12. Select Hard Disk 1 from the list of resources and then Advanced tab
    from the right side. Click the Clear button there and then Ok.
    13. Start your Windows VM using the green arrow button (or
    Action/Start).
    14. Install Parallels Tools once again using Action/Install Parallels
    Tools menu from the top.
     
  10. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello,

    Schulzkeil, do you have Daemon Tools or any other software for mounting iso images installed? If you do, please uninstall this software.

    Trevorcobb, thank you for your report. We are investigating the issue. Could you please let me know what answer did Microsoft support give?

    Jimcoyle, the issues described above do not seem to be related to Parallels Tools.

    Best regards,
    Xenos
     
  11. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    I'd be curious to know what the issue is. All I know is that when I followed these instructions, I was able to install Parallel Tools and be able to boot from Parallels and BootCamp. Until I did this, I could boot from Parallels. Each installation of the Tools resulted in not being able to boot from Boot Camp.
     
  12. Boy914

    Boy914

    Messages:
    1
    Any Update?

    Xenos,

    I have been keeping an eye on this thread because I am waiting to buy Parallels Desktop until I know it will work with my Vista SP1 Boot Camp partition. I just set Boot Camp up on Monday using the full "Vista w/ SP1" install (ie I didn't install Vista and then SP 1 after the fact - it was all part of the same install).

    Do you have an update on your investigation into trevorcobb's issue?

    Thanks!
    Rick
     
  13. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello all,

    Parallels developers are working to fix the issues of Boot Camp VMs with Vista SP1.
    Thank you for your reports again.
    We are sorry for the inconveniences caused.

    Best regards,
    Xenos
     
  14. test5477

    test5477

    Messages:
    5
    Same problem

    I'm having the same problem with the Windows Activation now saying that product key is already in use? I guess SP1 messed this up because before that I have been using this legit copy of Vista Ultimate that came with the Mac Book Pro.
    It came with Parallels installed - I uninstalled so I could set up Boot Camp and then use that for Parallels. any suggestions?

    Also, I saw in the WGA forums they are having alot of verification problems after SP1 installs.
     
  15. murraywheeler

    murraywheeler

    Messages:
    2
    getting ntoskrnl.exe error message in bootcamp

    iMac 24 inch screen
    Intel Core 2 Duo, 2.8 GHz, 4 GB
    Mac OS X 10.5.2 (9C31)
    Parallels 3.0 (5584)
    65GB Bootcamp partition with Vista and all updates.

    Being a risk taker... I installed Vista SP1 yesterday in the Parallels environment. Everything went well and there were no issues. Restarted and it all works great.

    However when I start up from boot camp directly, I get the message about ntoskrnl.exe being missing or corrupt. If boot off the Vista DVd directly and run the repair utility, it finds the same error and says it cannot repair it.

    If I boot from the same bootcamp partition using parallels again, there are no issues. If I boot from the Vista DVD using parallels and run the repair utility, it says there are no problems.

    So after SP!, parallels runs my bootcamp partition great but I can no longer boot directly from the partition.

    I read this article:
    Ntoskrnl.exe - Windows is unable to Boot - Ntoskrnl.exe File is Missing
    but it has not been updated for Vista and appears to apply to XP.
    My guess is that Bootcamp is trying to start from the wrong partition for some reason.
     
  16. test5477

    test5477

    Messages:
    5
    I have a different experience.

    After installing SP1 in Boot Camp I go to Parallels and try to start my existing VM and it asks about starting in Safe Mode and I say yes then it goes Black for a few seconds and then closes.

    I tried a new VM and does the same thing. Any help is appreciated.
     
  17. trimegistro

    trimegistro

    Messages:
    24
    Vista SP1

    Hello, I have been using Parallels desktop for about two weeks and going through the forums I just can't believe that Parallels is not Vista SP1 ready... What kind of software company would not prepare for a major release as such since the RC have been going around for a while. I hope you guys get your act together so we could install SP1 on Vista without a problem...
     
  18. test5477

    test5477

    Messages:
    5
    OK now i am where you are, i'm getting the same error when starting the boot camp option.
    Works fine under parallels though.
     
  19. Steven Block

    Steven Block

    Messages:
    1
    Is there some way to keep the Vista VM (with SP1) from pausing automatically after a period of non-use? With SP1 ALREADY installed (and it's not feasible to remove it easily; besides, our Stanford system applies these upgrades without choice!!!), the VM will die with the blue screen of death iwhen returning to a paused Vista. If I could keep Vista from pausing, I could keep it from crashing.
    Also, when will you have an update to Parallels that will fix the Vista Service Pack 1 problem????
     
  20. karmicscorpio

    karmicscorpio

    Messages:
    3
    same problem with Vista SP1 (with possible resolution)

    I installed Vista SP1 the evening of 3/18/2008 when it was released. Here's what happened:
    1. I started Vista using Boot Camp (Vista Native Mode)
    2. I installed Vista SP1 (successfully)
    3. Afterwards, I tested apps and ensured everything ran fine in Vista Native Mode
    4. I re-started in OS X (Leopard 10.5.2)
    5. Started the Paralells Vista VM (latest version - build 5584) and I had the exact same issue, the VM started to load Vista and then crashed mid way. The next time I launched it, I was prompted for Safe Mode - I tried that, it crashed again. This led me to this forum in search of an answer.
    6. I tried Vista using Boot Camp/Native Mode and Vista started up and ran fine.
    7. On a whim, the evening of 3/19/2008 I started in OS X and checked for Apple Software updates - there were 3 available. After downloading/installing/restarting OS X, the Parallels VM WORKED AGAIN!

    It's only been a few days, however, I haven't had any trouble with it since. Perhaps this is an OS X issue and not a Parallels issue? Hope this helps someone else.

    Robert
     

Share This Page