Parallels Desktop for Mac build 3120 RC1 is available for download.

Discussion in 'Parallels Desktop for Mac' started by STim, Jan 10, 2007.

  1. dkp

    dkp Forum Maven

    On earlier installations the .psf folder contains only what I've specified - a subdirectory in a specific user's account. The .mac folder opened to the root of the Mac boot disk. That's far more exposure than I'm willing to accept.
  2. ajcooper

    ajcooper Member


    As far as I know, Fusion needs 10.4 or 10.5 to function. The only other version I have is 8.xx which the camera won't install. Trying to download 9.5 to see if that will work.

    Million dollar question - when can we expect support for the 10.5 drivers?

  3. unused_user_name

    unused_user_name Pro

    I agree with dkp.

    There are known viruses out there that infect files over SMB shares. If there is a global "Share the Mac Hard Drive" share with read access then any (all) word docs (or any other data file) on the Mac could potentially be infected. While it would not hurt the Mac, it would be really bad for anyone else I could send files to...

    One of the things I do with Parallels is intentionally infect windows installations to see what they do. This would be a *really bad thing* to let things go from Windows to Mac without me _explicitly_ telling it that it can.

    I would much rather have the file copying take place on the OSX side of things.... How about a virtual SMB share on the mac side that contains the hard drive image of the guest OS? You could use a script on the OSX side to do the copying. Then it would (1) not let Windows viruses run amok on your OSX, (2) possibly work with other OSs if they name their SMB share the same as the default that Parallels Tool's names it, (3) It would continue working longer with Windows upgrades, as a unix-based script on Mac is unlikely to have the API changed....
  4. Delphyne

    Delphyne Member

    I had to completley uninstall parallels tools and reinstall them for coherence to work with this upgrade
  5. blackmac

    blackmac Junior Member

    I am still desperately missing supoort for the built-in camera of my MacBook. Isn't this going to come in the next release?

    Rumours are, a competitor has implemented this feature already?! ;)
  6. dailo

    dailo Member

    A lot of bugs seemed to be have fixed at least for me they have been. Parallels doesn't close when I try to run Remote Desktop anymore. However the memory leak is still there =/.

  7. STim

    STim Bit poster

    Our Fusion came with 10.0 drivers on the CD and works flawlessly with them. We were testing with both 10.4 and 10.5 as well - they BSOD like for you. We're working hard on the fix...

    Yeah I saw these rumors in action - great job for competition :) iSight support is being worked on as well, just wait a bit...

    Best regards,
  8. bhorta1

    bhorta1 Member

    Wow big difference. The first beta was totally buggy and unusable so I went back to 1970. Tried 3120 RC1 and night and day difference. and now I can import CDs into itunes!

    Whenever my wife wants to use the Mac I put it in fullscreen windows XP and she is happy itunes now imports. Old habits die hard :) :) :)

    but I use OS X :)
  9. Cyrealm

    Cyrealm Bit poster

    My Logitech Quickcam Communicate STX now works. Thanks Parallels Team! :D
    Last edited: Jan 11, 2007
  10. aokie

    aokie Bit poster

    I got a VM crash while running Microsoft Update under Windows 2000 SP4 Japanese.
    The crash is totally reproducable.

    #I cannot send email to I got unknown user error messages.
  11. Hugh Watkins

    Hugh Watkins Forum Maven

    I was really nervous about this upgrade

    But in a moment of inspiration I uninstalled Parallels tools from my working VM and then from its clone

    Then I upgraded to 3120

    I opened the clone first and installed the tools and then it worked perfectly after a reboot

    Closed that and open my main VM and started to install the tools

    I had to accept that the mouse no longer worked and made the install using Apple usb full keyboard with my MacBook Pro

    I saw the win XP cursor slowly sliding down a digaonal to the bottom right corner of the OS Window
    in fact the right mouse button still worked at that location

    max X 0 Y

    when it was time to reboot after the Parallels tools insatller got to the last pane "Reboot Now . . Later?

    I battled to get it to read the return key

    I could use the Start menu and open th atsk manager from the ctrl alt delete

    but the tools installer would not let go
    even when I used the arrow keys to call the blue shut down or reboot dialog with green or red button

    so I had to use the Parallels menu >> actions > stop
    to get out of it

    when I restarted the second VM it worked perfectly

    The shared folders worked again at last
    (see my other cries for help)

    thanks guys

    Hugh W
  12. BlueTrance

    BlueTrance Junior Member

    Definitively, you just need to open Parallels to see it's real RAM allocated size growing slowly but forever.
    You don't need to have a Windows instance running (I have noticed with all of my VMs). And you don't even needt to start the VM to check it.

    I wish this could help yo find the bug.

    And thank you for fixing the unexpected quit issue!!
  13. STim

    STim Bit poster

    More information is really needed. What is your MacOS X version? Are all latest updates installed? What's your Mac name? How much RAM does it have? And finally, what is the devices set your VM is configured with?

    Best regards,
  14. dworkman

    dworkman Bit poster

    Boo Hoo

    Did you ever think perhaps the Parallels guys are just plain busy? This isn't a social networking group.
  15. Hugh Watkins

    Hugh Watkins Forum Maven

    they clearly fix the bugs reported by several users

    My own heavy cpu usage is a win XP issue depending on what you install and run on the guest OS

    Hugh W
  16. Bit poster

    i can't view your jpeg, but i also see an artifact in Coherence mode.
  17. Ainvar

    Ainvar Member


    DITTO for me, I email this to parallels also, maybe they will get it fixed.
  18. methnen

    methnen Bit poster

    Ah good. I was just coming back to say its happening again. The memory leak appears to be a bit slower than before but difinately still there as I've had parrallels crash under the same conditions now 3 times since upgrading to the latest.

    Glad you guys have a handle on it.

  19. mroedig

    mroedig Bit poster

    My Motorola Q works PERFECTLY "out of the box", so to speak, with Fusion. I love Parallels, but if they can't get the USB, right my choice is made.
  20. triplex

    triplex Junior Member

    I got blue screen with STOP: 0x0000007B (which means "INACCESSIBLE_BOOT_DEVICE " as I know) when trying to run "bootcamp vm" with fresh installed 3120 RC1 parallels. Bootcamp windows is fresh installed too on fat32.

    my boot.ini of bc win looks like:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Share This Page