Parallels Desktop install MSVCP.120.dll error

Discussion in 'Installation and Configuration' started by DaveT2, Dec 17, 2016.

  1. DaveT2

    DaveT2 Bit Poster

    Messages:
    1
    I don't know for sure if this is caused by Parallels, but it's the only significant thing I've done since W10 was last working. Everything worked finr using W10 via bootcamp; after I installed Parallels desktop, I get an error when Windows boots: MSVCP120.dll is missing (it's not, I checked). Actually I get the error twice in succession and have to dismiss both. This happens whether I start Windows via Parallels, or the old way, restarting in bootcamp. This error prevents me from using my most important program 3ds Max. And although there are other apps that still function, there is a spinning blue disk with the cursor that never goes away. I have tried doing a reset of Windows, but that fails either in Parallels, or when I restart the machine using bootcamp. If anyone knows how I can repair this, whether or not it's a problem that originates with Parallels, I'd appreciate it.
     
  2. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    Hi @DaveT2
    Looks like the issue might occur if the Microsoft Visual C++ 2010 Redistributable Package is not installed properly. There are few more suggestion in Microsoft support page
     
  3. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hi @DaveT2 , we've received your reply:
    This seems to have worked. Thanks.

    Thanks a lot for your reply!
     
  4. lorein

    lorein Bit Poster

    Messages:
    26
    It might happen that while installing parallels desktop any of the DLL file gets corrupted or you have not installed it properly. So as you said it is showing MSVCP.120.dll error, then in this case you can try to fix it by downloading a DLL file. There are many sites that offer free DLL files but few of them are trustful. So, it is recommended to download it from the manufacturer site or Microsoft site. Or else perform a clean installation of the Parallels desktop. Hope this will help you.

    You can also make use of the DLL Repair Tool, if the issues is caused due to DLL corruption then this can fix the error automatically by scanning and fix the problem.
     
  5. Swati@Parallels

    Swati@Parallels Kilo Poster

    Messages:
    360
    Thank you so much for sharing this workaround. We are glad to see your active participation and appreciate it.
     
  6. lorein

    lorein Bit Poster

    Messages:
    26
    It is a pleasure for me.. I love to contribute my knowledge...
     
  7. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Right on! Thanks for your support! We love having fans like you.
     
  8. DanielN18

    DanielN18 Bit Poster

    Messages:
    1
    This was a top hit on Google.
    I ran into this error when launching the game "Sims 4" from Steam on a fresh install of Parallels (Windows 11) on my M1 Macbook Pro.
    I ended up getting this work by doing two things. I did them both at the same time, so I'm not sure which one actually fixed the issue.
    1. Run Windows Update and ensure Windows is up to date. It had various updates for for ARM64 and C++ Redistro, so maybe something here helped. Though I still got the error after installing all updates, I don't want to rule out the possibility that it might have helped with the following step.
    2. Install all three Visual C++ Redistros: Latest supported Visual C++ Redistributable downloads | Microsoft Docs (x86, x64, arm64). I'm sure the game only cares about the x64 one, but I don't know. Couldn't be bothered to find out.
    Once I did these steps, I never saw the DLL errors again and Steam was able to install Origin and launch Sims 4 in Parallels.
     
  9. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,039
    Hello, thank you for sharing the troubleshooting steps.
     
  10. RyanS30

    RyanS30

    Messages:
    1
    Just did this on my brand new MacBook with M1 Max. I didn't think it was still necessary to install x86 and x64 because the ARM processor. But after installing all three (x86, x64, arm64) it worked. Thanks!
     

Share This Page