Parallels doesn't auto-launch my VM.

Discussion in 'Installation and Configuration' started by dpouliot, Sep 14, 2007.

  1. dpouliot

    dpouliot

    Messages:
    7
    Launching Parallels itself brings me to a "New VM Wizard" with no choice of "locate an existing VM". Cancelling the Wizard quits Parallels. ARG! I have to double-click the .pvs file to boot into my VM.

    I have tried solutions listed on this site like ensuring that Parallels has the correct path to my VM's folder (it does).

    What's more frustrating, it is almost impossible to access the VM's configuration settings. Clicking the .pvs file boots the VM. Stopping the VM using the red button (to access the configuration settings) quits Parallels!

    I have to quit the VM, then I have about a second to select Edit>Virtual Machine before Parallels quits. Many times I have missed that moment in time and had to try again, shutting down a VM as it is booting, which I'm sure isn't good for the OS.

    It would be much less frustrating if Parallels just stayed open when I stopped a VM.
     
    Last edited: Sep 14, 2007
  2. sandro

    sandro Parallels Developers

    Messages:
    512
    hi,
    you can configure this Parallels behaviour. To do it select Parallells->Preferences menu item find there necessary checkboxes.
     
  3. dpouliot

    dpouliot

    Messages:
    7
    which setting do I change to keep Parallels open upon stopping a VM (and to keep the VM's configurations visible)?

    And how do I get Parallels to automatically boot into my VM when I launch Parallels?
     
    Last edited: Sep 15, 2007
  4. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Hit configuration on the config window. You should be highlighted over the top of the list on the left that says 'Options'. Select the 'Booting' tab and you should find the checkboxes there. To get in without booting hold down the apple or command key.
     
  5. dpouliot

    dpouliot

    Messages:
    7
    Thanks for the help. I see a checkbox that says "Exit application on VM shutdown". It is unchecked, yet Parallels still quits when I stop the VM.

    I don't understand your comment "To get in without booting hold down the apple or command key."

    If I hold down command while launching Parallels it still brings me to the "OS Installation Assistant". If I hold down command while double clicking the .pvs file it still boots the VM.
     
  6. sandro

    sandro Parallels Developers

    Messages:
    512
  7. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Odd, dpouliot... Not quite sure why it doesn't work...
     
  8. BarryP13@mac.com

    BarryP13@mac.com

    Messages:
    94
    try the option key, not the command(apple) key...

    The checkbox "Exit application on VM shutdown" just shuts down whatever applications are running. you can set what paralles does when you stop the VM under the Parallels desktop menu: preferences:general
     
  9. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Option? That's what I thought originally, until others told it was command. I never have the issue, I disabled the problem on all my computers and I used the .pvs file in the past. So quotquot.
     
  10. dpouliot

    dpouliot

    Messages:
    7
    I tried launching Parallels while holding down option key, still brings me to OS Installation Assistant.
    I do not see an option that tells Parallels to remain launched upon stopping a VM.
     
  11. dpouliot

    dpouliot

    Messages:
    7
    Interesting. I didn't know .pvs files were just text. That said, I noticed these values in my pvs file:
    Start auto = 0
    AutoShutdown = 0

    for kicks I changed them to:
    Start auto = 1
    AutoShutdown = 1

    then tried 1) launching Parallels (still brings me to @#$% OS Install wizard!) and 2) launching then shutting down VM (still quits Parallels).
     
  12. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Well, I think zero is no, and 1 is true. It was on the right settings to start with. Parallels?
     
  13. dpouliot

    dpouliot

    Messages:
    7
    I agree. I just changed the numbers to see if ANYTHING different would happen. Then I changed them back to 0.
     
  14. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    I wasn't criticizing your approach, I do the same when things are broke without being able to find a fix. I would submit a trouble ticket and hope that this thread gets Parallels' attention. Heck, you can even try to PM Tim Surgent or Archy and see if that gets their attention.
     
  15. xochi

    xochi

    Messages:
    88
  16. johnv

    johnv Parallels Team Parallels Team

    Messages:
    181
  17. dpouliot

    dpouliot

    Messages:
    7
    Thanks John,
    This helped me to get to the VM config: "While pressing the Command key, double-click the virtual machine's alias."

    But it is incredibly frustrating that I have to result to an undiscoverable method to edit my config.

    Furthermore, the other tip: "While pressing the Command key, start Parallels Desktop from the Applications folder. If you have more then one virtual machines, select the desired virtual machine in the Select virtual machine dialog and click the Select button."

    didn't help me at all. No matter what I do, when I start Parallels by double-clicking its application icon it insists on starting that New VM wizard. There is no way for me to select an existing VM!
     

Share This Page