"Parallels NAT" network config suddenly has self-assigned IP

Discussion in 'Installation and Configuration' started by ewestby, Feb 5, 2008.

  1. ewestby

    ewestby

    Messages:
    26
    I've been working with Parallels Desktop 3.0 build 5584 since its release without incident. Suddenly yesterday -- right before an important presentation, natch -- I lost all Internet connectivity from within the VM. I'm running Windows XP Pro SP2 with shared networking under Mac OS X 10.5.1.

    I went to my Leopard network preference pane and sure enough, the "Parallels NAT" component had a self-assigned 169.x.x.x IP address instead of the usual 10.x.x.x address. I had to uninstall, reboot, and reinstall Parallels to restore normal connectivity from within the VM.

    Any reason this might have happened, and strategies to avoid it in the future? I had done absolutely nothing unusual with Parallels or my network configuration that might have caused the problem. The problem persisted through several restarts of both my VM and my Mac, using both Ethernet and AirPort on different networks. The only thing that fixed it was uninstalling and reinstalling Parallels.

    One possible wrinkle: I do occasionally use the Cisco VPN client v.4.9.01.0100 when working from home. I used it without incident with build 5582. Has build 5584 perhaps introduced an incompatibility?
     
    Last edited: Feb 5, 2008
  2. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    169.x.x.x ip means that Parallels NAT cannot receive the ip-address from the DHCP.
    Nest time you have this problem please try to run the following command in Terminal:
    sudo killall –hup pvsnatd

    Best regards,
    Stacey
     
  3. jw0000

    jw0000

    Messages:
    1
    Thanks Stacey!!!

    By the way, I think the HUP should be capitalized in the killall command.

    Thanks again.
     
  4. Spero33

    Spero33

    Messages:
    1
    I'm sorry if I'm posting in the wrong place- new to forums and I can't find a way to post a new thread (I know, duh). This is along the same lines though...

    Anyway, I just installed parallels on my imac 24" 4 gb ram. Unfortunately however, I can't connect to the Internet... it's not recognizing my hardware or something... went to control panel and device manager and there's problems there with network hardware...

    Any suggestions? Thanks

    PS Figured out the UI (and how to post a new thread)... sorry!

    FINAL ENTRY ON THIS THREAD:

    ISSUE FIXED- INSTALLED PARALLELS TOOLS AND ALL IS WELL ;)
     
    Last edited: Feb 9, 2008
  5. ewestby

    ewestby

    Messages:
    26
    I'll try it, thanks.
     
  6. justinsouter

    justinsouter

    Messages:
    1
    I tried the command you specified and still my Parallels-NAT has a self-assigned IP address.
     
  7. boxclever

    boxclever

    Messages:
    1
    self-assigned IP

    Should Parallels be running when you try that Terminal command or not? Does it require a restart?
     
  8. John@Parallels

    John@Parallels

    Messages:
    6,343
    There is no difference Parallels Desktop is running or not
    Some situations can lead to such behavior
    - You manually limited DHCP scope - in Parallels Desktop -Preferences -Network increase scope
    - You have connected Wireless Modem, which either shutdown, or affects Parallels NAT stability - unplug wireless modem
    - Incorrect permissions or corrupted file /Library/Parallels/.parallels_dhcp_leases
    You need to get root
    to perform operations bellow sudo is not working
    echo > /Library/Parallels/.parallels_dhcp_leases
    killall -HUP pvsnatd
     
  9. Techhead156

    Techhead156

    Messages:
    130
    weird problem

    The above problem is what i face as well... How is the parallels virtual adapters tied to the physical NICs ?

    I just had a replacement logic board replaced on my mac, so it would (i gather) be a new MAC address. Since Parallels was already installed, prior to this, it couldn't get an psyical ip to either virtual nics on the mac. I would understand this that this would loose connectivity from within the VM's. but for me.. despite both of these virtual adapters have self assigned ip's, i can still get online from within the VM's I had previously crated a while ago. I'm not fussed as all works as expected still, but if this is how their binded, how can i still have 'net' access within the VM's (using the DHCP scope range in Parallels prefences), but the virtal nic be 169.x.x on the Mac. ?
     
  10. MtnViewJohn

    MtnViewJohn Bit Poster

    Messages:
    15
    Stacy, the command does not work and in fact kills Parallels networking until the next OS X reboot. Please edit your post to contain the correct command so that Parallels users do not waste time.
     
  11. John@Parallels

    John@Parallels

    Messages:
    6,343
    Please check my post
     
  12. anschmid

    anschmid

    Messages:
    4
    I had the same problems after I do a complete uninstall and reinstall of Parallels on my Mac.

    The Parallels NAT network adapter would have a "self assigned" IP address which was 169.xxx.xxx.xxx which wouldn't allow the Windows XP guest operating system to get to anything on the Internet.

    I solved my problems by starting up Parallels and go into -> Preferences.

    Under the Network options I clicked on Shared Networking and strangely there was NO TICK in the box for Enabling the DHCP scope. All I did click the tick to enable it and left all settings as they are.

    This fixed the problem, when I want back into Network settings in Mac OS X the Parallels NAT network adapter had a 10.xxx.xxx.xxx network address and all seems to work fine.

    Why this was switched off by uninstalling and installing the new build 5608 I have no idea?
     
  13. soundevolution

    soundevolution

    Messages:
    62
    doing killall -HUP pvsnatd does nothing because that process isn't running.

    It seems to work in bridged networking mode, but i'd rather be in shared mode to be behind the mac's firewall...
     
  14. John@Parallels

    John@Parallels

    Messages:
    6,343
    Actually it is for Shared mode, kextload should show you 2 kexts managed by pvsnatd
     
  15. djaneb

    djaneb

    Messages:
    17
    For what it's worth this command worked for me - I ran it, then went in and renewed the dhcp lease, which resulted in an ip address. I booted up WinXP in Parallels and had to check Shared Networking under devices and got the Internet connection back.

    Deborah
     
  16. ebudan

    ebudan

    Messages:
    7
    Suffering of the same problem. No obvious changes I would've done with my network settings, but the mac has been up for a few weeks, so I might have forgotten something.

    None of the terminal/application based tips in this thread have helped. Downloading build 5608 now and seeing if the update manages to shake everything into place.
     
  17. ebudan

    ebudan

    Messages:
    7
    Installing build 5608 solved this (mostly). The Parallels NAT IF is now connected normally, but the Parallels Host-Guest IF is still self-assigned. I'm able to access the net from the guest os, though, which was my primary concern.
     
  18. John@Parallels

    John@Parallels

    Messages:
    6,343
    In System Preferences -Network check that Parallels Host Guest is configured to get IP by DHCP
     
  19. djaneb

    djaneb

    Messages:
    17
    FYI I have another Mac that developed the same issue out of the blue - ran the sudo command in this thread with Parallels running and the DHCP kicked in automatically and am back online.

    Begs the question - why have two of my macs spontaneously developed this issue, my other mac hasn't and there are no issues with any of the machines.

    Don't care about the answer, just dropping it in there.
     
  20. cortig

    cortig

    Messages:
    30
    For what it's worth, I still also have this problem. Today, I was messing around restarting the Parallels startup item and I notices several references to Cisco VPN in the Terminal output. I therefore decided to uninstall it from my Mac (not trivial).
    After a reboot, the problem is gone!!

    Now…*I don't know whether it's gone for good, but in any case, it's looking good.

    Corentin
     

Share This Page