"Parallels NAT" network config suddenly has self-assigned IP

Discussion in 'Installation and Configuration' started by ewestby, Feb 5, 2008.

  1. joedoejunk

    joedoejunk

    Messages:
    1
    I just had the same problem. I went to Preferences, went to the Network tab, and unchecked "Enable DHCP scope for shared networking", then closed preferences. Then I opened again to preferences, re-checked the box, and all of a sudden I got back the proper IP address in Parallels NAT and Parallels Host-Guest in Mac OS X nework preference pane.
     
  2. jfs5

    jfs5

    Messages:
    2
    Thanks joedoejunk!

    Your suggested fix worked for me.
     
  3. bobodobo

    bobodobo

    Messages:
    22
    I had been having problems with network access for some months. Had the dreaded "Self Assigned IP address" 169.XXX.XXX.XXX despite all the sudos in the world, not to mention a bunch of other suggestions in other threads. Finally I read this thread and checked the "Enable DHCP scope for shared networking" in Parallels preferences. My "self assigned IP address" instantly changed to 10.XXX.XXX.XXX but still I couldn't connect to the internet. After shutting down and restarting the guest OS and Parallels itself, all is well now, finally. Hope others can have the same (almost) instant gratification experience.
     
  4. soundevolution

    soundevolution

    Messages:
    62
    Sweet. this fixed it for me, with Parallels running and windows loaded. Thanks John!
     
  5. benmadin

    benmadin

    Messages:
    4
    Broken Shared Networking fix

    G'day all,

    I just wanted to add that I have been using the 5608 build since June 2008 and this problem has happened a couple of times - and requires the pvsnatd to be stopped and restarted to overcome.

    Given that this has appeared as a problem since time immemorial, I was wondering could Parallels put a menu option or button somewhere in the interface to do this - given it isn't fixed yet?

    Would anyone else find this useful?

    cheers

    Ben
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    Such button will be implemented in Parallels Desktop version 4
     
  7. benmadin

    benmadin

    Messages:
    4
    pvsnatd restart

    Super - thanks for that.

    cheers

    Ben
     
  8. Corrado Fiore

    Corrado Fiore

    Messages:
    1
  9. Erik Bunn

    Erik Bunn

    Messages:
    1
    Been a while, but now I need to launch Windows again for testing. However, I'm back to the self-assigned IP problem on an Intel Macbook Pro and wireless network.

    None of the solutions mentioned in this thread work. Signalling 'pvsnatd' doesn't change things, and trying to renew the DHCP lease, switch network locations, or disable and re-enable the interfaces just ends up with the same 169.*.

    Parallels network preferences definitely have Shared networking activated, and DHCP scope is enabled. Changing network settings through the OS X network panel doesn't affect anything - the NAT IPs remain stubbornly self-assigned.
    Specifying manual addresses in the 10.0.0.* range doesn't seem to do anything.

    It's worth mentioning that run the Cisco VPN client (4.9.0.1, build 0100). Removing VPN is not an option.
    The discussion at http://forum.parallels.com/thread12457-2.html is related, but doesn't help in my case (VPN works fine, Parallels adapters never find addresses). I've attached my ifconfig output below, in case it is helpful. Interfaces en3 and en4 would be the Parallels ones.


    Any further ideas what to try?

    Thanks;
    //ebu

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:16:cb:8e:e8:2d
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    fw0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:16:cb:ff:fe:64:eb:78
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::216:cbff:feb6:94b5%en1 prefixlen 64 scopeid 0x6
    inet 192.168.1.2 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:16:cb:b6:94:b5
    media: autoselect status: active
    supported media: autoselect
    en4: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::21c:42ff:fe00:1%en4 prefixlen 64 scopeid 0x8
    inet 169.254.13.206 netmask 0xffff0000 broadcast 169.254.255.255
    ether 00:1c:42:00:00:01
    media: autoselect status: active
    supported media: autoselect
    en3: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::21c:42ff:fe00:0%en3 prefixlen 64 scopeid 0x9
    inet 169.254.13.206 netmask 0xffff0000 broadcast 169.254.255.255
    ether 00:1c:42:00:00:00
    media: autoselect status: active
    supported media: autoselect
    cscotun0: flags=8850<POINTOPOINT,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    closed
     
  10. papogotay

    papogotay

    Messages:
    7
    I was having the same problem-parallels working fine then suddenly lost all internet connections. I was nervous to use sudo b/c I don't know much about computers. The warning from terminal about possibly deleting files was a little scary, but I did it, and it's working fine now. Thanks.
     

Share This Page