Parallels network connections have self-assigned IP addresses

Discussion in 'Installation and Configuration' started by rfellows, Jun 20, 2008.

  1. rfellows

    rfellows

    Messages:
    10
    Periodically, the Parallels network connections decide that they want to have self-assigned IP addresses. The only way I have been able to resolve this is to reinstall Parallels, which is simple, but still I don't believe I should have to do this. I've tried refreshing the network connections in System Preferences, but that doesn't work. Is there another way to reset the Parallels network adapters w/o reinstalling Parallels?
     
  2. murphy

    murphy

    Messages:
    64
    Restarting the Mac fixes the problem for me.
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,343
    Some situations can lead to such behavior
    - You manually limited DHCP scope - in Parallels Desktop -Preferences -Network increase scope
    - You have connected Wireless Modem, which either shutdown, or affects Parallels NAT stability - unplug wireless modem
    - Incorrect permissions or corrupted file /Library/Parallels/.parallels_dhcp_leases
    You need to get root
    to perform operations bellow sudo is not working
    echo > /Library/Parallels/.parallels_dhcp_leases
    killall -HUP pvsnatd
     
  4. rfellows

    rfellows

    Messages:
    10
    Thank you John! I did this yesterday and it solved the problem! R
     
  5. Boatguy

    Boatguy

    Messages:
    14
    John, I have the same problem. Everything was working fine, then the last time I started up, the NAT device gets a self assigned address, can't get to the DHCP. The Parallels Guest is fine.

    So can you put your instructions into English? I can run a terminal line, but how do I get to root?

    Thanks

    Russ
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    open Terminal
    sudo passwd root
    enter twice root password
     
  7. BatmanPPC

    BatmanPPC

    Messages:
    5
    Please don't do this. There's a reason why OS X ships without root enabled.

    Get a root shell by running sudo -s. Then run the commands.

    The commands in sequence would be:

    % sudo -s
    % echo > /Library/Parallels/.parallels_dhcp_leases
    % killall -HUP pvsnatd
     

Share This Page