Parallels tools coming up each time: 3150

Discussion in 'Parallels Desktop for Mac' started by mgorbach, Feb 4, 2007.

  1. mgorbach


    Running xp pro sp2 with 3150, I'm getting a parallels tools install screen each time I start up the vm or un-suspend it. Is this a known bug of some kind? I think its auto-running from the mounted install "cd".
  2. jbwjim


    Parallels Tools

    I think if you watch it, it says INITIALIZING Parallels Tools, not installing........... FYI
  3. mjmac


    I get the same install screen each time I resume the vm. I have gone through the install numerous times and it just comes back. Have tried it with all virus/spy software unloaded. Also tried to eject Parallels Tools Setup Disk, but it will not eject.
  4. tomservo291


    I think the 2nd reply here is referring to a different issue.

    When you start up a boot camp VM it has a overlay that says "warning do not perform any operations ... may result in data loss ... loading parallels tools" etc.

    To the best of my knowledge, when you use a boot camp VM, parallels tools are installed/initialized differently (because they shouldnt be loaded if you boot into XP.) This is their mechanism for ensuring that they are loaded only when it is run in a VM.
  5. Atomic_Fusion


    mgorbach wrote: "I'm getting a parallels tools install screen each time I start up the vm or un-suspend it. Is this a known bug of some kind? "

    When is this happening? Specifically? While Windows boots? After the XP graphical user interface appears?

    It isn't likely to be happening in the GUI because the Tools setup CD only mounts when you choose Install Tools from the Action menu in Parallels -- unless you have copied the contents of the Tools CD to a folder on the hard drive, like I have before so I could install each driver separately during an experiment I was having.

    So, you must be referring to the "Inititalizing" screen overlay mentioned, and that is not installing the same Parallels Tools drivers that happens when you use the Action menu. Personally, I think that screen is referring to the initailizing of the drivers that are installed just after you press the Play button to start the VM. Once those drivers are installed and the hardware profile is created for Parallels, then Windows loads and those drivers are being initialized.

    It's just a guess, though. But it seems reasonable as to what is happening.
  6. SteveDemy


    Solution for me

    I had this problem. For some reason, the CD had become permanently attached to an .iso file that contains the Tools installation files. So each time Parallels was started, I would be re-invited to install (or remove) Parallels Tools.

    The solution was simple. Mouse over to the CD icon in the lower right corner of the Parallels application window. Select "Default CD/DVD-ROM" instead of the VM Tools .iso file. That restored normal operation for me.
    Last edited: Feb 28, 2007
  7. weesung


    I followed the what Steve Demy said but it is doing again and again when we restart 3150.

    Any way to fix it for good?
  8. Atomic_Fusion


    Post the exact message so we can see what it's saying.
  9. weesung


    1) When we start MacBook, We have Mac volume & PC Volume on desktop.

    2) When We boot from Parallels 3150, It is asking password for admin account.

    3) When we enter it, we have following message.
    " Unable to open disk image BOOT CAMP!"

    4) When we "OK" it, The Bootcamp volume dissapear.

    5) when we satrt to play Parallels again, we ahave warning message that it is installing Parallels tools.

    6) When we restart WinXP again, We see same Parallels tool installation again and again.

    How can we fix this problem?
  10. Atomic_Fusion


    That's not the exact message.
  11. Summi



    I am from germany and have the same problem.
    Wenn i start parallels beta und run WinXp the screen that paralells is initializing comes. then in win xp, the hardware assistent install some driver and says that i have to reboot system. wenn i restart win boot normal. at next time starting parallels an win, this happen again.
    i have no convertial partition with bootcamp. i have two partitions for windows. in bootcamp it works fine. in parallels i have modify the .pvs. so win over parallels work fine, and my two partitions mount, but i have the problem with the parallels-driver installation. here is my modified pvs file:

    Boot = c
    Parallels VM Name = Microsoft Windows XP
    VM Id = {79c6c1a1-84f2-4c0e-b72c-bca804006b49}
    VM Description =
    OS Type = 135
    Memory = 512
    Video Memory = 16
    Memory block size = 10
    Acceleration level = 2
    Enable write-back disk cache = 1
    VT-x support = 1
    Start auto = 0
    AutoShutdown = 0
    Start full screen = 23
    Start dashmode = 0
    Start full screen warning = 1
    PC Speaker enable = 1
    Window Mode = 1
    Multi frame = -1
    Guest Tools Status = 2
    [Shared folders]
    Shared folders enabled = 1
    Global sharing enabled = 1
    Shared folders count = 1
    Folder0 enabled = 1
    Folder0 readonly = 0
    Folder0 name = Macintosh HD
    Folder0 path = /Users/Matze
    Folder0 descr =
    Video resolutions enabled = 1
    Video resolutions count = 1
    VideoRes0 enabled = 1
    VideoRes0 width = 1024
    VideoRes0 height = 640
    VideoRes0 name = 1024x640
    Show taskbar = 1
    Relocate taskbar = 0
    Exclude Dock = 1
    Multiple displays = 0
    [IDE devices]
    Disk 0:0 enabled = 1
    Disk 0:0 = 1
    Disk 0:0 media = 1
    Disk 0:0 connected = 1
    Disk 0:0 image = Boot Camp;disk0s4
    Disk 0:0 cylinders = 0
    Disk 0:0 heads = 0
    Disk 0:0 sectors = 0
    Disk 0:1 enabled = 1
    Disk 0:1 = 1
    Disk 0:1 media = 1
    Disk 0:1 connected = 1
    Disk 0:1 image = Boot Camp;disk0s3
    Disk 0:1 cylinders = 0
    Disk 0:1 heads = 0
    Disk 0:1 sectors = 0
    Disk 1:0 enabled = 1
    Disk 1:0 = 2
    Disk 1:0 media = 1
    Disk 1:0 connected = 1
    Disk 1:0 image = Default CD/DVD-ROM
    Disk 1:1 enabled = 0
    Disk 1:1 = 0
    [Floppy disks]
    Floppy 0 enabled = 0
    Floppy 0 = 1
    [Serial ports]
    COM1 enabled = 0
    COM1 = 0
    COM2 enabled = 0
    COM2 = 0
    COM3 enabled = 0
    COM3 = 0
    COM4 enabled = 0
    COM4 = 0
    [Parallel ports]
    LPT1 enabled = 0
    LPT1 = 0
    LPT2 enabled = 0
    LPT2 = 0
    LPT3 enabled = 0
    LPT3 = 0
    Sound enabled = 1
    Sound = 1
    Sound connected = 1
    Sound device = Default Audio
    Mixer device = Default Audio
    Network enabled = 1
    Network = 3
    Network connected = 1
    Adapter No = 0
    Adapter name = Default Adapter
    Adapter type = 4
    Port = 0x00000300
    IRQ = 3
    MAC address = 00ce862d0459
    Network2 enabled = 0
    Network2 = 0
    Network3 enabled = 0
    Network3 = 0
    Network4 enabled = 0
    Network4 = 0
    Network5 enabled = 0
    Network5 = 0
    USB enabled = 1
    USB = 1
    USB autoconnect = 0
  12. Summi


    is there no solution for my problem???
  13. strells

    strells Product Expert

    Have you tried 3170?

  14. Summi


    still the same problem in 3170
    Last edited: Feb 22, 2007
  15. pairof9s


    Seems to be a requirement

    If I've read this thread correctly, it would seem that the Parallels Tools screen at launch is necessary as part of using the Boot Camp partition. This is the PT initializing itself onto the Boot Camp's XP boot which otherwise would not require Parallels Tools (ie, if you boot up using Boot Camp instead of Parallels). In addition, until the PT initialization is through, no actions should (or can?) be done in XP.

    Perhaps someone who does not use Boot Camp's partition for Parallels can confirm the lack of this screen during their boot up.

    Bottom line, this is not going change due to software requirements. Still, one might suggest a more modest screen announcement.
  16. Ken Kling

    Ken Kling

    Default CD/DVD-ROM fixed it for me

    This fix worked for me (except that the CD icon in question is in the lower right corner of the Parallels window) and my problem was not related to Boot Camp. I'm not using Boot Camp. The problem existed for me with build 3150 and continued to 3170. Then I found this fix. Thanks Steve!
  17. lupus


    I have the same behaviour with Parallels Compressor - it gets itself stuck to the CD drive, and every time it kicks off a Compressor run. I've done the same fix with the CD, but it has come back again.

    Posted about it at


  18. Billy Shears

    Billy Shears

    This has nothing to do with boot camp. I've been having this same problem with the compressor or the tools through all the beta.

Share This Page