Parallels Tools constantly wants to reinstall

Discussion in 'Parallels Desktop for Mac' started by ABLederman, Apr 20, 2007.

  1. ABLederman

    ABLederman

    Messages:
    5
    Running 3188 on an MacBook Pro, with Windows XP Pro SP2.

    Ever since I updated to 3188, everytime I restart my virtual XP machine, it wants to reinstall Parallels Tools. very annoying.

    I can disconnect the image, vmtools.iso, and it may go away for a little while.

    If I let it reinstall, it still comes up as needing to install again.

    HELP!
     
  2. nycruza

    nycruza

    Messages:
    224
    Are you sure you are not seeing the message "Parallels Tools is INITIATING"???

    Does this occur before or after the desktop is up and running?

    ajm
     
  3. ABLederman

    ABLederman

    Messages:
    5
    It comes up after XP is up and running. It then prompts me to continue installing Parallels Tools. I cancel, and it still works as though TOols was installed.

    It is not initiating, but installing. I can see that the image is still mounted as the cd drive.

    Thanks.
     
  4. nycruza

    nycruza

    Messages:
    224
    If you have not already tried

    Boot up in Safe Mode and login as Administrator
    Install Parallels using the Parallels Menu Bar.
    Reboot.

    ajm
     
  5. ABLederman

    ABLederman

    Messages:
    5
    OK, I tried to reinstall.

    After I install, when it goes to restart, I get a black screen that doesn't do ANYTHING. It never succesfully restarts, so I have to reset the virtual machine.

    I'm sure this is where the problem is.

    Advice?
     
  6. Art743

    Art743

    Messages:
    25
    This may help:

    One of Parallels techs responded on another thread that the tools must be deleted and reinstalled after an upgrade because they do not match (don't know why).

    The procedure he gave was to start windows in safe mode, and use control panel to un-install the tools. Then restart windows, and reinstall the tools. Several posters who had the black screen did do, and it solved their problem. Apparently uninstalling in the safe mode is critical.

    Then I saw this:

    http://www.parallels.com/products/desktop/faq/t5/#t5-3

    Good luck.
     
    Last edited: Apr 21, 2007
  7. patniemeyer

    patniemeyer Bit Poster

    Messages:
    6
    Password / Tools reinstall...

    Every time I boot parallels on my boot camp partition it prompts me for my admin password. It also reinstalls the parallels tools on every boot.

    I contacted support and they simply told me that they know about the problem and it will be fixed in the next public release. I am not sure if this is two problems or one... or what the time frame is for the next release.

    Anyone else experiencing this?

    Mac Pro / Boot Camp on a separate disk / Win XP.


    Pat
     
  8. ABLederman

    ABLederman

    Messages:
    5
    Tried the uninstall/reinstall in safe mode.

    NO LUCK.

    Any help?

    I too get an error asking me for my password on reboot, so I deleted my password.
     
  9. cedarhome

    cedarhome

    Messages:
    3
    can't reinstall parallels tools

    I went to safe mode and can't uninstall parallels tools because it's already gone
    When I try to reinstall parallels tools, nothing seems to happen.
    I can cancel the install that is supposedly in progress, but that's it.

    Any ideas?
     
  10. spike13

    spike13

    Messages:
    12
    This happened to me to awhile back when I first installed the latest version of Parallels. I believe how I fixed it, was to go into the configuration and turn off auto connect to the CD/DVD drive. So, not only did a unmount the image, I prevented Parallels from reconnecting when it booted up. Hopefully this helps you too.
     
  11. chriskrogers

    chriskrogers

    Messages:
    4
    Normal- for now....

    Right now, this seems to be normal. The support team responded to one of my earlier posts reporting the same issue you are experiencing. They explained that to mount or un-mount the Windows partition, OS-X requires a password. I don't think it is re-installing the tools - just initializing the tools. Hopefully, they will address these issues soon.
     
  12. Archy

    Archy Super Moderator

    Messages:
    212
    Hello everybody.

    Concerning transparent message about Parallels Tools initializing..
    We need to show you this message every time when you start VM with BotCamp partition because if you restart or stop VM before Tools were loaded you may lose any data on BootCamp partition.

    About password requesting - Mac requires admin password to operate with BootCamp partition.

    In next release Parallels Tools for BootCamp will be initialized instantly. I hope our developers will have time to do it.
     
  13. ABLederman

    ABLederman

    Messages:
    5
    Actually, it was going through the complete reinstallation, not just initializing.

    I finally just rebuilt a new VM and its gone (I think). I think it had to do with updating a VM built on r1970 or whatever to 3188 or whatever the current one is. It was never a BootCamp partition.
     
  14. tlevin

    tlevin

    Messages:
    1
    parallels tools restarting every time

    Tried the above suggestions without success. Any other solutions out there for how to stop parallels tools from re-installing each time. Is it problematic to not allow the re-install?

    Thanks
     
  15. Archy

    Archy Super Moderator

    Messages:
    212
    Ok. Please try this:
    1. Stop VM.
    2. Go to configuration editor and change CD-ROM settings.
    3. Choose "Use CD/DVD-ROM" option, CD/DVD-Rom Drive: "Default CD/DVD-ROM"
     
  16. sdaniels

    sdaniels

    Messages:
    2
    Archy's suggestion seemed to work for me. I had the same issue of the tools Setup running everytime I started up the VM. It would even run if I resumed the VM from a previous suspension.

    Thanks.
     

Share This Page