Parallels Tools do not install on RHEL9

Discussion in 'Linux Guest OS Discussion' started by DariusS1, May 27, 2022.

  1. SantoshC

    SantoshC Bit Poster

    Messages:
    3
    Anyone found the solution to this problem?
     
    GuillermoS2 likes this.
  2. lasse@christiansens.net

    lasse@christiansens.net Bit Poster

    Messages:
    40
    Also waiting for a solution. It happens on both RHEL9, Rocky9 and Alma9 (for pretty obvious reasons) :)
     
    LokalerA and GuillermoS2 like this.
  3. LokalerA

    LokalerA Bit Poster

    Messages:
    3
    We are having the same problem here. Alma Linux 9, Parallels 18.0.2, running on Mac OS Big Sur 11.6.7, Intel Mac
     
  4. RobertE18

    RobertE18 Bit Poster

    Messages:
    1
    We are also having the same problem. Alma Linux 9, Parallels 18.0.2, Running Mac OS Monterey 12.6, Intel Mac
     
  5. MaximM3

    MaximM3 Bit Poster

    Messages:
    1
    Hello everyone. Have the same problem with Parallels Tools installation on RHEL-9.0 (Kernel: Linux 5.14.0-70.26.1.el9_0.x86_64)
     

    Attached Files:

  6. maumbo

    maumbo Bit Poster

    Messages:
    3
    Same problem for me on Rocky Linux 9
     
  7. AlanS18

    AlanS18 Bit Poster

    Messages:
    5
    Same problem here, with the latest version of Parallels installed. This seems unacceptable as the issue has been around for a long time. Can someone from Parallels fix this please?
     
  8. PaulM64

    PaulM64 Bit Poster

    Messages:
    1
    I'm also having this issue when using Bento to generate a AlmaLinux 9 parallels vagrant box:

    Code:
    parallels-iso: Provisioning with shell script: ~/Documents/Code/bento/packer_templates/almalinux/../_common/parallels.sh
    ==> parallels-iso: + HOME_DIR=/home/vagrant
    ==> parallels-iso: + case "$PACKER_BUILDER_TYPE" in
    ==> parallels-iso: ++ awk -F. '{print $1}'
    ==> parallels-iso: ++ sed 's/^.\+ release \([.0-9]\+\).*/\1/' /etc/redhat-release
    ==> parallels-iso: + major_version=9
    ==> parallels-iso: + '[' 9 -ge 10 ']'
    ==> parallels-iso: + mkdir -p /tmp/parallels
    ==> parallels-iso: ++ uname -m
    ==> parallels-iso: + '[' aarch64 = aarch64 ']'
    ==> parallels-iso: + mount -o loop /home/vagrant/prl-tools-lin-arm.iso /tmp/parallels
    ==> parallels-iso: mount: /tmp/parallels: WARNING: source write-protected, mounted read-only.
    ==> parallels-iso: ++ cat /tmp/parallels/version
    ==> parallels-iso: + VER=18.1.0.53311
        parallels-iso: Parallels Tools Version: 18.1.0.53311
    ==> parallels-iso: + echo 'Parallels Tools Version: 18.1.0.53311'
    ==> parallels-iso: + /tmp/parallels/install --install-unattended-with-deps
        parallels-iso: Started installation of Parallels Guest Tools version '18.1.0.53311'
        parallels-iso: modprobe: FATAL: Module prl_tg not found in directory /lib/modules/5.14.0-70.30.1.el9_0.aarch64
        parallels-iso:
        parallels-iso: Tue Nov 15 22:16:39 UTC 2022
        parallels-iso: Start installation or upgrade of Guest Tools
        parallels-iso: Skipping BTF generation for /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prl_tg.ko due to unavailability of vmlinux
        parallels-iso: Skipping BTF generation for /usr/lib/parallels-tools/kmods/prl_fs/SharedFolders/Guest/Linux/prl_fs/prl_fs.ko due to unavailability of vmlinux
        parallels-iso: Skipping BTF generation for /usr/lib/parallels-tools/kmods/prl_notifier/Installation/lnx/prl_notifier/prl_notifier.ko due to unavailability of vmlinux
        parallels-iso: Skipping BTF generation for /usr/lib/parallels-tools/kmods/prl_fs_freeze/Snapshot/Guest/Linux/prl_freeze/prl_fs_freeze.ko due to unavailability of vmlinux
        parallels-iso: Start installation of prl_tg kernel module
        parallels-iso: Start installation of prl_fs kernel module
        parallels-iso: Start installation of prl_fs_freeze kernel module
        parallels-iso: Start installation of prl_notifier kernel module
        parallels-iso: Failed to resolve typeattributeset statement at /var/lib/selinux/targeted/tmp/modules/400/prltimesync/cil:35
        parallels-iso: Failed to resolve AST
        parallels-iso: semodule:  Failed!
        parallels-iso: Failed to resolve typeattributeset statement at /var/lib/selinux/targeted/tmp/modules/400/prltoolsd/cil:51
        parallels-iso: Failed to resolve AST
        parallels-iso: semodule:  Failed!
        parallels-iso: cp: cannot create regular file '/usr/share/icons/hicolor/48x48/apps/parallels-tools.png': No such file or directory
        parallels-iso: Parallels Guest Tools were installed successfully!
    I think the main issue may be this one: FATAL: Module prl_tg not found in directory /lib/modules/5.14.0-70.30.1.el9_0.aarch64
     
  9. 刘一谦

    刘一谦 Bit Poster

    Messages:
    2
    Same issue here with CentOS Stream 9 on an M1 Pro macOS 13.0 host with PD 18.1.0(53311)
     

    Attached Files:

  10. sbarnea

    sbarnea Bit Poster

    Messages:
    12
    I find it hilarious that Parallels claims via https://www.parallels.com/blogs/parallels-desktop-18-1/ that in 18.1.0 they fixed installation on M1 for CentOS 9 Stream, when everyone around here knows that that is not the case. The code still fails to compile with parallel tools 18.1.0.53311

    I opened a support ticket but got a reply with links about how to install parallel tools on Windows! Reopened the ticket and linked to this thread, hopefully we would have it fixed.
     
  11. WaldemarJ

    WaldemarJ Bit Poster

    Messages:
    1
    18.1.53311 the problem persists with CentOS 9 Stream. Any suggestion?
     

Share This Page