Parallels tools under ubuntu?

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by AlanD17, Dec 17, 2020.

  1. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    I'm making progress, but am stuck on parallels tools

    I installed ubuntu from here using the manual instructions from the other threads

    https://ubuntu.com/download/server/arm

    I wanted to use desktop version, but added the desktop afterwards with the instructions here

    https://linuxconfig.org/ubuntu-20-04-gui-installation

    It doesn't show the guy as it's loading the OS like a normal desktop install would do, but eventually shows the normal login screen. I guess there's another step somewhere.

    Now I need to install parallels tools to get get a few shared folders from the Mac. When I click install parallels tools, it just mounts the CD image. Am I missing a step or do I just need to share them like I would for an external machine?
     
  2. KevinB21

    KevinB21 Bit Poster

    Messages:
    22
    I mounted the CD image and attempted to install them but there script said they only work on x86 so I'm assuming they aren't updated for the M1 yet.
     
  3. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    okay, I just shared them from MacOS and mounted them in ubuntu and that worked as expected.
    I'm installing my full test environment now.
    I knew the old intel MacBook Pro was loud, but I didn't realize how loud the intel Nuc I have ben using was until I shut it down.
     
  4. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
    What did you share? I want to get them installed as well
     
  5. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    To share a Mac folder in ubuntu without
    In MacOS
    Go to System Preferences:Sharing:File Sharing
    (not sure the order here)
    turn on file sharing
    add the fold you want to share
    click options
    check share using SMB, turn on your account, set a password (don't think it has to be your Mac password)
    In ubuntu
    create a folder in your home directory that matches the name of the one you want to share
    sudo apt install cifs-utils
    sudo nano /etc/fstab
    add a line (replace computer-name, all of the username, password with the right things)
    //computer-name.local/FolderName /home/username/FolderName cifs uid=username,gid=username,user=username,pass=password,iocharset=utf8 0 0
    save and exit the file
    then run
    sudo mount -a
    if everything works, the folder will be mounted in ubuntu
     
  6. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    my post above is a workaround until parallels tools is implemented, clearly parallels tools is a better way to do this.
     
  7. AnonUKuser

    AnonUKuser Bit Poster

    Messages:
    12
    You can also use ssh to setup access to files on your Mac HD. System Preferences -> Sharing -> tick the Remote Login box. In Ubuntu you can set up a bookmark to the folder you wish to access in the File Manager window via Other Locations -> Networks.
     
  8. never_released

    never_released Bit Poster

    Messages:
    14
    Parallels Tools for Linux are currently x86 only...
     
  9. RakeshK7

    RakeshK7 Bit Poster

    Messages:
    2
    Thanks for this - I have tried this but failing and syslog says I have an error code 2...

    am I right in thinking the line should be as follows:

    //computer-name.local/<full path i.e. Users/<MAC USER>/share> home/username/<share> cifs uid=<UBUNTU username>,gid=<UBUNTU username>,user=<MAC username>,pass=<MAC password>,iocharset=utf8 0 0

    I've tried a few combinations and the log is not very helpful...

    Also I had to create the folder on the ubuntu VM ... but I guess that is expected?
     
  10. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    Change this

    //computer-name.local/<full path i.e. Users/<MAC USER>/share>

    to this
    //computer-name.local/share
     
    RakeshK7 likes this.
  11. AlanD17

    AlanD17 Bit Poster

    Messages:
    16
    Also, yes, linux needs an empty folder at the target location.
     
  12. RakeshK7

    RakeshK7 Bit Poster

    Messages:
    2
    Magic thanks- I had tried a few variations on the path but it didn't work in a sub folder but works now in my 'home' area

    Thanks mate!
     
  13. JimP6

    JimP6 Bit Poster

    Messages:
    4
    I'm new to Parallels and trying the M1 tech review. It works, I can load a Ubuntu 20.04 ARM version in it, but I prefer using Vagrant. There is a Ubuntu 20.04 ARM box available but the dev is waiting for Parallels tools, whatever they are, to be ported to ARM so it will run with Parallels. The box boots until it requires those tools. Does anyone know what the status of these tools is? Is an ARM version in dev now?
     
    BrookeS2 and AshleyD2 like this.
  14. Kerry1

    Kerry1 Bit Poster

    Messages:
    1
    Hi Alan,
    I'm still not sure WHICH of the Parallels tools you were installing under Linux now? I mounted the Tools folder from the Mac App, but neither the Linux install works and of course also not the Mac App to install them. So how/what did you then install on the guest linux?

    Thanks alot
    Kerry.
     
  15. todonoghue

    todonoghue Bit Poster

    Messages:
    20
    I think there are posts here referring to the x86 version of Parallels rather then the completely separate *M1* *ARM* version.
    That said, it would be really nice to see some input from Parallels about the progress, ETA, etc. of the Parallels Tools for *Linux* on the M1 Tech Preview. Y'know, since we're assisting with the testing and all. :)
     
    AndreyG4, BobW11, ChrisC47 and 3 others like this.
  16. RemyV1

    RemyV1

    Messages:
    1
    Parallels Desktop 16 for M1 Mac Technical Preview 2 includes a compatible Parallels Tools version that works with Ubuntu 20.04 ARM.
    • Support for installing Parallels Tools in the following Linux distributives: Ubuntu 20.04 or later, Debian 10.7 or later, and Fedora Workstation 33-1.2 or later.
    https://my.parallels.com/desktop/beta

    Mounting the disk via SMB share is very slow. With the Parallels Tool the

    To install it:
    mkdir /media/cdrom
    mount -o exec /dev/sr0 /media/cdrom
    cd /media/cdrom
    ./install

    Local disks can be shared and mounted to /media/psf/YOUR_LOCAL_FOLDER
     
  17. JimP6

    JimP6 Bit Poster

    Messages:
    4
    There is finally a Vagrant setup for the Mac M1 and Ubuntu 20.04 but it has an outdated version of Parallels Tools. I've struggled with installing Tools and have had to several times as I wire it up. Why is it so painful to just have file sharing which was easy in Virtualbox and Fusion on Intel Macs?
     
  18. BobW11

    BobW11 Bit Poster

    Messages:
    68
    21.04 is also not functional.
     
  19. RizzoA

    RizzoA Bit Poster

    Messages:
    7
    I can't use parallels tools on ubuntu 21.04 and for this, I cannot change the screen resolution. Please fix it
     
  20. BrionV

    BrionV Bit Poster

    Messages:
    3
    Parallels Tools does not install on Ubuntu 21.04 on Parallels 16.5.0 (50692) on arm64.
     

Share This Page