Parallels, Ventrilo and World of Warcraft

Discussion in 'Parallels Desktop for Mac' started by Gahlok, Dec 5, 2006.

  1. Gahlok

    Gahlok

    Messages:
    15
    Hello.

    I'm trying the beta version and it's the first time that I actually try using Ventrilo on Parallels and World of Warcraft. For some reason, after a while, the audio in Parallels goes off, and the only way fixing it is restarting the VM. At first I thought that this only happened when World of Warcraft was in Full Screen, but even Windowed it happens.

    Not like it's a major issue for me, at least I can listen and talk (when Parallels is the active application), but it's kinda weird when everything gets quiet and then I realize that it's because of that issue.

    Is there anything I could do to avoid it?

    And yes, I know that there's a Mac Vent, but the server I connect to uses GSM 6.10, and even a month of requesting the change it haven't happened.
     
  2. pfilias

    pfilias

    Messages:
    4
    You actually play World of Warcraft within Parallels????

    :eek: :eek: :eek:
     
  3. Gahlok

    Gahlok

    Messages:
    15
    Nope, I use Mac WoW.
     
  4. darkone

    darkone

    Messages:
    804
    sound cut out was a well known problem in really old versions of Parallels, are you using build 1970 or higher ?
     
  5. sydbarrett74

    sydbarrett74

    Messages:
    61
    What kind of Mac do you have? If it's a Mac Pro with an Nvidia 7300GT and more than 2GB system RAM, WoW barfs on that hardware config, and it has nothing to do with Parallels....
     
  6. sydbarrett74

    sydbarrett74

    Messages:
    61
    Agreed...the newer builds have much better sound support....
     
  7. Gahlok

    Gahlok

    Messages:
    15
    I'm using the Beta version (3036). I got an iMac 20" Core 2 Duo with 1GB RAM.
     
  8. Gahlok

    Gahlok

    Messages:
    15
    /bump

    ^_^
     
  9. Gahlok

    Gahlok

    Messages:
    15
    I just updated to Beta2 and I'm still experiencing this problem :( Is there anything I can do to avoid it happening?
     
  10. Gahlok

    Gahlok

    Messages:
    15
    After the latest beta (2) I've noticed that sound going off is happening more often, which is getting annoying T.T
     
  11. TenSafeFrogs

    TenSafeFrogs

    Messages:
    4
    I'm trying to do the exact same setup as you...

    i run wow on my macbook pro 2.33 ghz, and run vent under parallels for servers that don't support speex (seriously, how hard is it to just add in GSM codec support? grr.).

    when the sound cuts out, i have to restart the virtual machine and that fixes it for a while. i noticed that if i click the sound icon at the bottom right corner of the VM, and mute the sound, then try to reactivate it, it says that the sound is busy or something like that.
     
  12. Gahlok

    Gahlok

    Messages:
    15
    Yeah, I've tried doing that as well, among other things: when the sound goes off I try to lower and increase window's sounds, to see if I can get any feedback, but nothing. Then I've tried muting the sound (lower-right corner) and turning it on again and nothing as well :(

    The funny thing is that after the update the problem appears in less than 1 minute (or around there).

    I also agree that changing the damn codec to Speex would make the life easier, but meh, my GM said that he has been requesting it (for over two months, since I first started bugging about this) to his providers (NRGServers or similar) and nothing -_-

    Help with fix please :(
     
  13. lewisjones

    lewisjones

    Messages:
    1
    is there a way to run wow in full screen on mac yet run ventrilo with push to talk in parallels? becase at the moment if you are not selected on the VM, ventrilo will not respond to the push to talk key

    thanks
     
  14. sydbarrett74

    sydbarrett74

    Messages:
    61
    After the Before the Storm WoW patch, your problems with WoW should now be gone....
     
  15. Gahlok

    Gahlok

    Messages:
    15
    The problem is not with WoW, it's with Parallels. It's something like this:

    Parallels -> Ventrilo
    Mac OS X -> World of Warcraft
     
  16. TenSafeFrogs

    TenSafeFrogs

    Messages:
    4
    yeah, just to reiterate, this isn't a wow problem at all, it's a ventrilo + parallels issue where the sound cuts out after about a minute of use.
     
  17. stokkes

    stokkes

    Messages:
    27
    It may very well be a Ventrilo issue and the way it interacts with the GSM codec.
     
  18. TenSafeFrogs

    TenSafeFrogs

    Messages:
    4
    FYI to anyone else having the problem, the VMware beta for OSX seems to handle ventrilo just fine.
     
  19. TenSafeFrogs

    TenSafeFrogs

    Messages:
    4
    double post!
     
  20. Unkle

    Unkle

    Messages:
    4
    This has nothing to do with WoW. I run WoW on a separate mac that is not Intel. I have been using the parallels desktop to launch the Ventrillo to get the GSM codec to run. I am not even sure that this is a Ventrilo problem because once it cuts out, I try to get windows to run something to generate some form of a sound clip, .wav, .mp3, etc. I cannot get sound from any application once it cuts out.


    This get really frustrating and most Vent users who do not disable announcements begin to complain that I am bouncing in and out of the channel.

    Any help, acknowledgment of the issue, potential fix would be appreciated.

    Unkle
     

Share This Page