Parallels + Windows 2003 Issues

Discussion in 'Parallels Desktop for Mac' started by Washu, Jan 5, 2007.

  1. Washu

    Washu

    Messages:
    5
    I have build 1970 of Parallels running Windows XP without issue. I would like to install Windows 2003 R2 onto it and use it as a domain controller running Exchange 2007. I have encountered the following issues:

    After installing Windows, the Parallels Tools, and all Windows Updates, I run Manage Your Server and add the Domain Controller role using all defaults and selecting to install and configure DNS on the server. After the installation of the DNS service the install wizard sticks on "Waiting for DNS service to start" and counts up indefinitely. A look in the Application log indicates that sysocmgr.exe has crashed - this is the program that installs the DNS service - and DNS hasn't installed correctly in Services. Trying to open Add/Remove Components to remove/reinstall DNS results in the program hanging.

    DNS can be installed manually before AD is installed and seems to work correctly however.

    I then installed Exchange 2007 x32 Trial onto the VM, and the install process hung at the stage where it adds the Exchange services to AD at the end of the install (entire VM was unresponsive). Restarting the VM at this point resulted in a corrupt and unusable Active Directory.

    These problems are reproducable for me on build 1970 and the latest beta. Has anyone else encountered them?
     
  2. Washu

    Washu

    Messages:
    5
    Also, after installing Active Directory, I get the following error in the System log of the VM:

    Event Source: Disk
    Event Category None
    Event ID: 32
    Date: date
    Time: time
    Event Type: Warning
    Description: The driver detected that the device \Device\Harddisk2\DR0 has its write cache enabled. Data corruption may occur.

    It's not kidding either - if the VM dies for any reason at this point, AD will trash itself (see above). This only seems to occur after installing AD, and happens before installing Parallels Tools but persists after they have been installed.

    Going into the write cache policies on the hard drive in device manager tells me that "the write cache setting cannot me modified" and indeed it cannot.
     
    Last edited: Jan 6, 2007

Share This Page