Parallels Workstation 2.1 beta2 known issues

Discussion in 'Parallels Desktop for Mac' started by STim, Apr 9, 2006.

  1. STim

    STim Super Moderator

    Below is the list of most annoying known issues.

    * Mac OS X restarts when Parallels Workstation is left running and host revokes from “Sleep†mode. This is going to be fixed. To workaround the problem, just suspend or power off the VM before giving “Sleep†command the Mac OS X.

    * Parallels can’t read DVDs.

    * In beta2, it takes longer to boot guest. Will be fixed.

    * Guest tools installation process is not robust. Ideally, installation should start as soon as you press “VM->Install Parallels Tools…â€. If it doesn’t happen – you should manually browse to My Computer, open the CD device and click the “PrlTools.exe†file.

    * CPU usage is rather high when VM is in idle/paused state. Definitely, it should be close to zero in this case. We’ll fix this problem.

    * Still there are kernel panics possible when using PW. We apologize to everyone experiencing this nasty behavior. Please, if come across any grey screens, send us the panic.log as well as some additional info as described at

    * Guest mouse responciveness may be far from ideal. Artefacts are possible on the screen when dragging windows/browsing menus. Being fixed now. The workaround found by the community is:
    - While in guest, enter the Display properties, find Settings tab.
    - Click Advanced button.
    - In the window opened, browse to "Troubleshoot" tab and move the slider one notch left.

    * Keyboard input problems:
    - "F8" button doesn't work. Use Fn+F8 combination instead.
    - "|" button doesn't work. And no workaround for now

    I’ll keep updating the list. Networking issues are not covered yet as well.
    Last edited: Apr 9, 2006
  2. eduo

    eduo Bit Poster

    PW opens new safari instances. Can cause problems

    There is a nasty problem with uising the help in Parallels Workstation. For some reason the application, instead of either using the "open" routines for HTML files fires up a new Safari application instance.

    This is annoying in most cases but when using third-party Safari plug-ins it can lead to very NASTY consequences. In my case I have quite a few plug-ins and I'm trying to isolate the actual combination but I suspect Saft.

    What happened is that when I opened the help page through the PW menu item a new Safar instance and Saft told me it thought Safari had crashed, but in reality was running already. I copied the URL and closed that safari instance to go to the one I had already opened. Later yesterday I closed Safari and when I tried to open it again it wouldn't open. After some basic investigation I noticed Safari was an empty .app folder. No contents in the application at all. I had to recover from a backup to have a functional Safari going again, as it can't be easily downloaded or re-updated.

    Parallels should either have a webkit minibrowser in PW or use the normal "open URL" function of MacOSX to use the default browser (the same that the "open" command in the terminal does).

    Cross-posted at
  3. wjlevin


    And you're even going to work the weekend to get it fixed! ;) Many, many thanks!
  4. jasonbuzz


    Keyboard and mouse issues running WinXP

    I noticed that the decimal key doesn't respond and also when holding down any key to repeat a character or space there is no response. As for the mouse, it seems jittery with a slow response time.
  5. Lee


    Decrease HW acceleration for more speed!

    Someone figured out:
    In XP, go to Display Properties, Settings, Advanced, Troubleshoot, and slide the slider down one notch, things speed up considerably, particularly mouse tracking and menu hiliting.
  6. STim

    STim Super Moderator

    Lee, thanks for reminding. How come did I forget about this beautiful workaround found by the community...
  7. roscoe13


    Any progress for those of us who are unable to boot off of any physical CDs or CD disk images? I can't get it to boot anything other than a floppy image or the hard drive. I know both Parallels & the guests can see the physical drive, if I tell it to boot the physical CD first, it gives a pop-up about there not being a disk in the drive, and if I boot a DOS floppy image with CDROM support I can read the CD. Trying to boot from a physical CD or CD image I always get the no boot device error. All 6 of the CDs I've tried boot just fine under Q...

  8. snit


    The lack of key repeat is a MAJOR annoyance, especially when delete only removes a single character...
  9. sunnfun



    Is sound not working a known issue? Ben on the blog saif that sound would be working in beta2. I have to run CBTs and need sound... :(

    Otherwise it's a great product and I have just pre-ordered my copy.
  10. dkwong


    How about allowing the host and guest OS to share the same network interface and still be able to talk to each other? Right now, I have to use en0 for the host and en1 for the guest. Otherwise, the two can't see each other so I can't share files back and forth.
  11. OneSadCookie


    suspending the VM doesn't prevent the issue for me, unfortunately :(
  12. Bandito


    It works for me, using Beta 2 build 1658.30
  13. Bandito


    I have no wireless network in work, and no wired network at home. I have to change from en0 to en1 when I want to work at home, and back again at work, shutting down the guest each time. It would be great (really, really great.....) to be able to just grab whatever network connection the host is using.

    The sharing issue is a real pain. At the moment I am using a separate PC as an intermediate connection - sort of defeats the purpose!!
  14. spilker


    Well, i´m experiencing the same problem. The button to boot from a real cd/dvd is disabled and even to boot from the iso image i created from my suse linux dvd i can´t boot the guest os. As i´m new to Mac OSX, may i ask how you you create a working floppy disk image?
  15. bgreat


    Network sharing with OS X


    I was able to get network sharing working to my MacBook Pro from Windows XP SP2 by simply enabling the Windows Sharing on the Mac and then directly browsing to the Mac by entering the IP address in the Start->Run... box. I could not do a full network browse and see the Mac listed, but entering the IP immediately came up with a password dialog. Entering my Mac login info, I then was presented with all the files...

    I have attached a jpeg showing the same folder open on my Windows and Mac desktop.


    Attached Files:

  16. Bandito


    I could do the same with Beta 2v1, but not with v2.
  17. TimboFoo


    Something definitely broke in networking between Beta1 and Beta2 -- I cannot connect to a webserver on my host machine anymore (even if i just try a raw telnet to the port from VM to Host IP) even though I can ping the host machine. Tried all the obvious stuff (firewalls on both ends, etc) but no luck: seems to be a problem in Parallels itself. Worked fine until I upped to B2 this morning.
  18. dailo


    Ah so I am not going crazy, thought I was the only one with the networking problem in v2. With v2 everything works over wireless but not over ethernet, v1 everything works over ethernet but not wireless. However ever since I upgraded to V2 I have not had a single kernel panic, but I might need to go back to beta v1 when I need to use ethernet connections.
  19. ZBoT


    beta3 not working correctly in extended desktop

    Hi! I am running build 1658.42 and I am having trouble running Parallels in an extended desktop on my MacBook Pro. I use an external monitor as my primary screen and the MacBook's display as an extended desktop. When I try and use Parallels in the extended desktop (MacBook screen) it allows me to click into the VM and move the mouse around, but once I try and click something it makes the mouse cursor jump out of the VM and back into OS X (like when you press ctrl-alt). When I move it over to the main display (external monitor) everything works correctly.

    In the final product I would love to have Parallels running fullscreen on the extended display, while using OS X on the main display. Just thought I would post this. Thanks for reading!
  20. ZBoT


    This problem is fixed if you install the parallel tools. Sorry for the confusion!

Share This Page