Parallels + WoW running concurrently = BOOM!

Discussion in 'Parallels Desktop for Mac' started by sydbarrett74, Sep 28, 2006.

  1. sydbarrett74

    sydbarrett74

    Messages:
    61
    SOLVED: Parallels + WoW running concurrently = BOOM!

    I have encountered a problem with all builds of Parallels since version 1910, and I suspect it's related to 64-bit support (I'm on a Mac Pro, 4GB, quad core Xeon). If I run the Mac version of World of Warcraft client and have a Parallels VM open at the same time, my machine gives a kernel panic and I have to restart the box. Here is the logfile:

    panic(cpu 0 caller 0x003A2287): getPhysicalSegment() out of 32b range 0x15ae01000, len 0x1000, class IOGeneralMemoryDescriptor
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x47b2b658 : 0x128cdb (0x3c99c4 0x47b2b67c 0x131cdf 0x0)
    0x47b2b698 : 0x3a2287 (0x3edad8 0x5ae01000 0x1 0x1000)
    0x47b2b768 : 0x3a41e5 (0x7178e00 0x0 0x0 0x6866004)
    0x47b2b788 : 0x70340c (0x7179f40 0x0 0x0 0x0)
    0x47b2b7d8 : 0x710689 (0x51aca000 0x47b2b820 0x0 0x749791)
    0x47b2b848 : 0x74da55 (0x6816004 0x7176204 0x0 0x2)
    0x47b2b8d8 : 0x717e4f (0xc1d0003a 0xbeef0351 0x2 0x2)
    0x47b2b918 : 0x70e99f (0x47b2bc34 0x47b2bbd8 0x0 0x61979a4)
    0x47b2bbf8 : 0x705285 (0x0 0x600d600d 0x7024 0x47b2bc34)
    0x47b2bca8 : 0x91097c (0xc1d0003a 0xbeef0351 0x2 0x2)
    0x47b2bd18 : 0x3b0605 (0x6eee000 0x6bbb88c 0x6bbb890 0x6bbb894)
    0x47b2bd68 : 0x18a230 (0x6eee000 0x14 0x6224fc8 0x0)
    0x47b2bdb8 : 0x12b498 (0x6224fa0 0x6bbb864 0x0 0x0)
    0x47b2bdf8 : 0x124af1 (0x6224f00 0x0 0x2c 0x47b2bedc)
    0x47b2bf08 : 0x1959e7 (0x47b2bf44 0x0 0x0 0x0)
    0x47b2bfc8 : 0x19b18e (0x6a67d80 0x0 0x19e0b5 0x69f4000) Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.GeForce(4.3.6)@0x8d9000
    dependency: com.apple.iokit.IOPCIFamily(2.1)@0x5de000
    dependency: com.apple.iokit.IOGraphicsFamily(1.4.4)@0x6d5000
    dependency: com.apple.iokit.IONDRVSupport(1.4.4)@0x6f0000
    dependency: com.apple.NVDAResman(4.3.6)@0x6ff000
    com.apple.NVDAResman(4.3.6)@0x6ff000
    dependency: com.apple.iokit.IOPCIFamily(2.1)@0x5de000
    dependency: com.apple.iokit.IOGraphicsFamily(1.4.4)@0x6d5000
    dependency: com.apple.iokit.IONDRVSupport(1.4.4)@0x6f0000

    Kernel version:
    Darwin Kernel Version 8.7.2: Tue Jul 25 23:09:54 PDT 2006; root:xnu-792.10.96.obj~3/RELEASE_I386

    Model: MacPro1,1, BootROM MP11.005C.B01, 4 processors, Dual-Core Intel Xeon, 2.66 GHz, 4 GB
    Graphics: NVIDIA GeForce 7300 GT, NVIDIA GeForce 7300 GT, PCIe, 256 MB
    Memory Module: DIMM Riser A/DIMM 1, 1 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser A/DIMM 2, 1 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 1, 1 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 2, 1 GB, DDR2 FB-DIMM, 667 MHz
    Network Service: Built-in Ethernet, Ethernet, en0
    Network Service: Parallels Host-Guest Adapter, Ethernet, en2
    PCI Card: NVIDIA GeForce 7300 GT, Display, Slot-1
    Serial ATA Device: ST3500641AS P, 465.76 GB
    Parallel ATA Device: PIONEER DVD-RW DVR-111D, 408.65 MB
    USB Device: General Purpose USB Hub, Up to 12 Mb/sec, 500 mA
    USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA
    USB Device: HP USB WHEEL MOUSE, HP, Up to 1.5 Mb/sec, 100 mA
    USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA
    USB Device: ActionStar KVMS, ActionStar, Up to 1.5 Mb/sec, 500 mA
    USB Device: USB Device, Up to 12 Mb/sec, 500 mA
    FireWire Device: built-in_hub, unknown_value, Unknown
     
    Last edited: Oct 10, 2006
  2. sulam

    sulam

    Messages:
    3
    I have exactly the same problem with 1918, same video card, same system but slightly more memory (5G).

    1920 doesn't start for me, same problem listed on other threads here, so I guess I'm waiting for the next update.

    James
     
  3. sydbarrett74

    sydbarrett74

    Messages:
    61
    I guess we have to keep in mind, the dev team *did* say that 64-bit support is preliminary and they haven't worked out all the kinks yet, and user beware, and all that good stuff. :)
     
  4. rufosx

    rufosx

    Messages:
    22
    I sometimes get this crash as well and went looking on the WoW support forums. Looks like if WoW and/or the nVidia driver are trying to do something above the 2 GB mark in memory, it will crash. So if you've got Parallels up and running, you're probably going to force WoW above the 2 GB mark.

    I'd say Blizzard needs to find out how Parallels fixed their 2 GB memory problem.
     
  5. unused_user_name

    unused_user_name

    Messages:
    495
    If that is the case: Try running WOW first, and let it allocate all the memory it needs before you run Parallels.

    Maybe that will keep it below 2GB?
     
  6. sydbarrett74

    sydbarrett74

    Messages:
    61
    This does not work either. If they're running concurrently at any point, regardless of which one starts first, WoW will eventually crash, bringing down the entire machine. In fact, the problem is even more sinister. If I QUIT Parallels and start WoW, it will crash. Only will rebooting and clearing Parallels entirely out of memory allow me to run WoW without crashing. And this problem only started when I installed the build that turned on support for 'big RAM' machines. Under older builds, WoW and my VM would co-exist peacefully, albeit they would both be hella slow and barely responsive enough to be usable. This clearly tells me that support for systems with more than 2GB of RAM still needs a lot of work...
     
  7. sydbarrett74

    sydbarrett74

    Messages:
    61
    Is an actual Parallels employee going to comment on my problem, or am I just going to be ignored?
     
  8. palter

    palter

    Messages:
    243
    Given that it's a bug in WoW and/or the Nvidia driver, I don't see why Parallels should address it.
     
  9. sydbarrett74

    sydbarrett74

    Messages:
    61
    I have posted a message on Apple's support forums -- we'll see what *they* have to say. FWIW, Blizzard said it wasn't their bug/problem. All of this finger-pointing and 'notme-ism' is really starting to make me angry. To paraphrase Mark Knopfler from Dire Straits, 'if you point your index finger at someone, remember that you have three small fingers pointing back at you' -- so somebody please take responsibility for the issue!
     
    Last edited: Oct 6, 2006
  10. fmantek

    fmantek

    Messages:
    6
    not just WoW, not just nvidia

    I have the ATI 1900XT in a 3.0 MacPro, i get the same crash, not just with WoW, but with other Mac Games as well.

    I am not terribly concerned right now, it's just something to remember for the moment.

    Frank
     
  11. sydbarrett74

    sydbarrett74

    Messages:
    61
    Sounds like it *is* at least partly Parallels, partly with WoW. To wit, a comment from someone over at Apple:
    --------
    think it is right in front of our face

    >panic(cpu 0 caller 0x003A2287): getPhysicalSegment() out of 32b range 0x15ae01000

    It seems like an issue of the 64 bitness of the Mac Pro.

    I've heard already Boot Camp initially had trouble with that and so did earlier versions of Parallels. Maybe this is another one of those cases.

    Think about it, it is saying it is trying to go out of the 32 bit range.


    So it sounds to me like either Parallels and/or WoW are not '64-bit clean' fully yet....
     
  12. sydbarrett74

    sydbarrett74

    Messages:
    61
    Another thing I've noticed is that if I edit my VM properties and limit the RAM allocated to 1024MB (exactly 1GB), the problem does not occur. So I'm wondering if having WoW and Parallels in memory at the same time is pushing against some arbitrary memory limitation within OSX for how much RAM can be allocated to all running user processes.

    Let us also not forget that OSX on Intel is still probably very buggy. It doesn't have the approximately ten years of legacy that the PowerPC version has -- remember, OSX started life in the early '90s as a joint project with IBM called Taligent. Even the NeXTstep code acquired from NeXT that runs on PowerPC is at least ten years old.

    Rather than taking an old copy of OpenStep for x86 and bringing it up to snuff (which would've been silly), they simply took the at-the-time current release of OSX and ported it. Not only are you dealing with a change of manufacturers and processor brands and families, but Core is an entirely new microarchitecture, and I'm not positive that Apple's engineers have come even close to refining and optimising the OS code to run on it problem-free.
     
    Last edited: Oct 9, 2006
  13. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    Here is our analysis of this problem:

    This panic was caused by “com.apple.GeForce” driver, installed in your system.
    It caused "getPhysicalSegment() out of 32b range" panic.

    This panic is called inside the implementation of Apple IOMemoryDescriptor class
    as the result of "high" memory allocated with legacy "getPhysicalSegment" method.

    So, the only reason of this panic is "non-64-bit-ready" GeForce driver, that called
    legacy IOMemoryDescriptor::getPhysicalSegment() method. The best solution here
    will be to file a bug with your driver manufacturer and recommend to use the
    IOMemoryDescriptor::getPhysicalSegment64() call.

    The only way Parallels may be related to this problem is heavy memory usage that
    causes this bug to appear more often.

    Regards,
    Max
     
  14. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    In fact, it sounds like GeForce driver is not really 64-bit ready as it caused the crash here ...
     
  15. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    We've analyzed the problem.
    This crash is not related to Parallels Desktop as it was caused by the problem in GeForce driver (see my full explanation in this thread).
     
  16. sydbarrett74

    sydbarrett74

    Messages:
    61
    You're absolutely right, and I erroneously pointed the finger at you guys. In fact, a tech support guy from Blizzard confirmed that they have an open ticket with Apple and Nvidia about this very problem. The video drivers that Nvidia has provided to Apple for inclusion in OSX are riddled with bugs. The TSR even confirmed that this problem happens with *many* games and other apps that make heavy use of graphics hardware, and that it's simply a coincidence that I noticed it happening whilst using Parallels. Let me share the email I received from the Blizzard employee:
    --------
    Hello Victor,

    This is already a known bug that has been filed with both Apple and Nvidia. It is a driver issue and all I can suggest is setting your RAM to be recognized as 2GB at this time.

    Sincerely,

    Justin K.
    Blizzard Entertainment
    Technical Support Representative
     
    Last edited: Oct 27, 2006
  17. sydbarrett74

    sydbarrett74

    Messages:
    61
    I've found empirically that using sudo nvram boot-args="-legacy maxmem=2512" and thus enabling 2.5GB also works...that extra half gig is nice and makes things run a little better...you might want to update the FAQ or make this sticky....
     
    Last edited: Dec 4, 2006

Share This Page