PD 4.0, XP VM - Focus Issue, VM Unresponsive

Discussion in 'Windows Guest OS Discussion' started by nz_skater, Nov 13, 2008.

  1. nz_skater

    nz_skater

    Messages:
    19
    Have run into a strange issue with the latest PD4:

    Sometimes when switching back and forth between the VM in window mode and my Mac environment I find that, when clicking into the VM's window, that I end up with an unresponsive VM. The resolution is to click the window of the VM itself, which seems to capture the focus correctly, but clicking inside the VM, say in a window in XP, nothing happens.

    Anyone else find this?
     
  2. musk

    musk

    Messages:
    18
    I'm not sure if it's the same issue or not but I can't get my upgraded XP guest to respond at all to mouse clicks or keyboard input. I can restart, suspend, etc. at will using Parallels itself. Within the XP guest I have a spybot dialog asking if I should allow a change and Parallels Internet Security asking if I want to install it. Of course I can't answer those dialogs or do anything else in the guest.
     
  3. lfdiaz

    lfdiaz

    Messages:
    1
    I also have the same problem with an XP VM that I imported from Fusion using the Transporter tool. The VM doesn't accept any keyboard or mouse events.
     
  4. Flagg

    Flagg

    Messages:
    218
    Hello,
    you can try a Parallels Tools reinstallation: Virtual Machine -> Reinstall Parallels Tools. Does this help?
     
  5. musk

    musk

    Messages:
    18
    I don't have Parallels installed currently but no, I wouldn't have been able to do that because I literally can't do anything in the guest without mouse and keyboard.
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    I guess, you need to boot in safe mode for Virtual machine and delete mouse and keyboard devices
     

Share This Page