PD12.2 + Windows 10 creators update = Keyboard not working, explorer freezing, task scheduler crash.

Discussion in 'Windows Guest OS Discussion' started by DawidM, Apr 25, 2017.

  1. DawidM

    DawidM Bit Poster

    As mentioned in many other threads I have similar but a little different problem with PD12.2 and Windows 10 (creators update - installed from scratch 3 days ago).

    At first after fresh install everything was working smoothly - I have one restore point (clean system & parallels tools), where system is starting normally.

    After installing everything that I use to work (Office 2k16, Visual Studio 2017, MS SQL management studio, tortoisegit) everything was working perfectly (3 days ago). But yesterday without any reason (nothing has been added/Installed, nothing has been changed in configuration - I only restarted machine increasing ram) the problem come back (I reinstalled previous installation because of the same symptoms):

    1) Task scheduler won't start (error connected with UBPM.dll - no details at log at all).
    2) Explorer freezing/crashing on startup - only solution to run it is to manually start ctfmon.exe (what for? on fresh install with tools only ctfmon is not running!) and force explorer to restart. After hour of freeze explorer start showing icons, but for example there is no battery icon (after lunching ctfmon & restarting explorer battery comes back).

    I tried every soultion with ctfmon (starting from adding it to startup list on autostart folder, using registry etc.), but ctfmon won't start on system startup. I also don't think, that ctfmon is necessary for normal system operation (as on fresh install it wasn't running).

    I'm not going to do another reinstall, because it is fresh install without any crapware, viruses etc. - it's clean with only needed software installed. In fact everything was working smoothly before weekend (I restarted machine several times and it was running great), and after weekend without ANY change after restart it hangs on explorer and come back to point with previous installation.

    If You want suggest option with ctfmon - please don't. It's not a solution, it's not working and I don't understand why You are suggesting sth that is only partial solution for some people. Reinstalling tools? Done several times. Nothing helps at all for now. Please investigate problem and find solution, because for now parallels is crap and is useless (maybe time to migrate to VMware back).
  2. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Hi @DawidM, for initial investigation, can you please send us a technical data report? Via Help menu > Send Technical Data...
    Please post the report ID here.
  3. FloLen

    FloLen Bit Poster

    same here - macbook pro (2015) 10.12.4
    win10 on 1703 (15063.250)
    after first aprox. 10 min the system "works" but in the first minutes, taskbar freezes, etc.
    p.s.: and i always have a black screen after 1st attempt of starting paralles, have to "stop" the vm, boot again and then it works
  4. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Hi @FloLen, can you please also send us a technical data report? Via Help menu > Send Technical Data...
    Please post the report ID here.
    FloLen likes this.
  5. DawidM

    DawidM Bit Poster

    No, I can't because I reinstalled system doing snapshot after each program installed. For now everything is working, but we will see how long...
  6. FloLen

    FloLen Bit Poster

    hello dmitry, made a report - here is the id: 177054620
  7. TS-Micah

    TS-Micah Product Expert

    After looking into the issues being described here, I've been having these issues for quite some time now and it has come to a head this week. I have LOST approx. 2+ days of productive development work due to the latest issue. Because task manager doesn't start my event log is littered with errors about scheduling the Security Protection Service not being able to be scheduled.

    At first it started with the creators update (which I didn't start) after rebooting.... black. I reset the VM and the screen displays. (Pretty much EVERY time now). Minor inconvenience but whatever, I can deal with that. Then a snapshot happened, and on Monday I Explorer and the Start Menu & Win Apps unresponsive. I thought this may be due to corrupted Start Menu TileLayer database (I've experienced this before because of a snapshot or something else) - but nope. I found after 2+ days that it's an issue with the Task Scheduler that something has been corrupted. It takes nearly 45 min before it even becomes usable. It's now absurd!

    Come ON!!!!! At this point I'm pretty pissed off. I've been needing to get development time on a big project I'm already behind on and NOW THIS?! FML?!

    I submitted a report here's the ID: 181054637

    At this point, I'm copying the VM to a external drive to back it and and I am CLEAN installing Windows 10... There goes billable time... Still not a happy camper about this. Something needs to be done about the black screen on first boot - my hunch is that it is this and having to reset the VM that caused this. I even tried rolling back to the snapshot I had, same thing...

    UPDATE 2:
    The clean install of Windows seems to be working well although I still occasionally get the all black screen at boot up. Instead of just resetting the VM (b/c Restart/Shutdown is NOT available on the login screen) I figured I could use Microsoft Remote Desktop (available in the App Store) to connect to my VM and restart it. I ran into some issue(s) with it at first but I had to change my settings to use Native Resolution and it seemed to work. After logging in this way, I'm able to shutdown/restart the VM from the RD connection. I would also note that in the error logs I noticed that the WDM failed to start which leads me to believe there is an issue with the Parallels Display driver(s).
    Last edited: May 26, 2017
  8. FloLen

    FloLen Bit Poster

  9. RichardG7

    RichardG7 Bit Poster

    I too have the same issue and only appearing with the recent 12.2.0 (41591) version. I was advised to follow the steps here: http://kb.parallels.com/uk/122922

    I have succeeded in running the DISM tool (all fine) but reinstalling all applications is not an option for me as this is a Bootcamp partition (not a VM image) and not something I can trivially backup and restore (years and years of apps on here).

    I notice the system switches to the GPU when moving across to the Parallels VM. The inability for a basic Windows service to start (Task Scheduler) is a worry for me.
    KrisJ1 likes this.
  10. ChristopherM2


    I've submitted report ID 186496211 documenting similar issues as well.
  11. KrisJ1

    KrisJ1 Bit Poster

    I am affected by the same issue. Exactly the same.

    A crappy video showing the phenomenon:

    Windows version: 1703 (OS Build 15063.332)
    VM Software: Parallels Desktop Pro 12.2.0 (41591)

    This setup has been running fine for months (W10 on PD Pro 12, obviously with the occasional updates) until recently, and without any installation of additional software, except for updates of W10 and PD, login slowed down significantly.

    1) Cold boot of the VM to the sign-in screen is still fast.
    2) Entry of sign-in information using the keyboard is still fine
    3) After sign-in, the desktop instantly appears as before, _however_ issues start at this point:
    • the task bar will flash frequently
    • The Cortana search box in taskbar shows a flashing and/or wrongly aligned microphone icon
    • Trying to open start menu via mouse click or Windows key causes the entire desktop to flash
    • Hovering the taskbar shows the circular busy icon
    • While all this happens, CPU load is low, memory usage is low
    • Apps with shortcuts on the dektop can still be opened as fast as before
    • Ctrl+Alt+Delete can be used to bring up task manager and 'Run' can be used from there to start software
    • While all of the above happens, no typing is possible in any modern app such as e.g. the Edge address bar or any other text input field. Typing in cmd.exe or other classic apps continues to work
    • In the Event Viewer I can also see Task Scheduler cannot start due to a 'ubpm.dll' related error:
    Screenshot 2017-06-15 21.11.26.png

    At this point I am assuming that 'ctfmon.exe' is simply not running properly because task scheduler has issues.

    I have also posted about this on the Microsoft Community forums , no useful answers there yet.

    I have also been in touch with Parallels support (ticket #2410673) but other than the usual attempts:

    1) Try and create another user to see if the issue exists
    2) Try and do a re-install of the OS
    Nothing useful was done and no useful feedback was given (I don't blame the support guy, this is something for the development team and most likely Microsoft people).

    I prepared a report with ID 188829240 although the technician also created one for the ticket referenced above.

    That being said, I would really like to see a solution materialise, this has taken too much of my time already.


    Running system scan (sic /scannow) did not turn up issues.

    Update 2:

    After re-opening my support ticket referenced above, clearly mentioning this thread (to show I am not the only person affected), I was once again told to 'refresh the OS' while it is clear that will not help.

    Quite a frustrating experience: Parallels costs quite a bit of money, as does a W10 license and yet, the best support you seem to ever get is 'wipe your machine and install again', ugh...
    Last edited: Jun 15, 2017
    Dmitry@Parallels and FloLen like this.
  12. KenanI

    KenanI Bit Poster


    I have same problem...

    I prepared a report with ID 190096203

    Last edited: Jun 20, 2017
  13. ForrestC1

    ForrestC1 Bit Poster

    Same problem here, Mac Pro with latest updates of Sierra, and latest updates of PD 12. Stumbled here after trying Dell keyboards and a wide range of other things like the dev above has already done. I keep my VM's virgin OS and rarely boot them, no other software, not even Microsoft apps. Had none of these issues on same VM image of Win 10 Pro 64 using PD11. Uh oh, you know what that means? Yeah that's right... this is a Parallels 12 issue period, so just stop pointing fingers at Microsoft.

    I bought PD12 on a whim when I got an email about a big sale and figured what the heck, wish I'd stayed on PD11, it was working great. By the way, I maintain 34 physical stations with this same Windows OS on dissimilar hardware and none of them exhibit this behavior.

    The most embarrassing point of all of this is when I started searching for users with similar issues, they go back to January 2017. Sad, just sad. You think you might want to fix this? Hello. I hardly boot this VM so it's not that big of deal for me, but the OP and most of the other customers in here actually need what you sold them to work. Be nice if you actually decided to fix it. Just sayin'.
    FloLen likes this.
  14. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Hi @ForrestC1,

    Please give me more details on your use case and send us a technical report after reproducing the behavior.
    I've raised the priority of investigation on this thread to the top, but I need your help yet.

    @KenanI, i've went through the tech report you sent, and I see that mouse and keyboard are being grabbed and released (to and from VM focus) too often. I see that you're using the VM on two monitors in Full Screen. Please tell me how ofter do you move the mouse from one display to another? If you disconnect the second display and work on one, does the same behavior happen?

    06-20 13:14:38.776 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <released>. Reason: <GUI::GrabberDeactivatedReason>.
    06-20 13:14:38.779 F [HID_CTL] /prl_client_app:472:775/ Mouse is <released>. Reason: <GUI::GrabberDeactivatedReason>. Mouse type: <absolute>
    06-20 13:14:52.921 F [HID_CTL] /prl_client_app:472:775/ Mouse is <grabbed>. Reason: <GUI::GrabberActivatedReason>. Mouse type: <absolute>
    06-20 13:14:52.925 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <grabbed>. Reason: <GUI::GrabberActivatedReason>.
    06-20 13:15:01.090 F /prl_client_app:472:775/ handleInputSourceShortcutChanged. Type = 764
    06-20 13:15:01.090 F /prl_client_app:472:775/ nKeyCode = 31, nModifiers = 100000 nDirection = 0 bEnabled = 0
    06-20 13:15:01.090 F /prl_client_app:472:775/ nKeyCode = 31, nModifiers = 180000 nDirection = 1 bEnabled = 0
    06-20 13:15:01.192 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <released>. Reason: <GUI::GrabberDeactivatedReason>.
    06-20 13:15:01.194 F [HID_CTL] /prl_client_app:472:775/ Mouse is <released>. Reason: <GUI::GrabberDeactivatedReason>. Mouse type: <absolute>
    06-20 13:15:07.373 F [HID_CTL] /prl_client_app:472:775/ Mouse is <grabbed>. Reason: <GUI::GrabberActivatedReason>. Mouse type: <absolute>
    06-20 13:15:07.377 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <grabbed>. Reason: <GUI::GrabberActivatedReason>.
    06-20 13:15:13.399 F /prl_client_app:472:775/ handleInputSourceShortcutChanged. Type = 764
    06-20 13:15:13.399 F /prl_client_app:472:775/ nKeyCode = 31, nModifiers = 100000 nDirection = 0 bEnabled = 0
    06-20 13:15:13.399 F /prl_client_app:472:775/ nKeyCode = 31, nModifiers = 180000 nDirection = 1 bEnabled = 0
    06-20 13:15:13.507 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <released>. Reason: <GUI::GrabberDeactivatedReason>.
    06-20 13:15:13.510 F [HID_CTL] /prl_client_app:472:775/ Mouse is <released>. Reason: <GUI::GrabberDeactivatedReason>. Mouse type: <absolute>
    06-20 13:15:21.958 F [HID_CTL] /prl_client_app:472:775/ Mouse is <grabbed>. Reason: <GUI::GrabberActivatedReason>. Mouse type: <absolute>
    06-20 13:15:21.962 F [HID_CTL] /prl_client_app:472:775/ Keyboard is <grabbed>. Reason: <GUI::GrabberActivatedReason>.
    06-20 13:16:04.985 W [HID_CTL] /prl_client_app:472:775/ Switching mouse type from <AbsoluteMouse> to <RelativeMouse>.
    06-20 13:16:04.987 F [HID_CTL] /prl_client_app:472:775/ Mouse is <released>. Reason: <GUI::MouseTypeChangeReason>. Mouse type: <absolute>
    06-20 13:16:04.997 F [HID_CTL] /prl_client_app:472:775/ Mouse is <grabbed>. Reason: <GUI::MouseTypeChangeReason>. Mouse type: <relative>
    06-20 13:16:05.008 W [HID_CTL] /prl_client_app:472:775/ Switching mouse type from <RelativeMouse> to <AbsoluteMouse>.
    06-20 13:16:05.014 F [HID_CTL] /prl_client_app:472:775/ Mouse is <released>. Reason: <GUI::MouseTypeChangeReason>. Mouse type: <relative>
    06-20 13:16:05.019 F [HID_CTL] /prl_client_app:472:775/ Mouse is <grabbed>. Reason: <GUI::MouseTypeChangeReason>. Mouse type: <absolute>
    06-20 13:16:18.745 F /prl_client_app:472:775/ handleInputSourceShortcutChanged. Type = 764
  15. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Hi @KrisJ1, thank you very much for the detailed troubleshooting details and especially for the video. Indeed, our Technical Support suggested to install Windows 10 Creators Update and check how it behaves on your Mac. May I wonder if you installed a new Windows10 VM?
  16. Sam20

    Sam20 Bit Poster

    same issue. installing creator update won't help.
  17. ScottM7

    ScottM7 Bit Poster

    Me as well. I'm also presented with a "phantom user" when I first boot up, in addition to my normal login. Both have the same login name.
  18. ForrestC1

    ForrestC1 Bit Poster


    Just popped in to look up unrelated item and thought I'd check to see if my post was actually accepted. Kudos for that. I appreciate the escalation. As far as my use case, I maintain virgin installs with windows updates and nothing else. Once in a blue moon I'll fire up a copy of a VM and install some software to trial for real world use on physical stations or whatnot.

    I run PD on a Mac Pro w/ 32Gb RAM, single 24" monitor. I ran latest PD11/Tools and now latest PD12/Tools. As previously mentioned, exact same VM in exact same state (prior to any windows updates) did not exhibit this behavior in PD11. Same VM, same OS state, PD11 fine, PD12 problem. This pretty much sums it up.

    I ran all Win 10 Pro 64bit updates to present to see if it would fix, it did not. For now I just made a shortcut on desktop to launch ctfmon (once I can actually get to it that is), to stop the issue, and it immediately stops for duration of using the VM.

    As far as submitting technical reports I'm not trying to be unhelpful, just not worth taking the time for me. Your devs have got enough people saying "me too" to figure out this is an actual issue, not user ignorance. Tell them to try actually using their product.
  19. FransH1

    FransH1 Bit Poster

    Hi, I have exactly the same issues. Please fix this, very annoying. Just updates to PD12.2.1 (41615), still the same problems. Updated to Windows Creator, same problems.
  20. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Guys, @ForrestC1, we have released a hotfix for Parallels Desktop 12 version 12.2.1 (41615) where we've fixed an issue with VisualStudio (https://forum.parallels.com/threads...arallels-12-upon-awakening-from-sleep.339941/) and several more.

    Please let me know if this hotfix changes the VM behavior for anyone.
    If not, then we need you to try the following:

    1. This behavior might be related to Windows hiberboot (aka hybrid shutdown). Please disable this feature via command prompt using this command, then restart and check the results:

    powercfg -H off

    2. Try to re-create user profile following these steps: https://neosmart.net/wiki/corrupt-user-profile/#Fix_1_Registry_Editor. Check if ctfmon.exe now starts correctly.

    Will be looking forward to your results.

Share This Page