PD4 upgrade finally successful, but everything seems slower

Discussion in 'Windows Guest OS Discussion' started by jcncheng, Nov 12, 2008.

  1. jcncheng

    jcncheng

    Messages:
    7
    I spent 3 hours upgrading from PD3 to PD4 in my MBP early 2008 this morning. I started with a My-Boot-Camp VM created by PD3 and installed PD4. The conversion of PD3 VM to PD4 version was smooth but slow. When the conversion is done, I launched My-Boot-Camp VM again and Parallels tool was installed very slowly and stop a few times when couple of found-new-hardware windows pop up and stay forever. I rebooted the VM and same thing happened, Parallels tool never installed completely. I then remove the My-Boot-Camp VM and create a new one with custom option. But again, parallels tool never installed completely and stops in the middle. Finally I deleted the VM again and boot the machine natively in WinXP via bootcamp and remove parallel tool, and then boot into OSX and set up a fresh new VM again, and boom! parallels tool install correctly and everything seems to work nicely.

    But now I really don't feel the 50% increase in speed/performance. Everything seems slower than PD3 build 5626, even with 2 processors and 1500MB RAM allocated. VM boot up, software launch are obviously slower. Anyone notice PD4 is faster than PD3?
     
  2. eread

    eread

    Messages:
    80
    Apart from a Fedora Linux new VM installation (which was pretty good), I have found most things slower. For a laugh, I have even converted an MS-DOS VM and a Windows 98 VM. The DOS one is very slow (a small directory listing about half the speed I'd expect). Windows 98 will only boot in Safe mode after conversion from PD3 to PD4. When attempting a reinstall, it forces a scan disk. The scandisk might take an hour on a 40GB virtual HD. Booting in general, in safe mode, seems slow.

    I am hoping that there will be some small, simple fixes to realise the speed gains. PD4 is obviously a massive step forward in terms of features but the screws need some tightening.
     
  3. clauretano

    clauretano

    Messages:
    2
    I've experienced this as well with my Boot Camp VM. The speeds are awful. Overall, the boot camp in parallels experience is hugely improved (able to start without password, shut it down without having to go into the VM to initiate the shut down from the OS, etc) but it literally takes 4x as long to boot up as an identically configured VM with vmware fusion. I do like parallels more so I really would like to get this working.
     
  4. bucweat@rushpost.com

    bucweat@rushpost.com Bit Poster

    Messages:
    17
    same problems here...

    Macbook Pro 2.0GHz with 2GB memory. Startup is painful...CPU is pegged the whole time while the blue bar jerks across the screen, and it probably takes 4-5 minutes to boot. Parallels 3 booted in like 15 seconds. Once started its not bad, but I don't think it's as fast as Parallels 3.0 by any means. BTW upgrade toasted my Bootcamp install, so this is with a completely new Win XP install with SP3.
     
  5. jcncheng

    jcncheng

    Messages:
    7
    As some other users suggested in other threads, after rebooting the mac (and turn on the adaptive hypervisor), I got huge improvement in speed including VM boot up. I haven't time the VM boot up time but it feels faster than PD3 now. :) Looks great!
     
  6. JSAF

    JSAF

    Messages:
    6
    Similar issue with poor performance of PD4 c.f. PD3

    Unfortunately I do not have any solutions, just a similar problem.
    I upgraded to PD4 last week and, while the interface and features are great, the performance is far below that which I was getting with PD3. Most applications seem much slower and internet access is terribly slow. A game that worked under PD 3 is not working properly at all (I have posted this separately in the games thread on this forum).
    I tried re-installing parallels tools and have activated the adaptive hypervisor, but this does not seem to have improved things at all. I hope that there is an update that can improve things, or I might be forced back to PD3.
    James
    MacBook Pro, 2GHz, 2GB RAM, Parallels Desktop v4, Win XP SP2
     
  7. jcncheng

    jcncheng

    Messages:
    7
    make sure you have selected 1 CPU (instead of 2 CPU) in VM hardware config, i found that it speeds up things a lot
     
  8. JSAF

    JSAF

    Messages:
    6
    Thanks

    Dear JcnCheng,
    Thanks for the suggestion. Unfortunately, it is not the problem in my case (I had only 1 CPU selected, the default). I'll keep trying various things and see how it goes.
    James
     
  9. John@Parallels

    John@Parallels

    Messages:
    6,343
    Update was published , which is right now available at http://forum.parallels.com/showthread.php?t=31764
    The most of problem were fixed.
    Please navigate to that link, and download build 3540
    In post there are various instructions, how to fix problems.
     
  10. JSAF

    JSAF

    Messages:
    6
    Prompt reply

    Dear John,
    Thanks for your quick reply. Apologies for not checking for updates before I submitted my post. As I downloaded my version of PD4 on 19th Nov., I did not expect an update so soon. It's great that the 'team' is working so promptly on the teething problems. It must be mayhem for you mob at the moment! :)
    You'll be pleased to hear that I downloaded and installed build 3450 without a hitch. The overall performance and particularly the networking are much improved; thanks. I still have the problem with the game, but that is neither crucial nor urgent. I'm sure that it will be fixed with future updates. As I now have a (near) fully functional system operating under PD4, I am not gonna complain. I did not have anywhere near the problems that a few people seem to have had (judging by the comments on the thread that you directed me to).
    Thanks again,
    James
     
  11. tedevlin

    tedevlin

    Messages:
    10
    John,
    I'm not thrilled with my Boot Camp performance either. Can you answer some questions?
    Will a Windows XP VM perform better than a VM running off Boot Camp? How much better? (My Boot Camp VM didn't work at all in 3.0)
    How do I know how to set the number of CPUs, and whether it works? How about memory?
    It was suggested that the machine runs better if we just set the CPU to one. Why did you even put this option in?
    What does Adaptive Hypervisor do? Does it override my memory and CPU settings?
    How can we measure performance?

    The new documentation explains little.

    Mac Leopard 10.5.5
    Parallels 4.0 Build 3540
    RUNNING OFF BOOT CAMP
    Using Solidworks ONLY.
    Mac Pro Quad Core
    4 Gigs RAM
    Two screens
     

Share This Page