PD9 broke bridged networking?

Discussion in 'Windows Guest OS Discussion' started by pufferdude, Sep 5, 2013.

  1. pufferdude

    pufferdude Bit Poster

    I upgraded to Parallels 9 yesterday, then to build 9.0.23046 today. When I got home my Win8 VM would not connect to my access point via bridged networking, had to switch over to shared. Rebooted both Mac and VM and tried bridged again but the VM just wouldn't communicate. I'm not sure if this started with the latest build or the original build of PD9, but bridged networking worked fine for me prior to the upgrade.

    Anyone else seeing the same?
  2. In general, bridged networking through Wi-Fi is a very special and tricky case as access points have a lot of security options:
    - some of them do not allow to use MAC addresses other then host
    - some even do not allow to use more than one IP/MAC

    In general, you could see a special combo box on
    Virtual Machine -> Configure -> Hardware -> Network -> DHCP Server
    by default it should be set to Auto and this was how this check was working in PD8. You could try other options to find working one if intelligence is not working.

    Anyway, we will need a problem report from you (Help -> Report a problem) to proceed further if these options will not help.

    We do not recommend to use bridged networking over Wi-Fi due to reasons above.
  3. pufferdude

    pufferdude Bit Poster

    I understand the argument you make regarding bridged networking over wifi and its "trickiness", but the problem is that this has WORKED for years for me... at least since Parallels 7 and all through 8. Only when I upgraded to 9.0 (and/or the subsequent patch that was released soon after) did it break. Both the wifi at work and home is high-end enterprise Ruckus stuff... perfectly capable of handing out multiple IPs to the same Mac with ease, which it always has for me. Bridging the network is important when you're dealing with domain-joined Windows guests vs. hiding them behind NAT.

    The only thing that has changed in my equation is Parallels 9. Worked before, now it doesn't. I don't see the DHCP option you mention above under VM -> Configure -> Hardware -> Network on my PD9 install. I'm not sure if you're saying it should be there or used to be there but now is not. I will procedd with doing a problem report. Thanks!
  4. may be you have not switched to bridged mode to WiFi adapter back when checking the presence of this check...

    I understand your frustration, but the problem is that we have not changed anything else related to WiFi in PD9. Something went wrong. I apologise for the inconvenience.

    Can you pls post report number here for faster processing?
  5. pufferdude

    pufferdude Bit Poster

    Aha! I misunderstood you the first time. That worked! I had to go in and 1. change "bridge to default adapter" to "bridge to Airport", which allowed the DHCP option to appear. 2) Change "use generated MAC address" to "auto". 3. Bridging to wifi immediately started working and I was then able to change back to "bridge to default adapter" (I need that because I sometimes plug in via ethernet as well) and it worked fine, too.

    Thanks so much for the answer to the simple fix. I guess something just got "tweaked" in settings during the upgrade from PD8 to 9, somehow.
  6. yep. I got the point. This, indeed, is inconvenient. I will followup with a person responsible for the Network configuration screen.

Share This Page