PD9 (final) - Bug (report #28091179) - Incredibly sluggish mouse scrolling

Discussion in 'Windows Guest OS Discussion' started by Olivier, Aug 29, 2013.

  1. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Please see report ID # 28091179.
    This feels really wrong. The relay of up/down scrolling actions on the trackpad to Windows is completely broken. I have to move fingers by close to one full inch to get Windows to trigger a response.
    Next to impossible to work comfortably in Visual Studio for instance.
    It has been ongoing for the last 4 hours (since I upgraded) and I am becoming mad at it!

    Where is my backup so I revert to the last beta build ?... Had no such issue there.
     
  2. Olivier

    Olivier Kilo Poster

    Messages:
    610
    I have done more tests. PD8 (when I left it in June for PD9 beta) did not have that issue. PD9 didn't have that horrible bug in any of the beta I could try. And then suddenly the final release brings that stupid ugly wrong mouse / trackpad behavior. And now I'm reading that other customers have discovered this in some latest PD8 update ? Unacceptable. Contacted support using one my **PAYING** support tickets. It's been way more than 12 hours and I haven't even been contacted back, even only for information. When I see the time I will loose **trying** to work today, I would better convert straight to Fusion : I would loose 2 hours, but once for all.
    Parallels, hurry up, help me change my mind before I can't turn my eyes back.
     
  3. serv

    serv Parallels Developers

    Messages:
    804
    Olivier,

    I guess Visual Studio doesn't support smooth scrolling well. Try this:
    - start Regedit and expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID subtree
    - fully expand both VID_203A&PID_FFFC&MI_00 and VID_203A&PID_FFFC&MI_01 branches and find Device Parameters keys
    - under Device Parameters set VScrollHighResolutionDisable and HScrollHighResolutionDisable values to 1
    - reboot Windows
     
    Last edited: Aug 30, 2013
    RogerK2 likes this.
  4. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Bingo! You got it. Did that, fixed. I can't tell you how relaxed I feel to see this issue worked around, taking the amount of Visual Studio work I have to do.
    I can't blame you for an apparently sub-standard mouse support in Microsoft Visual Studio, though it came as a surprise with this release and could really give issues to other people in other applications which would work like Visual Studio regarding scrolling messages.
    Maybe some optional settings should be available in the VM configuration so that people could adjust that behavior without having to patch the registry.

    Anyway, and in between, thanks a LOT for this quick fix.
     
  5. RYinSF

    RYinSF

    Messages:
    1
    I'm having similar issues but my Win 7 guest OS doesn't have the registry item names noted under Device Parameters. Should I add the items? If so, are they binary or reg_dword or what?
     
  6. Olivier

    Olivier Kilo Poster

    Messages:
    610
    First get 100% sure that Parallels Tools are installed in that Win 7 guest. Install / re-install them if in doubt.
    Check you're using Parallels Desktop 9.
    Didn't you get mistaken due to a small typo in the post :
    "- start Regedit and expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\H ID subtree"
    The ending is supposed to read "...\Enum\HID". I hope the space did not lead you in error looking for the key.

    Else, I would have to suppose Parallels mouse devices ID are different depending on the guest OS and that my own experience with Windows 8 can't help you. But 'serv' might still help you better/easier than me if he/she still reading this thread.
     
  7. serv

    serv Parallels Developers

    Messages:
    804
    Parallels Desktop 9.0.23046 build now have an option to control smooth scrolling:
    VM Configuration > Hardware > Mouse & Keyboard > Enable smooth scrolling.
    Use this option instead of registry patch.
     
  8. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Great! Thanks for listening!
     
  9. joenst

    joenst

    Messages:
    1

    UAAAA - i just updated to 23046 - and now (after the automatic update of the parallels tools in the vm) my windows 8 hangs after the login screen in the welcome screen!!! shit.

    My luck is that i made an restore point befor i did that. After going back to the restore point i could login again - and then i tried the update of the parallels tools again - same result!

    The 23046 is shit!
     
  10. RogerK2

    RogerK2 Bit Poster

    Messages:
    1
    Great advice, works with Embarcadero RAD Studio X too. Thanks a lot!
     

Share This Page