Permissions Issues - Please Help...

Discussion in 'Installation and Configuration' started by SteBee, Jul 31, 2012.

  1. SteBee


    Hi All...

    I was previously using parallels 7 on a Macbook Pro running OSX 10.7 (Lion). The main reason I utilised the virtual machine was so that I could use Microsoft Office Pro Plus on Windows 7

    Everything was going great and I am really fond of Parallels for the simplicity and flexibility it offers - but now I have a problem which has taken up most of the working day today and I am still without a viable solution.

    The problem...

    My Macbook Pro was repeatedly frying its own logic board and apple gave me a completely new replacement under the terms of my apple care.

    So, before getting the machine, I backed everything including my original VM up (using target display mode) onto an external hard drive.

    I got my new computer and was advised by apple NOT to use migration assistant - he said he wouldn't be confident that files and folders would go across exactly as they should, instead recommending I take the time to 'clean things up' as I manually transfer across applications, files and folders.

    I installed Parallels from scratch (since I had the CD), got a fresh copy of windows and office (from disk images) before updating my OSX to Mountain Lion which in turn forced updates to Parallels...

    Everything works as it should. My problem lies with files located in the backup virtual machine which I really really need!

    Before backing up the VM file located in documents i took the time to ensure all of my outlook data files (.pst) were copied into the VM administrators documents - in a conveniently named folder titled 'outlook data files'

    It took me a while to locate them on the hard drive by mounting the backed up VM and navigating to Users > Administrator > Documents > Outlook Data Files and they were all there!!! I was overjoyed to see them, but the joy soon disappeared when I tried to copy them across to my Macintosh HD

    I don't have read / write priveledges to allow this and what is really frustrating is that I can't change these using the info pane in finder.. The permission section is greyed out, displaying read only...

    I don't know too much about this sort of thing, but I copied the 'where' line from the info pane which reads:

    /Volumes/.PEVolumes/PEVolume{30999943-cd88-4c98-ac2e-2f0bcff37a0d}/Users/Administrator/Documents/Outlook Data Files

    ...but as mentioned I can't do anything with them!

    I really need to know how to unlock the permissions for these files. I have been reading many possible solutions, some which suggest using terminal to unlock them...

    I have tried running the VM file (called windows 7.vm) using parallels but I get error messages asking if it has been moved / copied and it will never open thus eliminating the possibility of changing the permissions from within the old VM as the administrator...

    Would appear as though terminal is the way to go with this but I am quite nervous about going this way...

    Any help would be very gratefully received and much appreciated

    - Steve
  2. RonSchn


    This is clearly an OSX issue. I would have migrated the entire disk despite what the Apple guy said. What could you loose? If it wouldn't work you could go the way of a clean install anyway afterwards...
    Apple guys don't know everything, they are trusted too much...

    If you still have the full backup I recommend you use the assistant and install your entire backup.

    If not, you should first read some introduction about the file permission system:

    Also some helpful terminal commands:

    I am not a console/terminal guy, but I think you could do it with these... anybody please correct me if I'm wrong.
    But still, full backup restore is the best option by far.
  3. SteBee


    migrated the old VM from the hard drive.. Bosh - it worked...

    Can't believe it was that simple

    despite wasting a day i learned some valuable tricks with terminal :)

Share This Page