Phantom Windows XP Administrator account

Discussion in 'General Questions' started by dongreen41, Feb 24, 2007.

  1. dongreen41

    dongreen41

    Messages:
    1
    When I installed Windows XP on my Parallels virtual machine, there was a single account, "Administrator" with administrator priveleges and no password. I created an account in my own name, with administrator priveleges, logged off as Administrator, logged on in my own account and deleted, I thought, the Administrator account. Every time I restart the machine, I end up logged in as Administrator. I know this is probably a Windows problem, not parallels, but any help in driving a stake through the heart of this phantom Administrator would be appreciated.
     
  2. xeroed

    xeroed

    Messages:
    10
    your right it is probably a windows problem, and knowing windows the only real way to make it stop would be to completely reinstall windows >_<

    However, an alternative solution might be to back up your user files in your current account on a flash drive or removeable HD, erase YOUR account and rename the administrator one (Control Panel-> User Accounts). if you are extra worried about your files you could switch the last two steps as well, but either way I recomend backing up all your user files (which is a good idea, even if you aren't having compter problems).
    Also, if you havn't done so already, make sure you do some quick searches on Windows Help for User switching and such, just to make sure that you've tried everything they've suggested for deleting old users.

    Hope this was helpful
     
  3. joem

    joem

    Messages:
    1,247
    xeroed, if you're going to give advice, maybe you would like to confine it to things you have actually tried so you know they work, or include a statement that you are guessing.

    Reinstalling Windows wouldn't help here, but running userpasswords2 (which has been reported as useful but I haven't tried) probably would. AFAIK, the administrator account can't be deleted, but the automatic login can be turned off.

    What's a pepper?
     
  4. xeroed

    xeroed

    Messages:
    10
    k... well first off... I was making a joke about the reinstalling windows thing... and furthermore I was just trying to be helpful seeing as how no one else had anything to say on the subject.

    I really don't like being accused of given bad information... I tried to help given what I have tried and found to work... or what I speculate would work based on what I've HEARD too... so I dunno why you felt the need to call me out on this... but maybe if you want to do it in the future we could do it through a private message and solve this on a personal level. Thanks

    by the way, "I'm a Pepper" is an old Dr Pepper slogan that I liked.
     
  5. mejacobs

    mejacobs

    Messages:
    11
    Same problem here...

    I installed copies of Windows XP SP2 (OEM) on my iMac and MacBook using the Windows Express Install option. On both machines, accounts named "Administrator" were created. I created additional accounts: one an administrator account, another with limited rights. I set a password for all accounts, including the original Administrator account. Even after making changes to "User Accounts> Change the way users log on and off" Windows still logs on automatically to the Adminstrator account, bypassing any log on screen or request for passwords. Exact same behavior on both machines. The problem does not occur when I tried installing Windows XP on the MacBook using Typical Installation. (But I've had problems with some files not installing using that option...)
     
  6. dgoodin

    dgoodin

    Messages:
    3
    Phantom Administrator and worse...

    I had a similar experience with the phantom administrator account. It seems to have uncovered a problem with Parallels I don't know how to solve.

    Windows requires that you have at least one account with administrator privleges.
    Thats why when you first install windows and go to login screen you see "administrator".
    If you create another account and give it administrator privleges, then when you log in you don't see "Administrator" anymore, just the one you created and perhaps "guest". The administrator account is still there, its just hidden from you. This isn't a bug, its the way Microsoft designed it to work.

    Unfortunately, parallels seems to automatically log you in as Administrator, even if you have another account that you want to use by default, and thus you have to log out and log in again as youever you are.

    Worse yet, suppose you decide to change the password on the "Administrator" account. In my experience, Parallels still tried to login as Administrator but continued to use the "blank" password. This will hang system startup with an "incorrect password" window hidden under the "Windows is starting" screen. You then have to wait 20 minutes until the screensaver kicks in before you have control of your machine.

    I think parallels should fix this and leave you in the login screen.
     
    Last edited: Mar 2, 2007
  7. crazibri

    crazibri

    Messages:
    23
    Solution

    I fixed this on my machine very easily.

    go to Start > Run, type "Control userpasswords2". Then check the box that reads "Users must enter passwords...".

    Now you can add, remove, change users. Then click Apply. Now uncheck the box you checked above. The "Automatic logon" box will appear and you type in your username and password to auto logon to. CLick ok and you're done.

    Simple as that! :D
     
  8. joem

    joem

    Messages:
    1,247
    Parallels does nothing of the sort. XP does it. This has nothing to do with Parallels and is 100% an XP issue.

    Running userpasswords2 as I suggested several posts back in this thread will solve the problem.

    Reading the whole thread before posting will sometimes make the post unnecessary, and save us all time.
     
  9. mejacobs

    mejacobs

    Messages:
    11
    Worked for me. Thanks!
     
  10. madjack

    madjack

    Messages:
    8
    >> Parallels does nothing of the sort. XP does it. This has nothing to do with Parallels and is 100% an XP issue.<<

    I hate to disagree with you, but can safely say this issue is related to Parallels and not Windows XP. Having performed several dozen Windows XP installations, the normal Windows behavior I've witnessed for a non-domain-based install is this:

    1) An Administrator account is created with no password established. A Guest account is also created, but is disabled by default
    2) During the installation, additional user accounts can be specified, but again no password is required. They have administrator access by default
    3) After the installation is done, a restart is initiated
    4) On restart, only the additional user accounts are listed, not the Administrator account
    5) Clicking on one of the user accounts automatically logs in as that user.
    5a) Then, one can go to Control Panel | User Accounts to set passwords, change names, and make more restictive the user account and other additional user accounts, but not the original Administrator account
    5b) In XP Professional, one can go to Control Panel | Administrative Tools | Computer Management to manage users to a finer degree, including the original Administrator account
    5c) In XP Home, one must boot in Safe Mode to access the Administrator account to set the password. After that, booting in safe mode will list the Administrator and additional accounts, but a password will be required to access any password protected accounts, including the Administrator account.

    In all cases, once a password has been set for any account, including the Administrator account, logging into Windows using that acount requires a password.

    Except in a Parallels on Mac installation.

    Parallels bypasses the login screen and automatically logs onto the Administrator account. I don't know how, or why, but it does. Under normal circumstances, the Administrator account is not even visible, unless booting in Safe mode.

    So, this is not a Windows issue. It is a Parallels issue. Maybe it's fixable by running "Control userpasswords2", but that is not normally required by Windows and is at best a workaround to a nonstandard, and undesirable, behavior displayed by Parallels hosting Windows on the Mac.

    --
    jack
     
  11. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    not on my machines

    I get a big nice blue screen with my own admin log on name
    and my daughters user account (not admin) to chose from

    you should set up two user accounts with passwords

    MS recommends not using an admin log on for daily use

    Hugh W
     
  12. Purplish

    Purplish Kilo Poster

    Messages:
    521
    You don't have to use express install. You can always install windows the old-fashioned way.
     
  13. Revitonamac

    Revitonamac

    Messages:
    2
    Great tip!

    Great tip thanks, saved me a lot of hassle!!! :) Thanks!
     
  14. kfordham281

    kfordham281

    Messages:
    4
    It's definitely a parallels issue. I've installed XP hundreds of times and even after changing the logon properties in control panel it still auto logins with the administrator account. I used the express install with parallels and it did the same thing to me. Easy fix:

    Open regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

    and change the AutoAdminLogon key to have a value of "0" w/o the quotes. You'll notice the value is set to "1' w/o quotes before you change it.
     

Share This Page