Photoshop CC screen black after waking Mac from sleep

Discussion in 'Windows Guest OS Discussion' started by Brett_Conlon, Sep 11, 2015.

  1. Brett_Conlon

    Brett_Conlon Bit Poster

    Hi all,
    Strangely, whenever I put my Mac to sleep and wake it up or (less seldom) if the Mac screensaver kicks in and I wake it up, the Photoshop CC window will show black for all the images I have open :cool:. I can select the PS menu items and toggle between open images but they are all black. The only way I can get it to work again is to quit Photoshop and re-launch it. Sometimes I have to carefully remember what I was doing to know whether I should save the closing images or not!!! :eek:
    I've been hassled with this problem for a few years now but put up with it because it was initially only maybe once or twice a month when I was using my Color Think Pro app (for ICC profiles), to view 3D Graphs of ICC profiles. I thought it was a problem with the app, not Parallels. But, I think, since a Parallels update or two ago, it's now happening to most apps that seem to require more serious graphics crunching.
    Now that PS is a problem, it's hassling me almost every day now! :mad:

    I'm using Parallels 10.2.0 (28956) on a MacBook Pro (2GHz i7) running OSX 1010.3.
    Parallels Video settings are: Memory = 512MB and 3D acceleration = DirectX10. I tried changing the 3D acceleration to --whatever the other setting is-- but my Color Think Pro app was pretty unusable with the 3D graph (far too slow and jumpy).

    Please help! :(
    Best regards, Brett
    Last edited: Sep 11, 2015
  2. Brett_Conlon

    Brett_Conlon Bit Poster

    Wow, I can't believe someone else out there is having the exact same problem as me. Are you still putting up with it since you logged your post in 2015? I sure am!!! Sad nobody has responded to your post though. Maybe this is a less-known issue.

    I sure hope someone comes to your rescue so the both of us can fix this very irritating problem! I'm running Parallels 12.1.1

    Sincerely, Brett
  3. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi Brett_Conlon, thanks for reaching out. You may try the following:
    virtual machine Configuration -> Options -> Startup and Shut down -> on Windows close - keep running on the background.
  4. Brett_Conlon

    Brett_Conlon Bit Poster

    Cheers Paul,
    Before I activate it, what ramifications will come from this? Does that literally mean it's always running, whether the Laptop is put to sleep or the VM is Quit?

    Ta muchly!

  5. Ajith1

    Ajith1 Parallels Support

    Yes, the VM will be running in the background. The resources used by VM will not be released until the Windows is shutdown properly or Parallels Desktop is stopped.
  6. Brett_Conlon

    Brett_Conlon Bit Poster

    Hmmmm, these are the options I have. There's not a "Keep running" option under the "On Window close".

    Did you mean the "Always ready in background" option?

    Chz, Brett

    Attached Files:

Share This Page