Please help connecting to Linux using IPv6 on Parallels Desktop for Mac. (Maybe vnic0 bug!)

Discussion in 'Installation and Configuration' started by DonggyooL, Apr 10, 2015.

  1. DonggyooL

    DonggyooL Bit Poster

    Hi. I want to Linux from Mac OS using IPv6 on 'Parallels Desktop 10 for Mac Version 10.2.0 (28956)'.

    $ ifconfig vnic0
    vnic0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:1c:42:00:00:08
    inet netmask 0xffffff00 broadcast
    media: autoselect
    status: active

    vnic0 don't have fdb2:2c26:f4e4:: IPv6 address any more.
    I saw Parallels 6 inet6 address two at another thread titled with "Parallels IPv6 networking mess".
    inet6 fe80::21c:42ff:fe00:8%vnic0 prefixlen 64 scopeid 0x7
    inet6 fec0:0:0:fea9::2 prefixlen 64
    inet address don't need anywhere on IPv6. address works well with Guest OS Linux.
    Another mistake in Parallels IPv6:
    vnic0 and vnic1 use the fec0::/10 prefix for addressing. This prefix is deprecated with RFC 3879! Please use the Unique-local prefix fc00::/7 instead!

    On Parallels 6, inet6 fec0:: address is not correct. But this time; on Parallel 10; Parallels vnic0 interface have no inet6 addresses.

    How can I use vnic0 inet6 address? It seems to be Paralles 10 bug. Help me!
  2. Elric

    Elric Parallels Developers

    It is not a bug. The IPv6 address on VNICs were intentionally disabled, since there was a bug in Mac OS: when user tried to connect to some web-site which has both IPv6 and IPv4 address, Mac OS (likely it was 10.7) tried to connect to the site using IPv6 address. And, despite host didn't have any IPv6 default route, it took about 15 seconds before Mac OS starts using working IPv4 address of the site.

    It is possible to turn on the assignment of IPv6 address to vnic. This can be done by editing the network-configuration file of Parallels Desktop. Hope you are familiar with the vim editor:
    Quit the Parallels Desktop
    Start the /Applications/Utilities/Terminal and start the vim-editor
    sudo vim /Library/Preferences/Parallels/network.desktop.xml

    edit the line with SystemFlags to look like

    then save the file and start the Parallels Desktop.
  3. DonggyooL

    DonggyooL Bit Poster

    I saw that Parallels Destop 10 works too. Thank you.
  4. TresF

    TresF Bit Poster

    On an M1 Mac, Ubuntu 20.04 ARM64, I suddenly started having near-identical issues. Following the recommendation in this post doesn't help...
    • Pinging the IPv6 address using MacOS succeeds
    • Pinning the same IPv6 address using Ubuntu fails
    • Setting `<SystemFlags>vnic.assign_ipv6=1</SystemFlags>` per above does not help
    • Disabling IPv6 via `<IPv6Enabled>1</IPv6Enabled>` does not help
    I understand that there are ways to disable IPv6 on an OS-level, but something seems bugged. What's the solution to this same problem in 2022?
  5. NathanielC2

    NathanielC2 Bit Poster

    I have been trying to troubleshoot this exact issue. I also am on an M1 Mac, using Ubuntu Server 22.04. I am using the network Default Adapter for a bridged connection as is required for my use case to shell into the VM from other machines on my network. I can connect to it, and I can ping IPV4 addresses, but pinging IPV6 addresses stalls and never responds. I have another fresh Ubuntu 22.04 VM on another machine in Virtualbox and it does not have this issue. I left all of the default network configurations when installing Ubuntu on both VMs, but only the VM in Parallels has this issue.
  6. NathanielC2

    NathanielC2 Bit Poster

    An update because I can't see how to edit my post:
    If I plug into a dock with a wired connection, this problem goes away. So I only have this problem when on WIFI, but the Macbook will be on WIFI the majority of the time. I think I ruled out DNS resolution because nslookup works fine. So the narrowed down problem seems to be: Bridged / Default Adapter network, Host on WIFI, then the Guest cannot connect to IPV6 addresses.

    I don't think that it matters that it is Ubuntu specifically, I also tried the Fedora ARM that is listed in the Installation Assistant and it has the same behavior.
  7. gergnz

    gergnz Bit Poster

    I too am having this problem on any virtualised OS. It seems that DHCPv6 works, but not router advertisements. If I switch to bridge networking I get the router advertisement and get an IPv6 address, so something with the shared network doesn't like router advertisements.
  8. NathanielC2

    NathanielC2 Bit Poster

  9. gergnz

    gergnz Bit Poster

    Thanks for that @NathanielC2. Sadly I already have tools installed and thus hasn't changed my position.

Share This Page