Please, please PLEASE FIX THE MOUSE BUG!!!

Discussion in 'Parallels Desktop for Mac' started by krimple, Jan 2, 2007.

  1. krimple


    I downloaded and am using 3106 Beta 3, and am still having tremendous difficulty with the mouse if I attempt Coherence, suspend/resume, or resize any window. I just get the mouse drifting diagonally to the right no matter what I do.

    Please, please, PLEASE FIX THIS!!! Can you see I'm shouting? This was reported weeks ago, and it's driving me nuts.

    I have :
    - 17" Macbook Pro (original)
    - Apple Mighty Mouse
    - 2GB RAM
    - OS 10.4.8 with current patches.

    Thanks for any help. I can even beta test as I love this software.

  2. hhwong


    Mousing works fine in the currently released product (build 1970). If it's that problematic, why not just wait until 2.5 is GA? You shouldn't be using beta software in product environments anyway.
  3. krimple


    Because all of my other Beta experiences with Parallels have been excellent. I agree with you, if it isn't going to make the system unstable or make me lose my VM, to downgrade to 1970. Are there any issues with downgrading to 1970 at this point?

    Also, is the mouse bug being addressed? Can it be reproduced at the Parallels office?

  4. nycruza


    Since we have the same set-up and mine is working perfectly, it cannot be a Parallels problem persay but interaction with someother program or process you are running.

    I am using boot-camp and automatically disable the Apple Keyboard Manager program.

    If using boot-camp give that a try!

  5. darkone


    ive seen this before on PCs at work as a sign of the trackpad being faulty. quick call to Dell and they replaced the trackpad and the problem disappeared... so dont be so quick to SHOUT at Parallels about it ;)
  6. indycore


    NOT a "Hardware problem"

    This is a real issue with the 2-3 latest builds.

    BOTH on a Dekstop machine without trackpad and on my new MacBook Pro C2D.

    There is several reports here on the forum. But no answers to the bug!

    Could we at least have somone from the Paralells team acknowlegde this bug? Thats what public betas are alle about right? Reporting bugs and having them squashed in the next release?
  7. PeterP

    PeterP Bit Poster



    Posted a comment in regards to the downgrade question when you asked it in the "" thread.

  8. sandinak


    Frustrated in Virginia

    I agree .. and I am not using this in production.. but I *really* want to see the parallels group acknowledge this issue. Can someone from parallels please let us know this is being worked? I agree with the topic .. I have lost all my hair .. and my complexion is sallow now because of these mouse dropping issues.
  9. drval


    I'm not seeing this or any other mouse problem. I'm using 3106 on a MacBook Pro C2D.

    Perhaps this is really a Boot Camp - related problem?? I'm no longer using Boot Camp, only Parallels.
  10. bbf

    bbf Bit Poster

    I think it is more likely a badly initialized preference or something (it is definitely NOT hardware). I had this problem in 3094 when it first came out on a MBP. It happened the first time I used coherence - it then made parallels essentially unusable (I had been in full screen mode, and couldn't get the mouse to respond, just drifted down to the right, so I couldn't change the mode). IIRC correctly, the way I dealt with it was to force quit and restart parallels (several times), until I managed somehow to get it into windowed mode. When I finally got it out of coherence mode, it worked ok; then I shut down cleanly, saved the state of the machine, and restarted. Since then, coherence has worked fine in 3094 and 3106 without a hitch.

    Again, I don't remember exactly what I did, but essentially:
    1) The first time I started coherence I got the problem.
    2) The problem persisted until I managed to switch out of coherence (and toggle between full screen and windowed mode.) and cleanly save the state of parallels.
    3) Once I got it to work once, it worked every time after that.

    So that makes me think that there is some structure or whatever in the prefs file that needs to exist and be valid for coherence to work.

  11. drval


    I also raised the Boot Camp issue because, when I was using Boot Camp, and I used a Kensington Optical USB mouse, I would occassionally see the "drift" you describe. If I only used the trackpad I never saw the drift.
  12. Hugh Watkins

    Hugh Watkins

    I scrapped my mighty mouse and took it back to the shop and got a refund because my hand hurt

    better get a windows mouse
    mine MS Comfort Optical mouse 3000
    equally good for Mac OS

    even better if 5 buttons and wheel
    a mouse without batteries is the lightest

    Hugh B
  13. sandinak


    Still no acknowledgement from Parallels group

    I noted RC1 in the latest release.. if this goes live with this bug .. I will be extremely disappointed. EMC will win at that point.
  14. STim

    STim Super Moderator

    This problem has simple workaround - just disable mouse pointer trails. The mouse will stop drifting. Complete fix to be included in one of the forthcoming versions.

    Best regards,
  15. PeterP

    PeterP Bit Poster

    Thank you. Parallels is again the tool that lets me work in a Windows world on my MBP.
  16. Solistca


    Tim thanks for the tip.

    However, I still encounter the problem after following your directions. To be even more specific, when I went into the mouse options in Windows, the pointer trails option was already unchecked.

    Any other tips?

  17. Atomic_Fusion


    A couple of us have found a fix to the mouse drifting problem when you change your screen resolution in the VM, go to full screen mode, or Coherence. After Windows setup has reached 100%, reboots and enters the desktop to begin finding additional drivers, we have found that by cancelling all attempts to find and load drivers at this point for any remainder hardware, installing Parallels Tools, and then restarting the OS again, enables these latest features to work properly.

    Apparently there is a conflict at some point with Tools and any already installed drivers; conflicts that do not arise when Tools is installed first before these remainder drivers. Unfortunately, there doesn't seems to be any fix for OSes that already exist, like my own Bootcamp partition which I don't really want to go through the installation process again, with Windows plus all the software and tweaking involved, just to fix it. So I'm living with the quirks for now.

    So no workaround for already installed systems. But yes, a workaround for new installations, if done properly. If not, then it's another round a re-installation, unless somehow these drivers can be identified and reset to having not been assigned, so that Tools can be installed first.
  18. noovibe


  19. drval



Share This Page