Poor quality recorded audio

Discussion in 'Windows Guest OS Discussion' started by TucsonTom, Feb 14, 2008.

  1. TucsonTom

    TucsonTom

    Messages:
    56
    I am using Parallels 3.0 Build 5584 running Windows XP on a Mac Pro running Leopard 10.5.2 with 7 GB of RAM. I am using a Plantronics headset. When I record audio the quality is very poor. Lots of static, skips, etc. Prior to upgrading to OS X 10.5.2 everything was working fine. Also, in the previous build of Parallels I didn't need to select my usb microphone manually, it worked automatically. Now I need to select it or I can't record anything at all.

    I create online training programs for a living so this is a major issue for me. Please help!
     
  2. Alicia

    Alicia Parallels Team

    Messages:
    693
    Hello,

    what application do you use for audio recording?
    And what Host OS build did you previously have? I mean, before the upgrade to 10.5.2, did you have 10.5.1 which didn't have audio issues?

    As for connecting the microphone, please, ensure that in the Configuration Editor->USB Controller tab "Connect to the Guest OS" is chosen.
     
  3. TucsonTom

    TucsonTom

    Messages:
    56
    I was able to stop the problem by changing Parallel's settings for the VM.
     
  4. marklen

    marklen

    Messages:
    1
    What settings did you change?

    Hi Tom.

    I'm experiencing similar problems. What settings did you modify?

    Thanks.
     
  5. TucsonTom

    TucsonTom

    Messages:
    56
    I reset the sound in the Parallels configuration editor to use my headset. I've attached a screen shot showing my settings.

    Also, I later had some problems with the sound program I use, Audacity. Audacity's cut, paste, copy and other edit menu items were grayed out. So was Audacity's save menu items. Strange as it seemed, this problem was caused because I'd changed the Parallels VM to use my headset microphone for input, but to use the line out for output instead of the headset. Resetting the output to the headset solved the Audacity problems. I mention these problems and fixes to show that some strange things can happen.

    Hope this does the trick for you!
     

    Attached Files:

  6. TucsonTom

    TucsonTom

    Messages:
    56
    One other thing I just remembered doing. I moved my sound recording files from the Host OS (MAC OS X) to the windows My Documents directory. I may eventually run into a disk space issue, but I'll cross that bridge when and if I come to it.
     
  7. rowstyles

    rowstyles

    Messages:
    3
    i'm having a deeper issue. i can't get sound recording to work on my parallels win xp. i've tried EVERY combo of input devices on os x, parallels and winxp. i can get it to record from the intenral mic, but not internal input. help?
     
  8. beta_bob

    beta_bob

    Messages:
    3
    USB Audio Problems

    I am also having problems using a USB audio device connected to my VM that sound similar to yours, and there is a common element. The device I am using and your Plantronics headset use the same Micronas UAC3556 USB audio chip. If I let MACOS Core Audio open the Micronas device and I set the VM to use that core audio for sound, all is well. But if I let Parallels own the USB device and Windows opens the USB audio chip, I get lots and lots of noise. Spectral plots of both cases show a huge difference (Parallels/Windows looks terrible; MACOS core audio into Parallels is clean).

    Any ideas?
     
  9. rohneas

    rohneas

    Messages:
    3
    USB Audio Problems

    I am also having similar problems (skips and static). I am using a Samson Q1U USB microphone, on a MacBook Pro (Core 2 Duo 2 GHz) OS X 10.5.2, Parallels 3.0 Build 5584, Windows XP SP 2 with all updates. I'm recording using Camtasia Recorder 3.1.2.

    I've tried setting it as the default recording device in Parallels, I've tried Parallels in Windows and in Full-Screen (I haven't been using coherence). I've also tried muting the sound in Windows while recording (it does not appear to allow monitoring anyway, or it is off).

    The mic sounds fine in GarageBand, just not in Camtasia.

    I am also looking for any ideas.
     
  10. rohneas

    rohneas

    Messages:
    3
    Possible Solution

    This may not be a solution for everyone, but for me, it works well enough.

    1. In Camtasia/XP, turn on click sounds during recording and set it to not use a microphone input.

    2. In Garage Band/Mac open Garage Band (if it asks to create a new file, do a Podcast Episode).

    3. Click the record in Garage band.

    4. Start Camtasia recording.

    5. Say "Click" and click the mouse a few times on the screen

    6. Record video and sound

    7. Export from Camtasia as a Quicktime Movie

    8. In Garage Band, remove the dead air before saying "click" and sync it with the video

    This isn't perfect, but it is close enough for what I do. Also, Garage Band gives more control to vocals (you can do things like echo, reverb, or just change equalizer settings).

    I hope that posting this here helps someone.
     
  11. Ibsen

    Ibsen

    Messages:
    2
    Hey everybody.

    I have a problem, I hope someone can help me.

    I using parallels to run windows on a macbook and have installed logic 5.5. Logic runs fine. The problem is my soundcard, a Novation X-station. I have installed the drivers for the soundcard and chosen the soundcard in Logic, no problem. But when I open logic I get this message:
    ASIO: Hardware is mailfuncting (-999)

    Hope someone can help me?

    Thanks alot
    Cheers Martin
     
  12. vizbizwiz

    vizbizwiz

    Messages:
    1
    Perhaps this will work for you, too

    Hi,

    I'm running a MacBook (2.4Ghz, 4G, 250G) with Parallels 3.0 Build 5600.0 in OS X 10.5.5. I'm run XP patched to SP3 and the current (November 2008) evaluation copy version of Camtasia 5.0 running, of course, in XP. I have a Sennheiser PC-156 USB headset. I do not run in Coherence, keeping the XP side in a different OS X 'Space.' Here is what gets me good Camtasia audio:

    1. With the Sennheiser not connected, launch Parallels in its 'Space' (don't go into XP yet) and in the configuration/launch window, click 'Sound' to open those setting options; select 'Default Audio' for both 'Input' and 'Output.' Click 'OK' to close the dialog, returning to the configuration/launch window.

    2. Return to the Mac 'Space' and plug in the Sennheiser. Use 'System Preferences' to make sure that the Sennheiser is selected for both 'Input' and 'Output' under 'Sound.' Set the microphone level to about 2/3 of the way to max in 'Input.'

    3. Return to the XP 'Space' and launch XP by clicking the green arrow. Launch Camtasia Studio. Under the 'Tools' pulldown, select 'Camtasia Recorder.' In the dialog box that displays, click the 'audio options' link. In the dialog box that displays next, click the 'Audio Format' button. In the dialog box that displays next, open the 'Attributes' pulldown and pick a high bit rate digital audio sampling protocol that's appropriate to your recording. In my case (I'm doing Help videos for an application), mono is fine, so I select '48 kHz, 16 Bit, Mono 93kb/sec'. Click 'Ok' all the way back to wherever you want to go next in Camtasia.

    4. Here is something NOT to do: use the Camtasia auto volume-level setting wizard. For some reason it radically undersenses what's coming to Camtasia from the Sennheiser through OS X, Parallels, and XP. I think the best place to mess with the raw microphone input level is probably in OS X 'System Preferences.'

    My guess as to what's going on here has to do with how USB connections get handled by Parallels. For most data transfer bursty, asynchronous pass-through isn't particularly noticeable.

    Jeff
     
  13. tblack

    tblack Bit Poster

    Messages:
    91
    To Rowstyles: this is a mac problem, not a parallels problem. The mac "line in" jack requires a powered mike, an unpowered one won't work. Get yourself a USB mike.

    To others: this might be helpful, it comes of long experience with Parallels and windows voice recognition software:

    DON'T select your USB mike in the mac "sound" preferences;

    DO select your USB mike in the Parallels "sound" configuration editor;

    DO select your USB mike in the Parallels menu Devices>USB>[your mike]; you may have to repeat this step each time you open Parallels;

    In the Windows "sound" control panel, under the "audio" and/or "voice" tabs, for the input device choose [your mike], NOT "intel integrated audio".

    If you disconnect your USB mike, you may have to restart the VM.
     

Share This Page