Prevent parallels from locking windows VM when OSX locks?

Discussion in 'Windows Guest OS Discussion' started by loudog3114, Jan 29, 2011.

  1. loudog3114

    loudog3114

    Messages:
    6
    I have my windows 7 vm configured to never lock. No screensaver, and no display time out. Every time OSX locks, after my 10 minute time out, the windows 7 vm locks as well. Its really annoying to have to type in my account password twice, and on top of that the windows 7 vm is unresponsive for a good 20 seconds after unlocking. I dont know if parallels puts it in some kind of weird quasi-suspended state but its really annoying. Any way to disable this?
     
  2. Tony Carreon

    Tony Carreon Kilo Poster

    Messages:
    155
    that is odd, because i do not have this problem... no matter what my mac is doing as long as it hasn't gone to sleep windows is always running and unlocked. have you checked to make sure that not only is the screen saver off, but hibernate is turned off as well?
     
  3. loudog3114

    loudog3114

    Messages:
    6
    yep its all disabled.
     
  4. Tony Carreon

    Tony Carreon Kilo Poster

    Messages:
    155
    to be sure, i meant hibernate in windows, not in os x. i noticed that parallels created their own power plan though turning off the display and sleeping were set to never for both battery and plugged in options...

    also in the VM configuration i set Optimization -> Power to "Better Performance" instead of "Longer Battery Life"
     
  5. loudog3114

    loudog3114

    Messages:
    6
    yeah i got ya, no sleep or hib enabled.
     
  6. BenjaminRe

    BenjaminRe

    Messages:
    1
    found a workaround, but did you find solutions?

    I have the same problem. Parallels 8, bought January 2013 online so it's the newest version. I found a workaround: in the taskbar click the battery, More Power Options, Require a password on wakeup, Don't!

    But that's just a workaround Did any of you get a solution to actually stop it from locking the screen? Thanks -Ben
     
    Last edited: Feb 17, 2013
  7. costabas

    costabas Bit Poster

    Messages:
    38
    I have the same problem since some update in version 9. I don't like it. I locked the screen in OSX and when I came back (after ~ 1 hour) the VM displayed a message saying Click to Resume (the screen is semi-transparent). I clicked on the screen and I am prompted to enter the password. I don't have any screen savers on windows. Also, if I lock the mac and unlock it immediately, I am not prompted to enter the password in the VM, so there must be a timeout.

    How can we get rid of this?? I don't want to re-enter the password for the Windows VM. I didn't find any VM option related to this feature.

    Thanks
     
    Last edited: Nov 4, 2013
  8. RSG1

    RSG1 Bit Poster

    Messages:
    1
    well...I just joined this forum to find an answer to this question. Is this forum really worth looking at? Search feature doesn't find much else on this topic, and nobody has ANSWERED for nearly 2 years.
     
  9. RodB

    RodB Bit Poster

    Messages:
    62
    Clearly, no one at PARALLELS bothers to monitor this forum. I have the same issue. It only started in the last several months since going to Parallels 11. Prior to that, using Caffeinated allowed me to ignore the domain-enforced timeout and lock. Now, every time I lock my Mac (or it times out), not only does the Mac get locked but so does the VM.

    This is particularly annoying because it closes all network connections from the VM when this happens and I have to re-establish them. What a pain.
     
  10. Sasti@Parallels

    Sasti@Parallels Parallels Support

    Messages:
    278
    Hello Everyone,
    Try updating to the latest Parallels Desktop 11 build and also update the Parallels Tools. Let us know if there are any changes.
     
  11. RodB

    RodB Bit Poster

    Messages:
    62
    I see an update this morning. Let's see if this makes any difference...
    Nope, no difference, issue still exists in v11.2.0 (32581)
     
    Last edited: May 3, 2016
  12. RodB

    RodB Bit Poster

    Messages:
    62
    Just closing the loop: This is no longer an issue. A subsequent Parallels release resolved it. Now running v12.1.3 (41532) and not having this happen anymore.
     
  13. Raj@Parallels

    Raj@Parallels Guest

    Messages:
    467
    Great! Happy to hear that the issue is resolved. Please feel free to reach us anytime for support.
     

Share This Page