prl_disp_service

Discussion in 'Installation and Configuration' started by zkeith, Jan 5, 2009.

  1. zkeith

    zkeith

    Messages:
    18
    After upgrading to Parallels 4.0 a few days ago, I've begun to see the following screen image when I turn my machine on. Although I've seen reference to "prl_disp_service" in a few of the threads in this forum, none of them seem to reflect my situation. I suspect something needs to be tweaked.
     

    Attached Files:

  2. John@Parallels

    John@Parallels

    Messages:
    6,450
  3. zkeith

    zkeith

    Messages:
    18
    John's suggestion that I upgrade to the new build didn't solve my problem with the prl_disp_service message I get when I turn my computer on.
     
  4. zkeith

    zkeith

    Messages:
    18
    I believe I fixed my problem. I had the firewall setting in Kaspersky set too high. I moved the setting back to the "Training" level, which seems to be the solution. I know that I set it to a higher level than "Training" about the same time I began seeing the message.
     
  5. DaneC

    DaneC

    Messages:
    10
    I get the identical error message regarding prl_disp_service each time I reboot. If I do a reinstall (4.0.3846) it works until I reboot and then it reappears and prevents me from accessing XP. I also looked a the service and I can see it has 162 ports assigned to it. Thank God for booth camp, I had Fusion before, parallel is better, but issues are so frequent that the next time it works perfectly for me I will not upgrade until it stops working.
     
  6. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Please try to repair permissions. prl_disp_service is a launchd daemon and sometimes system refuses to load launchdaemons when /Library/LaunchDaemons directory has incorrect permissions - btw, it affects all Mac OS
     
  7. zkeith

    zkeith

    Messages:
    18
    DaneC, I don't get this message very often any more, but I did for a few logons after I installed the lastest version of Parallels. My problem seemed to be solved mostly by lowering security in Kaspersky. However, that may just be a coincidence. I do really like Parallels and don't want to go back to Bootcamp because of having to switch back and forth between operating systems. Because this seems to be an ongoing problem with Parallels, it seems to me that it would be prudent for the Parallels engineers to fix the problem so some of us don't continue to get bugged by it. I agree with your statement about not upgrading to newer versions of programs. I will continue to use Windows XP on my virtual machine as I don't want to go through what I understand is a very difficult process of totally uninstalling Windows XP before installing Windows 7. Likewise, I decided not to upgrade to Snow Leopard because if something breaks I would have no idea whether the problem is caused by Leopard, Windows XP, or Parallels.
     
  8. DaneC

    DaneC

    Messages:
    10
    Well, repairing permissions did not work for me, here is what I saw when repairing permissions.

    (1.)
    Repairing permissions for Macintosh HD
    Permissions differ on "private/etc/postfix/main.cf.default", should be -rw-r--r-- , they are -rw-rw-rw- .
    Repaired "private/etc/postfix/main.cf.default".
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    Permissions differ on "System/Library/Keychains/X509Anchors", should be -rw-r--r-- , they are -rw-rw-rw- .
    Repaired "System/Library/Keychains/X509Anchors".

    Launch Parallels Desktop, "Make sure that prl_disp_service is running or check your firewall settings..."

    (2.)
    Repairing permissions for Macintosh HD
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    Permissions repair complete

    Reinstalled Parallels 4.0.3846 and uninstalled Kaspersky Internet Security. Reboot same error message.
     
  9. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Hm... investigation is going to be tough.. I need several information: please start /Application/Utilities/Terminal and execute in it next commands (all without quotes), then post here their output

    1) "sudo launchctl list | grep prl"

    2) "ls -al /Library/LaunchDaemons/"

    3) "ls -al /Library/DiagnosticReports"
     
    Last edited: Sep 11, 2009
  10. DaneC

    DaneC

    Messages:
    10
    Here are the results from Terminal generated in the same order as requested (1, 2 & 3):
    Last login: Fri Sep 11 19:07:42 on console
    dane-chungs-imac:~ danechung$ sudo launchctl list | grep prl

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information

    133 - 0x100417550.anonymous.prl_disp_service
    120 - com.parallels.vm.prl_naptd

    dane-chungs-imac:~ danechung$ ls -al /Library/LaunchDaemons/
    total 16
    drwxr-xr-x 4 root wheel 136 10 Sep 23:08 .
    drwxrwxr-t+ 62 root admin 2108 10 Sep 23:08 ..
    -rwxrwxrwx 1 root wheel 471 1 Feb 2007 com.hp.lightscribe.plist
    -rw-r--r-- 1 root wheel 567 29 Aug 09:45 com.parallels.desktop.launchdaemon.plist

    dane-chungs-imac:~ danechung$ ls -al /Library/DiagnosticReports
    ls: /Library/DiagnosticReports: No such file or directory
    dane-chungs-imac:~ danechung$
     
  11. DaneC

    DaneC

    Messages:
    10
    Make sure the prl_disp_service is running...

    I have discovered that Parallels Desktop works fine if I do a shutdown, wait a 2 minutes and power on the mac.
    After using Parallels I shut it down and if for any reason I need to restart the mac then I encounter the message, "Make sure the prl_disp_service is running...". So the work around is to shutdown the mac, wait a few minutes and power it on. Only then am I able to launch Parallels Desktop.
     
  12. DaneC

    DaneC

    Messages:
    10
    prl_disp_service it works!!!- Uninstall, reinstall kaspersky, shutdown, power up.

    Well the only thing I did differently was to uninstall Parallels Internet Security by kaspersky and I reinstalled it and guess what it works regardless of whether I restart, reboot or logout.
     
  13. Elric

    Elric Parallels Developers

    Messages:
    1,667
    It's great -) I'd very appreciate if you could click PD menu Help->"Report a Problem" and send a problem report (just without any description and it is not necessary to have any VM running) and then post here the report number. The report contains logs and I hope to find the root of the problem
     
  14. CarstenB

    CarstenB

    Messages:
    7
    here the terminal output

    ls: /Library/DiagnosticReports: No such file or directory

    best regards
    carsten
     
  15. CarstenB

    CarstenB

    Messages:
    7
    next in que - i have the same problem with this service :-(

    hi folks
    so here is my story to this:
    i updated all my soft to the newest versions and since then parallels 4.0 does not start any more. everytime i try to start i get the infobox telling me

    "Make sure that prl_disp_service is running or check your firewall settings. If the problem persists, contact the Parallels support team for assistance." now i call you out htere for assistance.

    situation:
    i use little snitch version 2.2.b1 - and shut it down before i started parallels -> same error
    i allowded all incoming connections within the mac osx firewall (systemtray)
    tryed to start the service as recomended:
    sudo /Library/Parallels/Parallels\ Service.app/Contents/MacOS/prl_disp_service -e --logfile /var/log/prl_disp_service_server.log --pidfile /var/run/prl_disp_service.pid &

    the answer in terminal is:
    WARNING: QApplication was not created in the main() thread.
    i didn´t find a solution in this forum for this behaviour.

    i´m not able to send a bugreport out of the textbox showing me the error.

    i uninstalled several times parallels and reinstalled it but same behaviour.

    the cracy thing about that is that it worked well just before i upgraded the soft on my mac. i use osx 1.5.8

    after that i started a thread in the forum and got the tip to repair permissions - it tid this several times but the behaviour of parallels did not change. i cleaned all caches and run the unix daly, weekly and monthly scripts with onyx
    to ensure everything is up t date.

    after that eric from parallels forum told me to do some tasks within terminal:
    so i did this:

    1.) >>> sudo launchctl list | grep prl
    Password:
    207 - com.parallels.vm.prl_naptd

    [3]+ Stopped sudo /Library/Parallels/Parallels\ Service.app/Contents/MacOS/prl_disp_service -e --logfile /var/log/prl_disp_service_server.log --pidfile /var/run/prl_disp_service.pid


    2.)>>> ls -al /Library/LaunchDaemons/
    total 48
    drwxr-xr-x 8 root wheel 272 12 Sep 07:52 .
    drwxrwxr-t+ 65 root admin 2210 2 Sep 09:32 ..
    -r--r--r-- 1 root wheel 573 31 Aug 00:02 at.obdev.littlesnitchd.plist
    -rw-r--r-- 1 root wheel 567 29 Aug 15:45 com.parallels.desktop.launchdaemon.plist
    -rw-r--r-- 1 root wheel 621 20 Mär 2008 com.rogueamoeba.hermes.plist
    -r--r--r--@ 1 root wheel 499 21 Aug 16:47 com.synium.cleanappdaemon.plist
    -rw-r--r-- 1 root wheel 520 19 Apr 2008 com.vmware.launchd.vmware.plist
    -rwxr-xr-x 1 root wheel 724 3 Sep 19:35 net.decimus.synk.synkd.plist

    3.>>>ls -al /Library/DiagnosticReport
    ls: /Library/DiagnosticReport: No such file or directory

    again i stopped little snitch and tryed to start parallels nothing did change :-(

    any more suggestions on this ?

    i´m not a unix geek so i hope there is somebody out ther who can help me get it up to work again.
    thanks in advance !
    carsten
     
  16. DaneC

    DaneC

    Messages:
    10
    Make sure the prl_disp_service is running...

    Report id 513591
     
  17. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Ok.. Please reboot the Mac if you have not it rebooted after this command (actually, reboot is not required, but sequence of commands is too complicated to describe).

    Then start the terminal again and issue in it next commands
    1) ps aux | grep prl_disp
    2) "sudo launchctl load /Library/LaunchDaemons/com.parallels.desktop.launchdaemon.plist"
    3) sleep 1 && ps aux | grep prl_disp

    (please post here the output)

    then try to start Parallels Desktop again. If it doesn't start, I believe you should create a support ticket at http://www.parallels.com/support/desktop/request/
    but most likely it is really some firewall issue... please attach to the ticket files /var/log/system.log and /Library/Logs/parallels.log

    And.. post here the ticket number (if it is not a firewall problem, these logs will be sent to development team)
     
  18. DaneC

    DaneC

    Messages:
    10
    I realized that the target of the report, the log files are restricted to system and admin which means the last log files I sent you were probably missing. After installing Parallels Internet Security by Kaspersky I also experienced a Kernel Panic. Needless to say I am thinking of uninstalling it and going back to NOD32 unless you can recommend something better. I have sent you new log files under report id 514228
     
  19. CarstenB

    CarstenB

    Messages:
    7
    ok here is the output

    thanks eric again for your time and help !

    here is the output:

    1.) ps aux | grep prl_disp

    carstenbock 540 0.9 0,0 599828 500 s000 S+ 6:20pm 0:00.00 grep prl_disp

    2.) sudo launchctl load /Library/LaunchDaemons/com.parallels.desktop.launchdaemon.plist
    Password:
    com.parallels.desktop.launchdaemon: Already loaded

    3.)sleep 1 && ps aux | grep prl_disp
    carstenbock 709 0.0 0,0 599828 500 s000 R+ 6:26pm 0:00.00 grep prl_disp

    but still it cant start :-((

    ok now i try to post as mentioned the support ticket..

    sunny days to you out there
    carsten
     
  20. CarstenB

    CarstenB

    Messages:
    7
    here is the ticket number

    here is the ticketnumer:
    774656

    and here is the parallels.log

    * 12-09-2009
    * 18:16:01.223
    *
    * Operating System Macintosh
    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    18:16:01.223 F /disp:330:B0081000/ Execute mode is DESKTOP.
    18:16:01.558 F /CAuth:330:B0081000/ stat64() has returned error: No such file or directory, /Users/Shared/Parallels
    18:16:01.594 F /CAuth:330:B0081000/ stat64() has returned error: No such file or directory, /Users/Shared/Parallels
    18:16:01.643 F /CAuth:330:B0081000/ stat64() has returned error: No such file or directory, /Users/Shared/Parallels
    18:16:01.713 F /cmn_utils:330:B0081000/ CreateDirectoryPath() return error for path='/Users/Shared/Parallels'
    18:16:01.824 F /disp:330:B0081000/ Can't create Parallels directory /Users/Shared/Parallels
    18:16:01.906 F /disp:330:B0081000/ Can't create parallels vm directory /Users/Shared/Parallels
    18:16:03.571 F /disp:330:B0081000/ Stop of VMs. Please wait...
    18:16:45.201 F /gui:364:A0399720/ SDK Process is warming up
    18:16:46.505 F /IOCommunication:364:B0207000/ IO client error (sender 3): Can't connect to socket (native error: Connection refused [errno: 61])
    18:16:46.809 F /pvecontrol:364:B0081000/ Can't connect to dispatcher!
    18:16:46.903 F /gui:364:A0399720/ GUI Process is warming up
    18:16:54.361 F /gui:364:A0399720/ AHRegisterHelpBook failed with err == -50
    18:17:18.822 F /gui:364:A0399720/ Creating Mac menu bar...
    18:17:23.437 F /gui:364:A0399720/ Destructing application object
    18:17:24.271 F /gui:364:A0399720/ finished
    18:27:44.332 F /cmn_utils:720:A0399720/ ParallelsDirs::Init( ) was called. Current app mode = 1
    18:27:44.374 I SGAC/gui:720:A0399720/ Process Serial Number: {0, 245820}
    18:27:44.374 I SGAC/gui:720:A0399720/ Initialized: Shared Guest Applications dispatcher
    18:27:50.955 F /gui:720:A0399720/ Creating Mac menu bar...
    18:27:50.960 F /gui:720:A0399720/ RLIMIT_NOFILE changed to maximum: 4294967295
    18:27:50.961 I CPTOOL /gui:720:A0399720/ {init @ CPInit.cpp:34} CPInit initialization...
    18:27:50.961 I CPTOOL /gui:720:A0399720/ {init @ CPInit.cpp:51} CPInterceptor::Initialize returns 1
    18:27:50.962 I CPTOOL /gui:720:A0399720/ {init @ CPInit.cpp:55} CPInterceptor::Start returns 1
    18:27:51.004 F /gui:720:A0399720/ Patching Preferences menu...
    18:27:51.004 F /gui:720:A0399720/ Patching Quit menu...
    18:27:51.031 F /gui:720:A0399720/ localhost status: connecting
    18:27:51.061 F /gui:720:A0399720/ Patching About menu...
    18:27:51.091 F /IOCommunication:720:B02B2000/ IO client error (sender 3): Can't connect to socket (native error: Connection refused [errno: 61])
    18:27:51.191 F /pvecontrol:720:B00A1000/ Can't connect to dispatcher!
    18:27:51.202 F /gui:720:A0399720/ localhost: received result for [DspCmdUserLogin]. RC = [PRL_ERR_CANT_CONNECT_TO_DISPATCHER]
    18:27:51.272 F /gui:720:A0399720/ Showing message box. Type = [Question, PRL_ERR_CANT_CONNECT_TO_DISPATCHER]. Id =
    18:27:54.904 F /Std:720:A0399720/ Unknown PRL_RESULT code 0x2
    18:27:54.904 F /gui:720:A0399720/ Sending answer to server. The answer is Unknown. Issuer id =
    18:27:54.906 F /gui:720:A0399720/ localhost: sending [DspCmdVmAnswer] request...
    18:27:54.909 F /gui:720:A0399720/ The message box is closed.
    18:27:54.909 F /gui:720:A0399720/ localhost status: disconnected
    18:27:54.910 F /gui:720:A0399720/ Application is about to quit. Now we need to check all the windows and ask user if he wants to cancel exit.
    18:27:54.910 F /gui:720:A0399720/ Exiting application...
    18:27:54.911 F /gui:720:A0399720/ Application is about to quit. Cleaning up...
    18:27:54.915 I CPTOOL /gui:720:A0399720/ {deinit @ CPInit.cpp:67} CPInit deinitialization...
    18:27:54.915 I SGAC/gui:720:A0399720/ Deinitializing: Shared Guest Applications dispatcher
    18:27:54.916 I SGAC/gui:720:A0399720/ Deinitialized: Shared Guest Applications dispatcher
    18:27:54.917 F /gui:720:A0399720/ localhost: received result for [DspCmdVmAnswer]. RC = [PRL_ERR_NOT_CONNECTED_TO_DISPATCHER]
    18:27:54.921 F /gui:720:A0399720/ Destructing server object 0x1c48c80...
    18:27:54.921 F /gui:720:A0399720/ Destructing application object

    my system.log is about 44500 lines long. which of them are interesting to you ? can i sent this via attachment ?
    cheers
    carsten
     

Share This Page