Problem with using USB memory sticks in Linux guest

Discussion in 'Linux Guest OS Discussion' started by ulit, Jun 19, 2007.

  1. ulit


    Hi all,

    I've this problem since my start with Parallels with the 2.5 version and I tried already 3.0 with build 4124 and 4128:

    If I attach an USB memory stick (I have tried several different ones), the following messages are logged either in /var/log/messages or dmesg.

    usb 1-1: new high speed USB device using ehci_hcd and address 2
    usb 1-1: device not accepting address 2, error -110

    The message with those two lines repeats with several different addresses; the result is that I cannot access the USB device.
    This happens both with the current Knoppix CD and also a current Gentoo installation; host is an iMac Intel, 24".

    Do other people also observe this?

  2. kahm


    I've seen the same issue. Build 3188, Kubuntu 7.04 guest. OSX 10.4.8, Macbook Core 2 duo 2ghz.

    It officially is driving me nuts :(
  3. notarus


    I figured out how to make this work (in knoppix, anyway). I believe the key is you need to hand the kernel the irqpoll setting at boot time for this to work.

    I'm runnning Parallels 3.0, and 10.4.10

    My method was this:

    1. Create a new vm, point it at a knoppix cd.
    2. Edit the USB controller settings and make sure it is NOT autocapturing devices
    3. WITHOUT Parallels running, insert the usb stick.
    4. Open the finder. If the usb stick is mounted, unmount it. This wont work with it mounted.
    5. Start your VM. At the knoppix prompt, enter knoppix irqpoll. You can add other settings, like lang=us 2, whatever.
    6. Let it boot
    7. Now, pull down the devices menu, go to the usb sub menu, and capture your memory stick
    8. Wait. Linux will auto discover the stick. it will throw out some errors about irq9 being ignored, and then capture the stick as a scsi device
    9. Now you can use it as you want.

    Without "irqpoll", it'll give you the above errors, or in rare cases, it'll even manage to detect the drive and allocate a scsi entry, but it won't work.
  4. somebox


    Same problem with Debian Linux, irqpoll doesn't help

    Under Parallels Desktop 3.0 with a fresh Debian 4.0 install, the same problems occur with a Sandisk Cruiser Micro USB key. I see:

    usb 2-1: new high speed USB device using ehci_hcd and address 2
    usb 2-1: configuration #1 choses from 1 choice
    SCSI subsystem initialized
    Initializing USB Mass Storage driver...
    scsi0: SCSI emulation for Mass Storage devices
    usbcore: registered new driver usb-storage
    USB Mass Storage support registered.
    usb-storage: device found at 2
    usb-storage: waiting for device to settle before scanning
      Vendor: SanDisk    Model: U3 Cruzer Micro    Rev: 3.21
      Type:   Direct-Access                             ANSI SCSI revision: 02
    sda: Mode Sense: 03 00 00 00
    sda: assuming drive cache: write through
     sda: sda1 sda2 sda3
    sd 0:0:0:0: attached scsi removable disk sda
    usb 2-1: reset high speed USB device using ehci_hcd and address 2
    sr 0:0:0:1: scsi: Device offlined - not ready after error recovery
    sr 0:0:0:1: rejecting I/O to offiline device
    Without the irqpoll setting on my kernel boot command line, I never get the key mounted, just lots of errors. With the irqpoll setting added, Linux tries to mount the USB key, and assigns it to sda, but as soon as I try to do something with it (like mount it, or list partitions with fdisk), it bails out with the last three messages above, repeated many times.

    I would love to see USB flash key support working better in Parallels... in my case, I wanted to create a grub boot disk for another machine I am working on, but alas, I have to burn a CD instead!
  5. DaveRensberger


    Does anyone know if Parallels plans to fix this? I've been debating whether to pay for Parallels 3.0 or defect to VMWare fusion. I like the idea of supporting a startup company, but VMWare is the de-facto standard for Virtualization, and they seem to be more committed to supporting Linux. This is so frustrating, because usb-storage devices used to work fine with Parallels.
  6. bruckwine


    So then how else can we transfer files from the host to the linux guest if USB isn't working??
  7. nobodyinparticular


    Samba share workaround works for USB-drives/sticks

    The workaround that does it for me is to Samba-share my MacintoshHD, specifically the folder /Volumes.
    That way whatever is plugged into the Mac can be accessed through the network tab.

    tested with macbook/parallels 3.0 4560/Feisty Fawn 7.04
  8. its1louder


    this usb problem is a pain. I am building an embedded system by popping the compact flash out of the embedded computer and developing on my dualcore laptop. The linux/GNU virtual machine has all the tools and horse power - except I cannot mount the compact flash disk in the USB-CF adapter. So I end up putting the usb reader on my older, slower desktop - which runs linux natively and has no trouble mounting the same CF card.

    The ability to do this sort of stuff, with parallels, is what made me buy my first mac this year. Disappointed it isn't working so well as I'd hoped. On the other hand, the windows engineering software (various CADs) has worked well in parallels.

    But I'd rather light a candle then curse your darkness. If you are just trying to swap files between macos and linux, you don't need the usb flash. I find FUSE to be a good way. Your kernel needs the fuse module loaded or compiled in. what I do is this:

    - start virtual linux in parallels
    - open OSX terminal and SSH into the virtual linux
    - make a mount point, I use /mnt/fuse
    - issue this command: sshfs /mnt/fuse
    the address is the address of my mac and /mnt/fuse is where I want to mount my mac's home directory. now if i "ls /mnt/fuse" I see Desktop, Pictures, Movies, etc - all my macos home directories.

    Hope this helps some but it doesn't solve the main problem. Don't want to hijack the thread too much.
  9. notserpe


    I'm a bit disappointed in seeing this thread as I bought desktop for mac back in October and suffered through the linux usb related issues. I just assumed it was fixed for 3.0 and upgraded tonight only to find the same problems.

    Running USB devices with IRQPOLL is a bit ridiculous anyhow.

    I'm going to ask for a refund considering I wanted to install gentoo onto a usb disk while being able to do other work and performance seems to be teh suck and my FC7 VM just bombed.
  10. jerzeeshadow


    Help! Can't use USB thumb drives in Ubuntu 7.04

    Having trouble with Ubuntu 7.04, 6.10, and 6.06 on Parallels Desktop. USB hard drives and thumb drives won't mount on Ubuntu's Desktop. I can't access them at all. My host machine's specs are: Mac Book Pro, 2.16 Ghz. Please help! :)
  11. Tuurlijk



    I have problems reading from USB memory sticks and using USB card readers / hubs from Debian Etch. I am currently using Parallels 3.0 (build 5160). The release prior to this was better, it could hold in a stick fine but would get confused by the USB card reader / hub. The current release bombs on both round about a minute after booting.

    Booting with irqpoll hangs my system (Debian and Ubuntu and Gentoo) almost right after boot. It just becomes unresponsive.

    I am running on a MacBook 2 GHz Intel Core 2 Duo, 2GB ram.

    The virtual machine is a Debian Etch with a 2.6 kernel.

    It says: kernel: [ 253.848000] Disabling IRQ #9 . . . after which CPU shoots up to 100%

    I have the same requirements as its1louder (see lower in this thread). I need to write to devices over USB directly. Mounting them over a Samba share is not good enough.

    The fact that the USB support for pen drives has 'broken' with the latest release makes me wonder if SWSoft is doing any regression testing before pushing a release. Or about the position of this USB functionality on their priority list (probably pretty low).

    I have just signed up as a beta tester: In the hope of getting access to something like .. . . . a bugtracker where I can post some more information on my problem. I have been unable to find a bugtracker for parallels.

    In the mean time have also installed a trial version of VmWare Fusion. It meets my requirements nicely.

    I would however still want to see this product I bought off of SWSoft start to work for me again. At least partly with USB sticks as it did up untill yesterday.

    This thread has been around for too long already!
  12. bledvina


    Same problem with Debian Edge

    Hi, I am experiencing the same problem as everyone else. I'm using the most up-to-date stable version of Debian 4.0 (Edge).

    I have been able to mount the a USB drive by doing the following (as root):

    1. rmmod uhci_hcd
    2. rmmod usbhid
    3. rmmod ehci_hcd
    4. modprobe ehci_hcd
    5. I then plug in the USB drive. I can see the contents, but the drive fails to be read from or written to successfully.

    This partial solution may suggest conflicts between USB 1 and USB 2 drivers in Linux when running on Parallels. Also note that the previous version of Debian 3.1 Sarge, worked flawlessly with USB drives.

    I am using Build 5160 of Parallels.

  13. ulit


    Looking back on my initial posting

    Hi all,

    I'm astonished that also the current Parallels release shows still these USB problems. My intended use of the USB ports is similar to its1louder; I would like to create filesystems on CF cards for embedded Linux devices.

    I'll try to point Parallels people to this thread -- and in parallel (hence the name ?!?) I'll evaluate the new VMware product.

    Best regards,

  14. Xenos

    Xenos Parallels Team

    Dear all,

    We are sorry for the troubles with USB devices. We have to admit that there is a number of issues that are nor fixed in the current PD version. Parallels developers are working hard to fix them in future versions. Our apologies...

    Best regards,
  15. tony.rogvall


    Memory sticks works in VmWare running Linux/ubuntu and that is exactly what I need.
    Looks great. No problems installing etc. If and when I get some support I may rethink, I still own a license...
  16. ksh


    any updates on this ?
  17. bitsent


    I, too, have been unable to mount any of my USB mass-storage devices. I'm running Ubuntu 7.10 on Parallels Desktop 5584. This is very frustrating.
  18. Xenos

    Xenos Parallels Team

    Hello all,

    Here is a workaround you can currently use to get access to USB devices in Linux VM:

    On Leopard, Fedora

    1. Connect the USB to your Mac;
    2. Open Mac System Preferences -> Sharing and choose Network Sharing from the list of services;
    3. Add the USB device and set the account;
    4. In Terminal (Applications -> Utilities) run this command: ifconfig - and remember the Mac IP address. You will find it in the "en0" section, "inet" line (for wired connection) or in the "en1" section, "inet" line (for wi-fi connection);
    5. Launch your VM and choose "Places" from the Guest OS menu bar, then click "Connect to Server";
    6. In "Connect to Server" window set "Windows share" as Service type and copy your Mac IP into the "Server" field, define the User name and the Name to use for connection, click "Connect" button. The USB device folder will get mounted on the Guest OS desktop;
    7. Open the mounted folder, click "Places" and Add the bookmark. This will let you to get access to the device quickly each time you need it.

    On Tiger, Fedora

    1. Connect the USB to your Mac;
    2. Open Mac System Preferences -> Sharing and enable Windows Sharing in the list of services. On Internet tab of the same window enable the network connection type that you use;
    3. In Terminal (Applications -> Utilities) run this command: ifconfig - and remember the Mac IP address. You will find it in the "en0" section, "inet" line (for wired connection) or in the "en1" section, "inet" line (for wi-fi connection);
    4. Launch your VM and perform the steps 5 - 7 described above.

    Best regards,
  19. Michael Carney

    Michael Carney

    Within this thread, the SAMBA solution is as good or better. I support Parallels because it does a lot of things right; at the present time however, USB is not one of them.
  20. dkennedy05


    it appears that this issue has been there since mid 2007, is there any planned release for fixing this? I just bought parallels and am completely disappointed that I can't get USB support. It may be in everyones best interest to switch to Fusion until Parallels decides to fix a almost year old bug.

Share This Page