Problems with VPN on Windows 10 ARM Apple M1

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by MateuszM3, May 5, 2021.

  1. MateuszM3

    MateuszM3 Bit Poster

    Messages:
    3
    Hi,
    I have switched from a MacBook Pro with Intel to MacBook Pro with M1 and start to regret that change...
    On Windows 10 ARM there is no chance to install Endpoint Check Point VPN nor FortiClient. Both of them doesn't work.
    But what is worse - I have set shared network on Parallels and while connect to VPN on MacOS, on the quest I could not connect to SAP system, because the address is not reached...
    Has anybody faced this problem? How to fix this problem?
     
    Alexandre9 likes this.
  2. PedroS7

    PedroS7 Bit Poster

    Messages:
    9
  3. MateuszM3

    MateuszM3 Bit Poster

    Messages:
    3
    Unfortunately this doesn't work with certificate I got from the company.
    When I am connected to the VPN on the host MacOS I got in netstat -nr
    destination gateway
    10.10.10.10. 175.168.188.1

    But on the guest Windows 10 ARM I could not ping 175.168.188.1, and do not have those destination/gateway combonation.
    What should I do to pass connection VPN gateway to Windows 10 and on Windows 10 access VPN network?
     
  4. BrentonB1

    BrentonB1 Bit Poster

    Messages:
    2
    Hey @MateuszM3 did you manage to get this working in the end? How did you get it working if you did?
     
  5. MateuszM3

    MateuszM3 Bit Poster

    Messages:
    3
    Hi @BrentonB1
    Unfortunately MacBook with M1 is useless for using with Windows. There is no point in having Pararells if you would like to use VPN, because on Windows for ARM I could not find any VPN that is working correctly.
    Even when you start VPN on MacOS connections from Endpoint and FortiClient are not passed to Windows.
    But when you manage to get it working please inform me, so maybe in some time I will not need to use a Windows laptop
     
    lee17 likes this.
  6. BrentonB1

    BrentonB1 Bit Poster

    Messages:
    2
    Hi @MateuszM3
    Sadly I had the same experience as you - I tried the X86 version of the Endpoint Checkpoint VPN as Windows can emulate X86 for the ARM processor, I just couldn't open any of the dialogs to setup anything. That's possibly an emulation issue, I'm not sure really?
    So I'm also using remote desktop to connect to a windows machine which is local, ok at the moment but not a solution if I travel.
    I'll make sure to come back to this thread if I find a solution.
     
  7. yihhowL

    yihhowL Bit Poster

    Messages:
    4
    I am facing the same issue, It seem like the Window on Parrales failed to install the Virtual Adapter.
     
  8. WillH7

    WillH7 Bit Poster

    Messages:
    13
    Did you try the Microsoft Store version of the CheckPoint Capsule VPN? This worked for me on the ARM version before my company switched to Palo Alto. I'm also able to use the Global Protect VPN client from Palo Alto in the Windows Store.

    Get Check Point Capsule VPN - Microsoft Store
     
  9. RobertoV7

    RobertoV7

    Messages:
    2
    Hi guys,

    I had the same issue. But I found a solution in my case it worked and I hope it can help you.

    - Go Microsoft Store
    - Find "Forticlient"
    - Click to Get it
    - Follow the steps to set up the VPN using Settings > Network > Add VPN
    - VPN Provider > FortiClient
     
    MikaelO1 likes this.
  10. himanshub2

    himanshub2 Bit Poster

    Messages:
    2
    Hi, I am facing the same issue. I am using openVPN connect on my mac but if I try to access SAP logon on windows 11 it doesn't work. it works fine on mac.
    I already tried FortiClient and Check Point Capsule VPN and none of them is working for me. Please help.
     
    Alexandre9 likes this.
  11. Alexandre9

    Alexandre9 Bit Poster

    Messages:
    1
    I have the same problem. Did you manage to resolve this error?
    No VPN is working, not FortClient, not Cisco Any Connect, not WatchGuard, not CheckPoint.
    I couldn't identify if the problem is with the VPN provider, Windows, Macbook, or Parallels.
     
  12. MikaelO1

    MikaelO1 Bit Poster

    Messages:
    6
    Could you give some more detailed steps on how you managed to get Forticlient working?
     

Share This Page