Publish Windows Server without AD join

Discussion in 'Parallels Remote Application Server' started by Hellau, Feb 12, 2024.

  1. Hellau

    Hellau Bit poster

    I want publish a RDP Connection to a Windows Server which is not member of the Domain (Active-Direcotry).

    The RAS Client (VDI / RAS ...) can intalled local without pushing through the RAS-Console.
    I can create an Domain\User to get Acces to the RAS Portal but then when I want to start the RDP Session to that Server I canĀ“t figure out how to get connection with different (Server\LocalUser) User Credentials.

    Is there any possibility like runas mtsc or any other idea for me?
  2. jpc

    jpc Pro

    RAS will use the same user name as the one that logged in. In general, the username can NOT be changed.
    However, there are a number of workarounds that you can try:
    1. Add a hop between the user and the machine: Publish an mstsc/rdp file which will be run on a domain-joined RDSH. This rdp file should be preconfigured to connect to the user you want to connect to. Alternatively, RAS Client with a standard RDP desktop connection shortcut on the desktop can be used for the same effect. This is a bit clunky though.
    2. If using the Windows client AND the server is accessible from the client machine, then a solution using 2XRemoteExec could be tried out. It is still a bit clunky though.
    3. You could try passing only the username (OR if needed, a username like this ".\username"). The RAS Server will need to be configured so that the option to "Force clients to use NetBIOS credentials" is disabled. If publishing a desktop, this should allow you to use the same username but a different actual user account. Publishing applications from such non-domain joined servers is a different story and probably NOT officially supported due to security restrictions for domain accounts.
  3. Hellau

    Hellau Bit poster

    The solution for me was to publishe a preconfigured rdp-file on the SessionHostServer. This is working fine.
    In the first time I tried to publish this rdp file from a different location (file-server) but thats not working - the way over the SessionHost (Terminalserver) is working as expected ... mabe thats also logically

Share This Page