Quickbooks cannot open company file on shared mac folder

Discussion in 'Windows Guest OS Discussion' started by jmpeeples, Jun 17, 2009.

  1. jmpeeples

    jmpeeples

    Messages:
    2
    Running:
    Parallels desktop v4.0 for Mac (Build 4.0.3844).
    Windows 7 (release candidate).
    Quickbooks 2009 Pro (R5) windows version running in VM, not a Mac program.

    Shared all all Mac disks with VM. Shared disk appears in windows explorer as "Host on '.psf' (W:)".

    When I try to open company file in my user directory of this shared disk Quickbooks gives me a warning window reading:

    Error: -6176, 0
    Quickbooks cannot get the network address of the server.

    Quickbooks obviously seems to think this is a mapped network drive on another PC.

    I have opened and used this same company file on this same pc using this exact same setup with one exception, running Windows Vista instead of Windows 7.

    Anyone have any idea why Quickbooks suddenly thinks this is a networked drive in Windows 7?

    Any clues or pointers would be appreciated.
     
  2. TapisVolant

    TapisVolant

    Messages:
    14
    I have exactly the same problem. Can anybody help please?
     
  3. TapisVolant

    TapisVolant

    Messages:
    14
  4. James Collard

    James Collard

    Messages:
    5
    Yep, I'm having the same problem. Only happens in Windows 7 through Parallels / VMWare. Only solution is to host the file within Windows but that is not what I want to do... But if this is a Windows 7 issue then can the Parallels team even do anything about it?
     
  5. TapisV

    TapisV Bit Poster

    Messages:
    8
    James, are you sure this is a windows 7 problem? Cause I also have Quicken and it has no problem connecting to my mac files and making backups there.
     
  6. DrKarl

    DrKarl Bit Poster

    Messages:
    63
    Just to confirm the same problem here. Quicken has no problems at all. QuickBooks, however, cannot use files on a shared Mac folder (Parallels share) with a Windows 7 VM. I'm in Parallels 5 at this point, and Snow Leopard 10.6.1

    I verified that this problem exists with Win 7 exists with QB Pro 2008 and QB Premier Accountant 2010.

    There is no problem at all with an XP Pro SP3 VM ... the QB data is accessed just fine from a shared Mac folder. So, no question in my mind after hours of trying all kinds of things that this is something related to Win 7, or the way Win 7 and Parallels sharing interact. (I did try turning off my firewall entirely in case something was up there, too.)

    My workaround for now, which might help others is less than ideal, but provides data safety:

    Quickbooks WILL create backups (qbb) on a network share, so:

    1. Copy the QB data files to your Windows VM Documents folder and access them there. QB runs fine locally.

    2. Set up QB backups so that a backup is saved to your network share (on the Mac side - so Time Machine will back it up) and that you are asked to backup every time you exit QB (set time to ask to '1'). Further, uncheck the option to append the time/date to the backup file - so that each backup will have the same name. This way, Time Machine will be able to consolidate weekly and monthly copies of the file. If each had its own name, then eventually every backup created every time you exit QB will end up on your TM drive.

    Exiting QB now will have the hassle of responding to prompts to do the backup, and a small (to large) delay while the file is created.

    Also, with this workaround, you will only have a backup on the mac side when you exit QB. So, if you are in QB all day entering 100's of transactions - there won't be a backup unless you manually create one. Because of this share glitch, Time Machine won't see your QB data-in-progress. So, if you have a heavy data entry/etc load, consider doing a manual backup once an hour or so, or quitting QB so that you're prompted for the backup.

    I have not run QB on a real Win 7 machine to know if this is truly Win 7, or if it is an issue with shared folders under Parallels with Win 7.

    Karl
     
  7. James Collard

    James Collard

    Messages:
    5
    Well, I'm going purely on the idea that it worked in Windows XP but not in Windows 7. That's about all I have really. Quicken is a different program so maybe the way it accesses and opens files is different to Quickbooks?
     
  8. James Collard

    James Collard

    Messages:
    5
    I stumbled across this on the VMware support files actually and thought it might relate to Parallels as well if someone can work out what to replace the hosts line with:

    http://www.vmware.com/support/fusion3/doc/releasenotes_fusion.html

    QuickBooks cannot save a company data file on a shared or mirrored folder.
    When you attempt to save a new company data file to a shared or mirrored folder, QuickBooks reports error -6176, 0 "QuickBooks cannot get the network address of the server". To have QuickBooks recognize the shared or mirrored folder as legitimate, you must add the folder to the hosts file.
    1. In the guest operating system, go to \Windows\System32\drivers\etc.
    2. Open the hosts file.
    3. Add the line 127.0.0.1 vmware-host and save.
    Note: This can sometimes create undesired behavior: opening a file in the guest instead of failing when shared folders are not functioning, or it can cause a login dialog to appear under some circumstances.
     
  9. TapisV

    TapisV Bit Poster

    Messages:
    8
    @JamesC
    Thanks, but I tried that and it didn't change anything. Let us know if it works for you.

    @DrKarl
    I am going to follow exactly your recommendations. Thanks!
     
  10. James Collard

    James Collard

    Messages:
    5
    Tapis - that line won't work as it is set for VMware not Parallels - if someone can work out which line to put in for Parallels instead then it may work.
     
  11. Any luck finding a solution for this short of keeping the Quickbooks files within the virtual machine hard drive? Just started using Windows 7 in Parallels and am having the same problem with Quickbooks Pro 2007.
     
  12. EEFranklin

    EEFranklin

    Messages:
    5
    I had the same issue and found a solution on Intuit's forum.

    In Windows, open C:\Windows\System32\drivers\etc\hosts in Notepad

    Add a line that matches the host (Mac) IP address, which can be found in 'System Preferences'->'Network' on your Mac. Depending on how your VM is using networking will determine which IP to use. I am using 'Shared Networking' (In Parallels->Devices->Network Adapter), so I use the IP from 'Parallels Shared Networking Adapter', in my case 10.211.55.2.

    My hosts file looks like this:
    It fixed the problem right away for me. If it doesn't also do Start->Run "ipconfig /flushdns"
     
  13. helixloop

    helixloop Bit Poster

    Messages:
    12
    Have same problem. Installed Parallels 5 with Windows XP and Windows 7. Running Quickbooks Pro 2009 on both. Data file is on Mac Snow Leopard, which both Windows OSs see as Z: .psf drive. Navigating there and opening the file from Quickbooks on XP - no problem. Doing the same on Windows 7 - getting Error: -6176, 0 QuickBooks cannot get network address of the server.
     
  14. helixloop

    helixloop Bit Poster

    Messages:
    12
    Put my post up, then saw EEFranklin's post. Tried it. Did not work for me. An I even have same IP on my Parallels Shared Networking Adapter that he did: 10.211.55.2. Put that in hosts file, flushed the DNS. Same problem. Thanks though EEFranklin for the post.
     
  15. RicardoB

    RicardoB

    Messages:
    1
    Just Hung up with QuickBooks Support and it works

    I just hung up with QB support, I am using a MacBook Pro with Win 7 and QuickBooks 2010. I was having the same error messages as stated above. Support had me save the files to QuickBook Folder that saves it Sample Company's since each time we tried to open them the file was found no problems. Since my knowledge is limited I will give each step we did. Go to Start, select Computer, select Local Disk (mine happens to be C:), select Users, Select Public, Select Public Documents, Select Intuit, select QuickBooks, Select Company Files and save your Company Files to that folder. This Folder should have a file by the name of QuickBooks Letter Templates already in but I dont think that matters, nothing more than a referance point. I saved my file to that folder and each time I opened my Company File, it worked fine. Hope it helps.
     
  16. helixloop

    helixloop Bit Poster

    Messages:
    12
    Thanks, RicardoB. The way I understand it though, Intuit had you save and access company file on Windows 7 "local" drive (C:\Intuit\Quickbooks\....). Doing that was never a problem for me. It is accessing the file from the network drive (.pst in this particular case which Parallels creates to allow Windows access Mac folders) that caused the above error.
     
  17. SunilD

    SunilD

    Messages:
    1
    OK this is what I discovered yesterday. You could download a network diagnostic tool from intuit that will tell you exactly what the problem is.

    http://support.quickbooks.intuit.com/support/networking/nettool.aspx

    In my case there were two issues.

    1. Quickbooks is using a couple of ports and the firewall could be blocking those ports. The tool will identify this and give you an option to open this ports form tool itself.

    2. One of the previous posters mentioned a host definition. That is the other problem. In your host file you have to define a new entry.

    First go to Mac System Preferences -> Network and find out the host IP address.
    Second from your Network Diagnostics tool Check "Change Hosting Server" Click on the button with "...". It will pop up a Host name selection window keep drilling down until you find your shared drive name in one of those nodes. Copy that exact name and add it to the host file with IP address as described in the previous post. Once you do this you should be able to open your company file from the computer where you have properly defined the host and opened up the ports even though the file is stored on a drive connected to an ethernet port of a Wireless Hub or on a networked machine.
     
  18. helixloop

    helixloop Bit Poster

    Messages:
    12
    Thanks, SuniID. Downloaded the Network Diagnostic tool, run it and clicked Open Ports, which completed successfully. Using Change Hosting Server and clicking "..." button I see host ".pst" listed, which is not expandable. Putting .pst in the hosts file with my iMac IP did not resolve the problem.

    Another thing I tried was under Test Connectivity section is browsing directly to my Company File (which works just fine ironically using W7 file explorer), and hitting Test Connectivity. What I got back was:

    IP Reverse Lookup Status: Success
    DB Service Status: Not Reachable
    QB Port Service Status: Not Reachable
    Company File Directory Accessible: Readable/Writable
    File Open Status: File Open Failed (-6177)
     
  19. SandiG

    SandiG

    Messages:
    1
    I'm having the same issue. Have tried to update the etc/hosts file but that doesn't work. Not sure I'm using the correct IP address for .psf. Can anyone tell me how to find it? Not seeing it when I look under Parallels network adapter settings.

    Also tried the QB diagnostics tool. Can't find my .psf folder.
     
  20. PoloL

    PoloL

    Messages:
    1
    Files on Mac

    You are not the only ones having this problem. It does not have to do with the way you have setup your network. It is the way that Quickbooks handles the files. Mac has a unix system and it protects the files every time they are copied to any folder it does not matter where it is copied. Quickbooks some how when the program is launched it creates a copy locally so you can work on the file copied back to the Mac computer. Since this file is recreated, Mac will protect the file and it will only have read only permission and therefore can not write back to the file and give you an error.
     

Share This Page