RAM Issues

Discussion in 'Installation and Configuration' started by Adi_Kerr, Dec 18, 2007.

  1. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Mark,

    How much memory is allocated to Parallels in Parallels Desktop -> Preferences -> Memory?
    Try increasing this value and reducing the VM RAM in Configuration Editor.

    Best regards,
    Xenos
     
  2. dweichelt

    dweichelt

    Messages:
    2
    Try this...

    Here I have the same issue on my MacPro with 16 GB RAM (OSX 10.5.2).

    I created a new VM with custom Details. At the point where you can chosse the HDD-options I used an existing HDD-File (the file of my existing VM) Now my VM is running with 2 GB RAM again and not only with 1 GB RAM.
     
  3. Inability to allocate RAM related to MAC system's HD size?

    I've recently encountered this precise issue, but in my case it occurred only after switching from a 750GB system drive on the Mac to a 1TB drive. I'm wondering if there is a connection.

    I have a first generation MacPro running a pair of dual core processors and 10GB of RAM. I have been happily running WinXP under Parallels (build 5584) with 2GB of RAM allocated to the VM for a very long time.

    On Tuesday I cloned the prior 750GB system disk in the MacPro to a new 1TB disk, then swapped the drives and booted from the new 1TB disk. Although everything else was fine, Parallels would not start the VM, complaining about an inability to allocate enough RAM. The suggested pre-allocation setting was already in place. Booting from the old 750GB system disk allowed the VM to open. Reducing the RAM allocated to the VM to 1024 allows it to open on the larger system disk, which is how I am currently running.

    Could there be a connection? It certainly seems so...

    Thanks...Bob
     
  4. K-Dee

    K-Dee Bit Poster

    Messages:
    53
    I think there is. I just cloned a hard disk on my Macbook Pro and got the same issue with my Vista VM which has 1.25GB allocated to it. Dropping it to 1GB made it work. I am in the process of reformatting the drive to "Case Sensitive" and cloning the data over to it (as per the suggestion of gialom earlier in this thread) to see if that works.
     
  5. K-Dee

    K-Dee Bit Poster

    Messages:
    53
    I just confirmed the following:

    - Cloning the hard drive causes the issue. (as the old HD doesn't have this problem because booting off of that drive allows the VM's to run with > 1024MB of RAM)
    - Setting the VM to 1024 or less allows it to boot.

    I tried to format it with MacOS Extended Journaled (Case Sensitive) and it didn't make a difference. But I should note that the old HD was formatted for MacOS Extended Journaled. So I'm not sure if that mattered in the first place.

    Everything else on the drive works so this is clearly a Parallels issue.

    If it matters, I'm running build 5600 (which was working fine prior to this).

    Oh yeah. I also did an uninstall (with the deletion of any files that may be in the library and system folders) too and that didn't work.
     
    Last edited: May 12, 2008
  6. initiators

    initiators

    Messages:
    1
    Same problem for me.

    I'm using version 2.5 build 3224 on a Macbook with 2 GB RAM and Leopard with all patches. After changing HDD for a bigger one (used Carbon Copy Cloner 3.1 to clone the old drive) Windows XP Pro won't start with 1024 MB. It starts with 1000 though.
     
  7. K-Dee

    K-Dee Bit Poster

    Messages:
    53
  8. Tanker10a

    Tanker10a

    Messages:
    15
    Memory Allocation Errors

    I have two Macs: one MBPro and a MacPro. I have Parallels installed on both Macs. The MacPro is running Parallels using Leopard 10.5.3 (latest OS X update) with no problem.
    The MB Pro on the other hand has given the same problem twice. I have downgraded to 10.5.2, installed all the patches and I have deliberately avoided the installation of the Security Patch every I get prompted for an update. Here I am again with the same problem. I have checked and unchecked the "Use secure virtual memory"
    from the Systems Preferences/Security/General because I was told that might make a difference but to no avail.
    So I have to rebuild the MB Pro all over again because there is no other way to restore Parallels.
    Dammm I HATE WINDOWS!
     
  9. John@Parallels

    John@Parallels

    Messages:
    6,343
    Did yo tried suggestions bellow
    1. Restart MAc, start Parallels Desktop and hold Apple key
    2. Parallels Desktop -Preferences - Memory change Adjust memory limit from automatically to manual and set to less than 1 gb
    3. Decrease Windows XP memory to less than 1 gb
     
  10. EdenM

    EdenM

    Messages:
    2
  11. EdenM

    EdenM

    Messages:
    2

Share This Page