RASClient no longer installs in Fedora 37

Discussion in 'Parallels Client for Linux' started by DavidP30, Jan 3, 2023.

  1. DavidP30

    DavidP30 Bit Poster

    Messages:
    3
    In the latest version of Fedora Linux (37), libusb has been changed to libusb-compat and so installing RASClient fails with the error:
    Error:
    Problem: conflicting requests
    - nothing provides libusb(x86-64) needed by rasclient_x64-19.1-23476.x86_64

    On my system, a search for installed libusb components reveals the following list:

    sudo dnf list installed | grep libusb*
    libusb-compat-0.1.x86_64 0.1.7-9.fc37 @fedora
    libusb1.x86_64 1.0.25-9.fc37 @anaconda
    libusbmuxd.x86_64 2.0.2-7.fc37 @anaconda
    libuser.x86_64 0.63-13.fc37 @anaconda
     
  2. jpc

    jpc Kilo Poster

    Messages:
    399
    Fedora 37 is not yet supported by the rpm package. The RAS client currently requires the old libusb package which was renamed to libusb-compat in Fedora 37.
    You can use the tarball if you want, but that will not install the required dependencies. Alternatively, you can change the rpm dependencies using rpmrebuild, change libusb(x86_64) with libusb-compat(x86_64) and install the resulting rpm.
    ref: https://linuxconfig.org/how-to-modify-an-rpm-package-using-rpmrebuild
     
    DavidP30 likes this.
  3. DavidP30

    DavidP30 Bit Poster

    Messages:
    3
    Many thanks. That's very useful.
     

Share This Page