RC2 = no DHCP ??

Discussion in 'Parallels Desktop for Mac' started by bmelnick, May 31, 2006.

  1. bmelnick

    bmelnick

    Messages:
    2
    Hi all,

    Installed RC2 today .. and now my bridged network support doesn't work with DHCP. I have to assign an IP address to the Guest OS (XP Pro SP2) in order to access my airport ....

    Things I've checked:
    1. Installed new version of Parallel Tools
    2. Made sure I'm using Bridged and Airport
    3. Made sure I have internet access through host (osx 10.4.6)
    4. Made sure I haven't changed any of my home network settings.

    Anybody else with same problems?

    Blue
     
  2. milomindrbindr

    milomindrbindr

    Messages:
    3
    same here. this was supposedly fixed in RC2, but alas is not working. Anyone else thinking these releases seem a little premature? Seems we go two steps ahead in one respect and three steps back in others.
     
    Last edited: May 31, 2006
  3. bmelnick

    bmelnick

    Messages:
    2
    Hi all,

    Ok ... tried uninstalling parallel tools, then parallels .... then reinstalling both ... still no dhcp support .... very disapointing seing as this has worked fine since at least Beta 3.

    Blue
     
  4. steve3

    steve3

    Messages:
    32
    Interestingly, my Win2K VM can get an address from my DHCP server over WiFi, and my WinXP can't.

    They're both Bridged Ethernet, default adapter.
     
  5. RickMaddy

    RickMaddy

    Messages:
    52
    I've never had a problem with DHCP and Bridged Ethernet under Win2K. I've seen many threads with issues under WinXP though. Strange. I think I will stick with Win2K.
     
  6. Jmdor

    Jmdor

    Messages:
    26
    I've got no problems with DHCP under XP Home. I did establish a MAC address that was entered into our router's filtering program.
     
  7. snit

    snit

    Messages:
    32
    DHCP has always worked for me, but has always freaked out on occasion, giving me 1-2 minute periods where I have no connectivity. Sometimes it happens quite frequently.

    The work-around I've been using since more or less day one is to use connection sharing, and tell Parallels to use the connection that isn't the main connection. The only problem with this solution is that if I go to a hotel where I have to plug in to the wired interface (happens often), then I have to reboot the VM to change the network interface. Honestly, you should be able to do this on-the-fly from the tool thingys in the bottom right corner!
     
  8. vamp07

    vamp07

    Messages:
    86
    RC2 appears to have fixed my DHCP problems.
     
  9. rjgebis

    rjgebis Kilo Poster

    Messages:
    186
    It works here in XP an linux. It does not work well in Solaris 10. In Solaris 10 I have to specify other than "Default Adapter" to make it work.
     
  10. Dubliner

    Dubliner

    Messages:
    1
    Airport works in XP

    Installed XP while Airport wasn't active. Later, when in Airport friendly zone, network didn't work. Closed XP, ensured network adaptor (Parallels) was set to Airport, booted XP, set XP network settings to LAN, and everything works. Excellent !
     
  11. jim_az

    jim_az

    Messages:
    5
    Just installed OpenBSD 3.9 as a guest on a MacBook. DHCP via AirPort doesn't recieve any IP address, but it works using the standard ethernet port...

    This is using RC2.

    Jim
     
  12. sdfjkl

    sdfjkl

    Messages:
    9
    DHCP (RC2 bridged, Airport, on a Macbook Pro) works in Windows guests (2003 SP1 and XP SP2) but not in Linux 2.6, NetBSD 3.0 or FreeBSD (FreeNAS) ones. Networking works fine with manually assigned addresses though.
     
  13. jim_az

    jim_az

    Messages:
    5
    Ok, I guess I'm just stupid. I didn't notice until now that in the configuration editor you have to specifically choose which network adapter to use in the VM for bridged networking (Airport or Ethernet). I guess my problem doesn't really exist - unfortunately my router just died on me so I can't verify this...

    Jim
     
  14. John Martinez

    John Martinez

    Messages:
    1
    FreeBSD doesn't work for me either

    I set it up with DHCP and my MacBook is on AirPort.

    I'll try the ethernet adapter next.

    It does work when I manually set the address withing FreeBSD, though.
     

Share This Page