Record Screen/Capture Area no sound was recorded at all

Discussion in 'Parallels Toolbox for Mac' started by Anthony17, Jan 10, 2022.

  1. Anthony17

    Anthony17 Bit Poster

    Messages:
    4
    Hi there,
    I tried to use your "record screen" feature and the experience was confusing...

    I restarted my iMac (running Catalina) after pressing 'Install' on "An additional sound driver is required..." dialog. I double checked and could see that "HAL" directory inside my "/Library/Audio/Plug-Ins" directory.

    However, after trying to record my screen, I didn't get any sound, which completely beat the purpose of it.

    I made sure I chose "computer" as the source of the sound, not microphone.

    Could you please look into this and advise how to get this sorted out?

    Thanks a lot,
    Anthony
     
  2. sergk

    sergk Parallels Developers

    Messages:
    520
    Hello,
    try this:
    - Remove "/Library/Audio/Plug-Ins/HAL/ParallelsToolboxAudio.driver"
    - Restart mac
    - Launch Record Screen tool again, chose 'Computer' audio source
    - Press 'Install' on dialogue about additional sound driver
    - Restart host
    - Try to record computer sound again.
     
  3. Anthony17

    Anthony17 Bit Poster

    Messages:
    4
    Thanks - may I ask what's the logic behind this?

    Are you suspecting that the driver is corrupted or something?
     
  4. sergk

    sergk Parallels Developers

    Messages:
    520
    These are steps to reinstall driver. It can help if somehow driver was not updated after switching between versions of Toolbox.

    If it doesn't help, check this:
    - Make sure that 'Computer' audio source is selected in preferences of Record Screen
    - Start screen recording
    - Open "System Preferences" application -> Sound -> Input
    - "Parallels Loopback" device should be selected. Also check that "output volume" is not zero and check that "Mute" checkbox is unchecked
     
  5. ShoebS

    ShoebS Bit Poster

    Messages:
    2
    HI I have the same issue , no audio while screen recording. I am using OS Monterey Ver 12.1.

    Appreciate your help.

    Thanks
     
  6. sergk

    sergk Parallels Developers

    Messages:
    520
    Hello,

    Please check this:
    - Make sure that 'Computer' audio source is selected in preferences of Record Screen
    - Start screen recording
    - Open "System Preferences" application -> Sound -> Input
    - "Parallels Loopback" device should be selected. Also check that "output volume" is not zero and check that "Mute" checkbox is unchecked
     
  7. ShoebS

    ShoebS Bit Poster

    Messages:
    2
    I cannot see Parallels Loopback under Sound Input. Please advise what should I do.
     

    Attached Files:

  8. sergk

    sergk Parallels Developers

    Messages:
    520
    You need to start screen recording to see "Parallels Loopback" device in the list.
     

Share This Page