Resolution Does NOT Resize when switching between Full-Screen and Window

Discussion in 'Parallels Desktop for Mac' started by nickm, Oct 14, 2006.

  1. nickm

    nickm

    Messages:
    3
    I've read the several threads in various forums that state that video resolution should change when switching to full-screen to the native resolution of the monitor (in my case an Apple Cinema Display 30") provided that the "Allow Change to Guest Screen Resolution" button is checked in Parallels Preferences.

    However, I cannot get mine to do it. I have checked, unchecked, started, restarted, etc etc, reinstalled Parallels Tools, nothing seems to fix the bug.

    In my case I have the Windowed resolution set to 1600x1200 and want Parallels to automatically switch to the full resolution of 2560x1600 when I switch to full-screen. It just doesn't do it.

    Anyone else having the issue? Anyone solve it?
     
  2. dhazeghi

    dhazeghi

    Messages:
    16
    I take it you can manually change it to something bigger than 1600x1200, right? That is to say the Parallels video drivers support the desired resolution in XP.

    You tried the tips in the other thread <http://forum.parallels.com/thread3516.html>?
     
  3. nickm

    nickm

    Messages:
    3
    Yes, I had tried the suggestions in the forum you mentioned (a few times, after restarting in between...).

    You are correct - I can change to the maximum resolution of the Apple 30" Display just fine in Windowed or Full-Screen mode. In Windowed mode, it'll hang off the screen a bit of course. In full-screen mode, it looks wonderful.

    The problem is that the Full-Screen resolution just doesn't stick after I go back to the Windowed mode and reduce the resolution a bit. The Full-Screen resolution is affected by whatever I change the Windowed mode resolution to.
     
  4. odin

    odin

    Messages:
    10
    Same exact problem here. I have had it work correctly on a MacBook Pro.

    I tried adding 2560 x 1600 as a custom resolution in Parallels Configuration - no effect.

    MacPro 2.66 / 3 GB / 30" Cinema HD
    Parallels 1940 / 10.4.8
     
  5. Pleiades

    Pleiades

    Messages:
    79
    Same here. It will work fine on a MacBook Pro but does not work on my 30" Cinema Display on my Mac Pro. I don't know if it's the 2560x1600 resolution or whether it has something to do with the Mac Pro.
     
  6. mcg

    mcg

    Messages:
    168
    I've reported this issue more than once. You would think that the Parallels folks would have acquired, or at least rented, a 30" display by now so they could check this out.

    Furthermore, 2560x1600 is limited to 16 bits/pixel. I see no reason why it need be so, but hey, I don't know the internal limits Parallels is forced to work with. But I do suspect that the issues are related.
     
  7. dbates

    dbates

    Messages:
    1
    I am also having this issue. Does Paralells have a solution yet?
     
  8. fmantek

    fmantek

    Messages:
    6
    That seems to be an issue specific to the 30'' screen. I just upgraded from a 24'' sony, running 1920x1200, where this was working fine, to the 30'' monitor, where it does not work anymore.

    Not something i worry about (i just run windows in 1900x1200 in a window) but certainly a bug that should get fixed.

    Frank
     
  9. Scott Willsey

    Scott Willsey

    Messages:
    174
    I can confirm that it also works as it is supposed to for me on my 24" Dell widescreen. It does indeed seem like a problem with 30" monitors (or more precisely, resolutions above 1920 x 1200).
     

Share This Page