** RESOLVED ** Mouse clicks not working in Windows 10. Win10/Parallels Pro/MacOS at latest versions

Discussion in 'Windows Guest OS Discussion' started by MarkC12, May 15, 2017.

  1. MarkC12

    MarkC12 Bit Poster

    Messages:
    5
    Hello,

    Versions: Windows 10, 1703/Build 15063.296. MacOS Sierra, 10.12.5, Parallels Pro 12.2.0 (41591).

    Lost ability today to get mouse clicks to work in the WIndows 10/Parallels VM. Mouse movement/trails work within Windows 10 window, but I cannot engage any icon, menu, focus, etc. left or right button. I was using a standard Logitech Bluetooth (dongle) type mouse, but also connected a USB wired mouse. Again, both mouses work just fine on the Apple OS, movement/clicks.
    I have tried in Parallels Host OS Configuration/Hardware:
    1. Reset Mouse: Optimize for games, Don't Optimize from Games -- no change
    2. REmove and re-add USB/Bluetooth -- no change
    3. Remove and reinstall Parallels tools -- no change
    I am continuing to try different things. Any other ideas you have or is this a known problem?
     
    Last edited: May 15, 2017
  2. Swati@Parallels

    Swati@Parallels Kilo Poster

    Messages:
    360
    Hello Mark, please try this article and keep us posted.
     
  3. MarkC12

    MarkC12 Bit Poster

    Messages:
    5
    I completed settings task as outlined in above post. Setting the flag "devices.usb.mouse=0" in advanced tab of hardware->boot order->Advanced, did NOT solve problem. No change. One other observation (either state, i.e. with flag set or not), see Device Manager output for mouse (notice error reported on second line):

    upload_2017-5-16_11-47-1.png
     
  4. MarkC12

    MarkC12 Bit Poster

    Messages:
    5
    Update. I created a TEST windows 10 environment as per: http://kb.parallels.com/122641 KB. I am able to use mouse as expected in this new test environment.

    Looking at the Windows 10 Device Manager in this TEST environment, it shows (notice there is no error on "Parallels Mouse Synchronization Device" entry):
    upload_2017-5-16_19-58-5.png

    FYI... In my normal Windows 10 environment, I have tried to delete all mouse entries, reboot W10 VM, they are recreated, but I get the same error showing in device manager (as in post above this one).

    Reminder: This was working fine. I have been using a Logitech wireless mouse (uses a USB dongle connected on Mac) -- no manual driver install. Works fine on Mac OS. I also removed this mouse and connected a wired USB mouse -- again, works on Mac as expected (movement/clicks), but not in the original W10 VM. Both mouses work in new W10 TEST VM now. I don't know what else I can do as the drivers in both W10 VMs show "Parallels ...." drivers, which I assume are installed with the Parallels Tools or something similiar -- net-net -- it is a Parallels driver to interface between the two OSes.

    Thoughts?
     
    Last edited: May 16, 2017
  5. MarkC12

    MarkC12 Bit Poster

    Messages:
    5
    ** RESOLVED **
    After doing some more digging on mouse click problems within W10, I came across this URL:
    https://answers.microsoft.com/en-us...se-after/1b860377-6c36-4b2b-a4dd-81b196e26f69

    Which basically pointed to this registry entry in W10:
    I was able to fix this problem by adding a missing MultiString value to this registry key (I compared the registry entry in the working TEST Win10 VM to the broken Win10 VM. This value WAS NOT in the broken W10 VM (try using a keyboard only to get through the regedit tool, APITA....). Anyway, added key to this registry in broken Win10 VM, restarted, and all is working!!!:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}
    Value Type: Multi String
    Value Name: UpperFilters
    Value: mouclass
    An article that explains it in a very round-about way is here:

    https://answers.microsoft.com/en-us...-code-10/326f7c0d-14cb-45c2-a705-32d3a2ab07d6
     
  6. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @MarkC12, thanks for the article. It helps a lot.
     
  7. PragmaticPraxis

    PragmaticPraxis Bit Poster

    Messages:
    73
    Hmm, was hoping this would solve the constant mouse click loss problem in Windows 7 too, but that value is already there on my Win7 VM that has lost mouse click capability 5 times now in less than an hour. Reboots work, for a time, but within 10 minutes mouse clicks are gone again. Very frustrating.
     
  8. ChrisM16

    ChrisM16 Bit Poster

    Messages:
    18
    Me too. There was a step-change for the worse with the penultimate version of 12, and since then I've not seen any action by Parallels, merely the straight-forward assumption that I can't configure a mouse...
     
  9. PragmaticPraxis

    PragmaticPraxis Bit Poster

    Messages:
    73
    I have to say, the level of support for a "pro" app is simply abysmal. As much as I hate to do it, I fear I am going to be switching to Windows in Bootcamp and Hyper-V for my virtualization needs. Parallels "Pro" is a damn joke.
     

Share This Page