[RESOLVED] Parallels Desktop 17.1.1. resolved a USB devices connectivity issue

Discussion in 'General Questions' started by Maria@Parallels, Nov 30, 2021.

?

USB connectivity issue

  1. Resolved in Parallels Desktop 17.1.1.

  2. Still have an issue

Results are only viewable after voting.
  1. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Parallels Desktop 17.1.1. resolved a USB devices connectivity issue.
    Please check the issue and post any results here.
     
    Last edited: Nov 30, 2021
  2. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    99
    Hello, what happens for me is this, I have a SanDisk 1 TB USB Stick attached, and it is configured to be attached to the VM. But whenever the VM is paused/shutdown or some other everyday action occurs, the drive is no longer connected to Windows. Sometimes it does not show up anywhere, and sometimes it shows up as a network drive because it is now attached to MacOS. In the menu bar, where one can add a check behind the attached usb device, the check mark does not always reflect the current situation. Usually what I do is I just click the usb drive in the menu once, wait, sometimes twice of three times (always waiting a bit) and at some point during that procedure it will re-attach to Windows. It is not a big problem, but I remember this used to be better in the past. It is not fixed with 17.1.1 I think.
    I am using Windows 11 release version, Big Sur latest relase, and latest Parallels, on M1 MB Air.
     
  3. AlbertN2

    AlbertN2 Bit Poster

    Messages:
    9
    I can confirm a similar checkmark discrepancy on the latest version when connecting a USB SpeechMike
     
  4. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    439
    Hello @MatthiasE5, please Provide the technical report ID By following the KB article http://kb.parallels.com/9058.
     
  5. JuiceD

    JuiceD Bit Poster

    Messages:
    25
    Just FYI what ever happened to USB in version 17 is still on going. Spent the past couple of days trying to figure out why the Pixhawk (https://pixhawk.org/products/) flight controller would no longer work in Win 7 or Win 10 instances in parallels. Its basically a USB Serial device that you then use in conjunction with a program called Mission Planner (https://ardupilot.org/planner/). For all purposes every thing looks like its working, windows can see the device, windows can load drivers, every thing is OK. But you can't actually -use- the device.

    Down graded to version 16 after days of research and coming across these "USB SOLVED ISSUES" in 17, worked first time. Works every time. Two different Macbooks of different builds, both with the same issue, resolved going to version 16.

    Also some feed back, your previous versions do really disgusting tactics to prevent a person from installing them, giving the user a big INSTALL VERSION 17 window with the only option of YES and no clear option of no I want 16 cause I downloaded 16 and I need 16 why are you telling me I can't install 16.

    1 out of 5 stars.
     
  6. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    439
    Hello @JuiceD , please upgrade to Parallels Desktop 17.1.1 and check the USB.
     
  7. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    439
    Hello @JuiceD, Is your issue resolved?
     
  8. ArinaM

    ArinaM

    Messages:
    1
    I'll take a note.
     
  9. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    439
    Hello @ArinaM, we are happy to help you. Please reach us back for any further queries.
     
  10. JuiceD

    JuiceD Bit Poster

    Messages:
    25
    Sorry for the late reply but yes was tested with 17.1.1 on two different models of Macbook and same issues. I'm staying on 16, I see no real point in going to 17 or any new version unless parallels ever conquers the virtualization nightmare of X86 on ARM. I'm in a pretty niche little world where I still need to emulate every OS that has ever existed and parallels and Mac OS covered that really well these past 10ish years. But going forward I'll most likely have to start migrating over to Linux on whatever hardware that has the least issues.
     
  11. JoachimV

    JoachimV Bit Poster

    Messages:
    20
    The USB problems with e.g. the SpeechMike are also NOT resolved. Please feed back to R&D.
    Last version working is 17.0.1.
     
    RoderickL and HC_3 like this.
  12. pip2

    pip2 Bit Poster

    Messages:
    3
    I still have a problem, MacOS12.1+ParallelsDesktop17.1.1, this is the ID 387879214 after I sent the technical data
     
  13. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Please help us with the USB model you are facing issue with. Kindly downgrade to Parallels Desktop version 17.0.1 here and let us know if still the issue persist.
     
  14. pip2

    pip2 Bit Poster

    Messages:
    3
    The version is good.
     
  15. JoachimV

    JoachimV Bit Poster

    Messages:
    20
    Here (and also for all other users of this device) the USB problems with the Philips SpeechMike not working correctly in neither recording, nor playback is still there with 17.1.1 as it was in 17.1.0.
    In version 17.0.1 things work.
     
    RoderickL likes this.
  16. pip2

    pip2 Bit Poster

    Messages:
    3
    Thank you for the reply. Do you plan to fix this in the new version?
     
  17. PreetiS3

    PreetiS3

    Messages:
    1
    He can we resolve the issue as philips SpeechMike is not working with me also, any information to help.
     
    RoderickL likes this.
  18. JoachimV

    JoachimV Bit Poster

    Messages:
    20
    At the moment there are two possible workarounds:
    1. Install the older V17.0.1 of Parallels software, this will make the Speechmike work with all features - but sound still is a bit choppy.

    2. The "ugly way"
    Connect the SpeechMike to the Mac, not to the VM. Open the Mac "Sound" preferences and there configure the SpeechMike as input device. Open Parallels and click the config symbol on your VM, go to Audio and Camera. There you now can select the SpeechMike for both microphone and sound output. With that the SpeechMike will work in the VM for in- and output and with really clear quality - BUT (and this is a big but) the buttons to start/pause/end recordings don't work.
    Maybe I'll get this to work with some special key mappings - still experimenting with that approach.
     
  19. thirdbasejoe

    thirdbasejoe Bit Poster

    Messages:
    4
    I am a custom integrator and I've got issues connecting to our URC (Universal Remote Control) products still, using their programming suite called Complete Control Program. The virtual machine (17.1.1 win 11) will see some usb devices but not these remotes... I've heard people say that the prior version of parallels (using win 10) worked well. Can I trade my license in for an older one? Any help is appreciated.

    M1 MacBook Pro macOS Monterey 12.1 ./ Parallels 17 / URC CCP thumbs down if you're thinking about doing this type of programming work.
     
  20. JoachimV

    JoachimV Bit Poster

    Messages:
    20
    You already tried the V17.0.1 build?
    https://download.parallels.com/desk...19.2147354111.1642014387-486170635.1640632829
     

Share This Page